[OBSOLETE] Lock User Management (LUM)

I have answered my last question with this link https://community.smartthings.com/t/faq-is-this-device-a-repeater/25626

Just installed the 7.12.0 build. Its working fine, however whenever I unlock the door with the code, I get a notification from SmartThings that the code x has unlocked the door. I didn’t set anywhere to enabled those, I think I found all the place to not send any notification but still it does… Is it supposed to and how do I turn it off. Thanks

That message sounds like it’s from from the ST Guest Locks app (not related to the LUM app, you can control notifications for each user in LUM). You will need to uninstall guest lock if you don’t want notifications from it (depending on where you installed it, Classic or new ST app).

So is something in LUM triggering it as it’s never done that before I put this app on. Getting it as well from classic app is that because I have the smart things lock manager on that integrates with SHM ?

That’s a good question @dpdurst, and I noticed that myself today. I use LUM to set codes for my keypad, but I can also see that name and code in ST’s Smart Lock Guest Access app. I can even change the name in ST’s app and it changes in LUM. I honestly don’t know if that was always there or not. Tagging @RBoy for clarification.

1 Like

Yes, that’s by design. LUM, RLA and Lock Manager API all try to keep the Names in sync with the Guest Lock/Smart Lock apps (the Classic and the new ST versions). However all code changes should only be done through the LUM/RLA/LMAPI apps.
There is a bug in the new ST app Guest Lock where it doesn’t always process the name correctly and sometimes shows as a generic Code X instead of the user’s name (the Classic smart locks app doesn’t have this issue). It’s been reported to ST and they’re aware of it.

1 Like

Ok so once LUM is installed, then the smartthings guest lock in the new app, and the classic st app will then start to send notifications?

Why? This defeats the purpose of having both. Just trying to understand why LUM triggers the default apps to start notifiying when they don’t when LUM is un-installed.

I have a bit of an odd question. When someone opens the door, my Sonos notifies “Front door has been unlocked by Tony via keypad” at volume 65, which is great! Just what I want. However, the Sonos volume after the announcement is set to zero. Is there somewhere I can tell it to go back to the previous volume before the notification?

To recap our PM conversation for the benefit of others: If you specify a volume in the notifications page then LUM will ask the device to restore its previous volume after playing the message.

Since it’s working for one of Sonos Playbase systems and not the other one, possibly doing a firmware upgrade or factory reset may help.

UPDATE: The ST staff member is looking into it, it appears to be an issue with some specific Sonos models. More details here.

I’ve just done a check for updates and the Sonos Playbase firmware is up to date. I guess this just isn’t working for me. Shame as I really wanted to use it too

For some strange reason my lock stopped locking automatically after 5 minutes. It has been working faithfully ever since I installed the lum & universal dth 3 years ago. I just updated my dth & lum is current
Have there been any issues that I have may missed?

@maddie can u help pleqse.

@all4dom having the same issues as of a few days ago. If I set LUM to re-lock immediately upon door close it works fine, but if I set a delay it never re-locks. I contacted @maddie via email, but haven’t found a resolution for it yet. I wonder if something changed on the Smartthings side of things? I looked in the event log in the IDE. I see the re-lock command being ‘scheduled’, but it never seems to execute.

Still troubleshooting. May just have to set it to lock immediately upon door close for now and hope this gets worked out eventually…

Try uninstalling the app & reinstalling. Maddie said it has something to do with Samsung platform outage other day. I called support but the girl had no clue. @Brad_ST can u help?

@RBoy @jody.albritton can you guys help? Since then last few days my door is not locking with a 5.min delay after closing. Does not even lock automatically after closing. Called support & they said it was roboys app & if I delete it I cant reinstall unless.on classic. I’m trying not to uninstall it because I have a ton of lock user codes for my daughters nurses & I have a free automations tied with the lock. Thanks.

Sounds like support is either unaware or misguided. The installation instructions link in the first post are for the new app.

I checked and re-lock is working here with a 2 minute delay on Schlage and Yale locks.

  • If you have multiple locks selected in the app, double check which door lock you’re setting the delay on.
  • If you’re seeing it schedule the re lock action in the logs and it doesn’t execute then likely the platform scheduler is dropping or not executing the command (this can happen if the platform is under heavy load or experiencing an outage)
  • If the platform is executing the command but the lock doesn’t re-lock then likely the command is being lost in the mesh.

Hi @RBoy & thanks for responding. I have a schlage lock & I have been using the new app since last year. This just happened a few days ago. Even some of my automations were acting up but they are working now. I am using the lock delay in the lum smart app & I’ll reboot my router & see if that works but my door is locking automatically after closing. Support was misguided to put it nicely.

Folks in general are seeing issues with automations and schedules across the platform for the past few days. More reports here.

I suspect some servers (shards) are impacted more than others; some folks are seeing issues while working for others.

I hope.they get this stuff fixed soon. It’s very annoying.

Multiple times a day I have been getting notifications that say: Lock User Management has detected a code upgrade… please open the app and save. Why am I getting this? Where do I open App. I have tried in IDE. New app and classic app none stop this message.