[OBSOLETE] Lock User Management (LUM)

I’m pretty sure that if you wipe out the names/codes, there is (first) no way to copy them or (second) to paste them back.

Hello @RBoy I’m new to ST and have just installed your Lock Code User Man app and the Universal Extended DH with our new Schlage BE469 with some success. Able to do most of the user code management I need to except the One Time Code. I can set the code, use the code and the code is then deleted. However, a few minutes later the same code is added again by ST. The app states "One time code USED! but I’m able to use it time and again. Have tried re-installing ST app but behaviour remains.

Any idea what’s going on ?

So, in effort to fully “clear” the configuration, I cleared the codes then reset to factory via lock-specific documentation (Schlage FE599). I excluded the lock then pulled batteries on everything then restarted. Re-included the lock, updated the Rboy device handler (Universal Enhanced…) and then the Rboy Smartapp (Lock Multi User Management…). The Smartapp proceeded to move through the formerly programmed slots and zero them out. I’ve not added any codes at this point.

I am getting an error on lock and one on unlock when using the ST app. Here they are, let me know if you would like the full sequence for context:

On Lock:
a00e3fa7-97c3-4b5c-82de-687e9012a1dc 3:24:12 PM: error groovy.lang.GroovyRuntimeException: Cannot compare java.util.ArrayList with value ‘[]’ and java.lang.Integer with value ‘0’ @ line 1255

On Unlock:
a00e3fa7-97c3-4b5c-82de-687e9012a1dc 3:25:09 PM: error org.codehaus.groovy.runtime.typehandling.GroovyCastException: Cannot cast object ‘[]’ with class ‘java.util.ArrayList’ to class ‘java.lang.Integer’ @ line 1073

Are these expected behavior in the lock’s current state of install? I want to make sure this configuration is airtight as I’ll be 200 miles away all summer with weekly renters needing reliable access!

I’m still having an issue where for some reason I am no longer receiving any notifications when a lock code is used. Everything worked great until May 8th. I’ve uninstalled both the SmartApp and the DeviceHandler and reinstalled the latest versions, 5.05.02 and 3.03.03, and that did not solve the problem.

Anybody else not getting notifications any longer?

Thank you for pointing this out, this issue was introduced accidentally during the last release while adding support for master code reporting. We have patched it this up immediately as it’s a critical fix and it’s been released into production. Please update to the latest code and let us know.

@kevinGS@ @Ron_Lu please update to 05.05.03 and see if your issues are resolved (just incase it was a side effect) as then this error was thrown the rest of the code doesn’t execute. With the above resolved it should be rock solid stable again.

##Critical Update for users on version 05.05.01 or 05.05.02

##door Lock Code Multi User Management with Notifications and Actions - Version 05.05.03

  • Fixed a bug which would cause lock/unlock actions to not execute under certain conditions

Recommend use the [Universal Enhanced Z-Wave Lock] ([RELEASE] Universal Enhanced Z-Wave Lock Driver for Schlage, Yale, Kwikset, IDLock, Popp, Danalock, August Pro, Keywe, Philia, Samsung) device handler version 03.03.00 or newer for full SmartApp and automatic update notification functionality

The updated code has not changed the absence of notifications for me, though perhaps I didn’t give it time to fully percolate through the system. Also note my other email re: the lock not being fully identified by ST - perhaps that makes mine a separate issue?

Unfortunately upgrading to 05.05.03 did not solve the issue for me. I still see the notifications for my lock codes being added and set, but I do not see any notifications when any of the codes are used.

Any other ideas?

Updated to 05.05.03 but unfortunately issue remains. One time code is added, used, burned by app but then re-addded a minute later by the app allowing the same code to be used multiple times.

Just me or a general issue ?

Just tried again after the system has had 7 hours to percolate. Still no notifications coming in on code use.
The only “Warn” lines in the log say “Unsupported device with MSR null”

I’m not sure “normal” volume of lines in the log,but 15min of monitoring creates pages and pages of “debug” and “trace” entries. These are probably the result of my having 30 programmable slots (19 of which are full).

Two of the 19 codes still don’t work, even though the app indicates they are active. The log seems to show a cycle of deleting each of the codes and users, but they are all “debug” and “trace,” not appearing to actually be sending anything to the hardware itself.

@RBoy - despite showing specific codes as active (“Permanent”), some of them will not work in the lock. In addition, I am unable to change any code, whether it is functioning at the lock or not - the app states that it updated successfully, but going back into the app shows the code remained the same. The lock continues to respond to the old code as if the change request was never sent.

In the logs, I continue to see “info” lines like this (sequentially through most of the codes):
8:34:31 AM: info Confirmed Nancy Logan user 16 was deleted from Universal Z-Wave Lock With Alarms

@dmccr you have an issue with your lock pairing.

Unsupported device with MSR null

This indicates that you lock didn’t pair properly with your hub. It’s a known issue with the recent ST hub firmware. See the thread on the Enhanced Z Wave lock. Once you fix this issue make sure you run the clear codes procedure on our website and everything should be fine.

I still see the notifications for my lock codes being added and set, but I do not see any notifications when any of the codes are used.

Are you using / have you enabled the contact address book feature for your account? It’s still a beta feature from ST and can cause random issues like you’re seeing. If you have that feature enabled, contact ST support to disable it.

The app is working fine exactly as it supposed to, it burns the code and disables it after a one time use.

The app states "One time code USED!

Note that when you open and SmartApp and if you click Done it WILL reset the one time codes and reprogram them. So if you’re just “checking” on the state of the code in the SmartApp after using it, do not click on Done as now you’re starting a new programming when you click Done.

Instead press back and come out of the app or set the code as inactive if you don’t want to use it again and then click Done.

Also make sure you’ve done the clear codes procedure the first time you install the device handler or SmartApp to clear the database before using the codes.

Sorry, but the app is not working fine for me.

I cleared the codes from the lock, reinstalled the app, set up a different (never previously used) code as a one time code which also cleared the codes from the lock. Tried the code - which worked - left it for 2 mins, tried it again, without touching my phone/app and it worked again, then again and so on. The one time code is behaving like a permanent code.

Any other ideas ?

This indicates that the lock is having communication issues with the hub, it isn’t deleting the codes after use. Try moving it closer to the hub and doing a Z-Wave repair (also reboot the hub which helps a lot!). It’s working without issue here across 10 locks from 4 different manufacturers. How many active Z-Wave devices do you have? A weak mesh can also play havoc with communication.

The SmartApp sends a delete command to the lock once the code is used. Look at your IDE Live Logs when you unlock the door using your one time code. Look for when the SmartApp sends the delete command check to see if lock acknowledged it (it will be in BLUE). If you don’t see the acknowledgement then that’s the indication of a mesh/communication issue.

Feel free to PM (copy paste) me your Live Logs and I’ll check it out for you. Please filter the messages by the SmartApp only (top row of the Live Logging, select the name of the SmartApp).

1 Like

@RBoy I’m thinking of signing up to your smart apps and device handlers… just want to know first if your app supports the yale conexis l1 lock and more specifically RFID notifications for that particular device?

1 Like

Yes it does, you will need to use the Enhanced Z-Wave Lock device handler, see these release notes:

So I’ve installed the device handler and smartapp… I have a yale Keyless connected on my front door and a Conexis l1 on my back Door… I can’t seem to figure out how to make the RFID notifications work… I’ve reset both locks and tried to set up all keycards / pins again but no joy. Is there a specific way to do this?

If you’re using the RFID tags, then use this SmartApp along with the Enhanced Z-Wave lock device handler (after installing the device handler code I hope you’ve also changed your lock/device to use that custom handler). The below app is used for only reporting/taking actions (since you can’t program RFID tags as yet through ST), otherwise it’s identify to the app on this thread with the exception of the programming part.

Enter the username for the slots and program your RFID tags to use those slots, configure the notifications options and you’ll get the notifications when the RFID tags are used.