[OBSOLETE] Lock Manager

Figured it out. Carbon based error. Works great!

Hi - I had the old Lock Code Manager installed to support my Schlage FE469NX. Unfortunately, Lock Code Manager started to malfunction.

So, I installed the newer Lock Manager Smart App that replaced Lock Code Manager. I tried to follow the directions, but I am running into a problem when I get to the “Devices” steps. I installed and published the Schlage Touch Screen Device Handler.

At this point in the instructions, it says that I should go to the Devices page, and I should see my lock appear. That doesn’t happen - I see a screen that just says: You don’t have any devices yet.

If I manually try to add the Schlage Touchscreen door lock device using the Schlage Touch Screen Device Handler, it looks OK, but nothing happens after that. I can’t use my phone to unlock/lock the door, and adding new users/lock codes doesn’t work. It also never went into a “Learning Phase”.

This is effectively what I saw with the Lock Code Manager Smart App, and why I tried to upgrade to Lock Manager. I also see a message that my hub is Ofline when I try to make changes to the configuration.

Fortunately for now, the lock still has my existing codes. However, I can’t seem to get the Smart Apps to work with the lock anymore.

Should the lock have been automatically detected when I went to the Devices page?

What should I do to get my lock working again with my SmartThings Hub?

Thanks,

AzJazz

If your on the website and no devices display: Before going to the "My Devices; click “My Locations” select the one location listed, and then at the bottom of that page select “List Devices”

Double-check to ensure the Schlage device is using the “Z-Wave Schlage Touchscreen Lock” for the device handler.

Hi, @g0fish - When I went to My Locations >> My Home >> List Devices, I also saw a No Devices Found message.

Should my Schlage lock be automatically detected, or do I need to manually add it?

We replaced the battery on the door lock when the batteries died a few weeks ago. I think there may be an issue here, since I get a red X when I try to pair the lock.

I feel like I am missing something very basic here.

AzJazz

Try to access your device using this URL https://graph-na04-useast2.api.smartthings.com/device/list

Minor issue - I have no icon for Lock Manager or lock manager child apps in Lock Manager, in SmartThings app (Android).

Lock Manager App and child apps are up-to-date according to my IDE - “Local and repository versions are identical”:

Took a quick look and the Icon URLs in Lock Manager app look OK as far as I can tell:

iconUrl: 'https://images.lockmanager.io/app/v1/images/lm.jpg', iconX2Url: 'https://images.lockmanager.io/app/v1/images/lm2x.jpg', iconX3Url: 'https://images.lockmanager.io/app/v1/images/lm3x.jpg' )

Any ideas?

EDIT:

OK - something magical just happened…I went into the SmartThings app to do something with another smartapp, and the Lock Manager icon popped in as I was looking at the screen. Checked in the app and all of the child icons were there as well. Spooky…but this is Halloween, after all.

Thanks for the great app. I have spent a lot of time and effort researching and reading through the forums before I posted anything out of respect for the communities’/developer’s time. I unfortunately have reached the end of my capacity for understanding how to fix my particular issue. I will be detailed as possible.

I have a Kwikset 916 ZIGBEE model lock. I have done the guide to set everything up and it is a great guide. I deviated for one part because I have a zigbee. When installing the Device Handler I chose to add a device handler From ZigBee Device Fingerprint. The only part was confused on was the ZigBee Server Clusters Supported section. I did some research on what the hell clusters were and finally input “0101” and it worked.

I made sure then to have my GitHub Repository set to lock-manager (master). I was able to then run the simulator and could lock and unlock the device from my laptop. Personal first for me.

I downloaded the lock manager FROM the Automation section and NOT the marketplace. Under the automation section I have added the lock successfully as well as a new user.

Here is the issue. When I click on the lock itself it is giving me the message: “App is learning codes. They will appear here when received. Lock may require special DTH to work properly.”

Hopefully MY above deviation is not what is causing the issue. Thanks in advance for any help that you may provide.

Kane

Hi, @g0fish - Thanks for the help! I got things farther along, but not by much.

I determined that part of the problem was that my Z-Wave pairing to the lock was lost somehow (possibly when the batteries died).

I re-paired the lock to my Smart Hub (it took multiple tries), and then it appears in my device list.

However, that’s about where things end.

I reinstalled the Lock Manager app from scratch and have the Schlage FE469NX set up as a Z-Wave Schlage Touchscreen Lock. I see a bunch of events occurring now (like code scans and such), but I can’t do anything to read or write to the door lock.

For example, none of the existing codes were read back from the device in Lock Manager. I also can’t lock/unlock the door through the SmartThings GUI, regardless of whether I use the Lock Manager or the built-in SmartThings functions.

Also, I can’t add or delete any codes on the lock.

Darned confused,

AzJazz

I decided to do a factory reset on my Schlage FE469NX. It seemed to do the trick … I can now control the lock as I should through the Lock Manager Smart App.

Thanks for the help!

AzJazz

1 Like

Switch the device handler to the Z-Wave Lock Reporting. Install it the same way as the apps except in the device handler tab instead of the smartapps tab of IDE.

https://github.com/ethayer/lock-manager/tree/master/devicetypes/ethayer/zwave-lock-reporting.src25

Once installed you will need to publish, then go to devices, then edit your lock device and change it to the new DTH which should be located at the bottom of the list.

@g0fish Slight boo boo there. He has a zig bee lock so he can’t use a z-wave dth.

try this DTH for your Kwikset zigbee lock…

hope this helps! :slight_smile:

1 Like

Thanks @jkp!! I’ll give it a try and see if it works.

@ethayer - Erik, I’ve got something going on w/codes.

First issue:

A few weeks ago I set up a new use/code, lets say as 12345. That worked fine.

Then decided I wanted to change it, let’s say to 12346. Result:

  • Original code still works
  • Updated code does not work

Second issue:

Just today I set up a new user w/code. Result:

  • New User Code doesn’t work - waited several hours to ensure it wasn’t an update lag issue. The new code is rejected when I try to use it on the lock.

I’m being careful to use the correct number of digits (5) for the codes, and also ensuring that I don’t try to use a slot already taken by a previous account.

Lock is Schlage Camelot, and as I posted a couple messages up, I have the latest DTH/SmartApps installed from your repository, and am using the Schlage-specific DTH for the lock. The lock is 10’ away from two GE Zwave switches that act as Zwave repeaters, so communication between hub and lock should be fine. Other Zwave devices in my house much farther away work w/out issue.

Is it time to reset the lock and start over, or are there smaller steps I can take to troubleshoot and attempt to resolve these issues w/users-codes? I have the lock in several automations and would prefer to fix things w/out a reset if possible.

Thanks!

Quick question: once a 1-time use code has been “burned”, can that code ever be assigned again?

Answer is YES. The DTH doesn’t store the previously used codes. All it does with the ‘burner’ code is delete it when it’s been used once.

New to ST and just installed Lock Manager (excellent, easy instructions!), but having some issues:

  1. Automation->SmartApps: Lock Manager appears there 4 times
    • 1st one: “Installed” section shows Lock name and then 3 of my 6 users. “Locks” section shows lock name. Note: When I set them up, these 3 users were set up in slots 1, 2, and 3.
    • 2nd one: “Installed” section shows nothing (blank). “Locks” section shows nothing (blank).
    • 3rd one: “Installed” section shows the 4th, 5th, and 6th users. No lock name. “Locks” section is blank. Note: When I set them up, these 3 users were set up in slots 10, 11, and 12.
    • 4th one: Same as 2nd one.
  2. I’ve tested- all 6 user codes are working.
  3. App seems to work every time, but 2-3 seconds for unlocking and 7-8 seconds for locking. These times are ok with me, but mentioning because I’m not sure if it’s “normal” or not.
  4. MyHome -> Front Door shows 2 rows of 3 buttons:
    • 1st: I guess keep hitting it till it gets to the alarm mode I want to stay with.
    • 2nd; What’s the slider?
    • 3rd: Battery
    • 4th: “Auto Lock” seems to do nothing when I hit it
    • 5th: “Lock & Leave” seems to do nothing when hit it

Thanks for any help in fixing and helping me to understand!

  1. i’d Recommend removing three of the 4 Lock managers you have installed and adding all users/locks to just one LM. The reason you have multiple lock managers is at some point you were in MarketPlace: SmartApps: My Apps: Lock Manager and tried to use it there. Each time you tried to set up users or locks there and clicked done, it would create a new instance of LM in Automation: SmartApps. Avoid the MarketPlace location. :slight_smile:

  2. :slight_smile:

  3. that seems to be a normal time-frame for locking/unlocking.

  4. the slider sets the sensitivity level of the alarm mode. Read the user manual for your lock on what the levels are. With lock and leave and auto lock, you may need to press several times to set. You can also read the user guide on how to set them manually on your lock.

Hope this helps!

@jkp, Thanks so much- Helped a lot! One last question if you wouldn’t mind… Time To Burn: Is that the number of failed attempts before a passcode gets disabled? Thx

Burnable users (set allowed number of uses).

1 Like