[OBSOLETE] Lock Manager

sorry, forgot we were in the lock manager thread. I was thinking of Smart Lock Guest Access which allows you to share the code via text or email when you create it from what I remember.

@ethayer keep us posted on how things are going as we head into the new year, non-Groovy land. Happy to help test across the multitude of different hubs, locations, and locks I have setup. Just configured a new account that’s fresh and already on the new Edge drivers as well so easy to sandbox test anything that’s available even if buggy on launch.

An alpha version of the new app should be up in the next few days. Just working through some dev-ops stuff to get it running.

There are many features missing in the front-end UI of the new site. For now, the app will be free so it seems fitting to just let ya’ll go at it. Hosting costs are more than expected, so that might light a fire in me to get it out of alpha.

More very soon.


I have schlage locks and would love to alpha/beta test it and would happily pay for it when time comes

Trying to be quiet about it, but the app is available now. It’s missing a lot a features but supports basic member creation and scheduling. Check it out if you’re brave. :wink:



Right on time Groovy SmartApp Shutdown

1 Like

i’m brave but running into an issue setting it up. after i enter the client id, client secret, and app ID, clicking save appears to do nothing. same with clicking next. however, if i refresh the page and click next, those fields were saved. but again, clicking next takes me nowhere. tried in both safari and brave.

It sounds like you might have to click “Verify App” in the smart things website. Did you do that step?

oooph. definitely missed reading that step. got through now. :sweat_smile:

1 Like

Thank you for your work .
Just try and 2 things.
1 - lock is stuck at (Lock is initializing, This could take some time. 0/0 )
2- when created a user , it only allow me to put 6 digit code , my lock is a shclage be469 and it set to 5 digits , I would think that is a limitation from smartthings.


I got it installed. No problems. I hesitated to start using it, though, because there was a warning about not using it with other apps installed and I still have Rboy’s LUM installed. I suppose for testing purposes I might be able to turn that off (although I think I’ve seen posts where this is no “off” switch for it like other apps (although now that I just looked, there is an on/off toggle). If I do run it concurrently because I can’t turn LUM off, how bad of a situation will I create for myself? ;-). I also installed the Smart Lock Guess Access app, which I saw was recommended in the meantime, and it’s not very useful although it does give me notices as to who opened a lock, which is helpful for Routine and SharpTools Rules. Thanks.

Tried setting up an account 3 times, but no email. Any thoughts?

I resent the confirmation instructions to the email you used to sign up.

If an app tries to sent a code to something, lockmanager.io will detect that as an issue and try to delete it as an unexpected code. This is in order to prevent code conflicts that can create infinite loops. One app will try to override the other app forever. :stuck_out_tongue_winking_eye:

1 Like

Mine always shows no locks online. Only certain locks supported?

Can’t seem to get past the “App Keys” section - clicking “Save” and then “Next” nothing happens.

Make sure you click “Verify App” in the SmartThings developer dashboard after entering your keys.

Got it, thanks!

Stuck on Lock is initialising.

I have gone through the setup process and get a notification on my phone saying “Front Door sweep started.” Nothing happens after that. When I check the web interface I see

Lock is initializing. This could take some time. (0/30)

And it’s been a few hours. Any idea what I’ve done wrong?


I clicked on link to register but never got an email