[OBSOLETE] Lock Manager

I went back to using the default device handler for my Schlage BE469. The only thing it does not do at the moment that I need is let me set an expiration time/date on a new code. I was using this DTH but it was a little too buggy and reading somewhere in this thread, he is no longer maintaining the code.

Thanks. I will change back to the standard DHT

Any luck? We have the Lock Manger App, but for some reason getting an unknown error when trying to add new users.

I was too hasty in saying it works fine in the new SmartThings app. It does provide me with all the notifications I had before. But today I found out that I can’t add new users (I could probably delete users, but I didn’t try that) in the new app. When I try, there is essentially a loop of creating a new user and no way to enter a code. So I’ll stick with the SmartThings Classic app for now. That still works.

I’m trying to get this to work with August and a Centralite 3400 keypad. Any help would be appreciated. What I need is a way to see who unlocked the door at a specific time.

Please email me if you can help


This hasn’t worked for me in a while. I’m now using this enhanced keypad dth along with the rboy LUM app to program my Centralite keypads. LUM sends me notifications when someone uses the keypad but you can also review the usage activity from device activity screen in the ST app. I have one keypad setup to open/close my garage doors and I’m using one to arm/disarm STHM directly. See this post for how use the keypad with the new app STHM. There’s another app from rboy for security called Intruder Alert which works even better with the keypad but I like the STHM dashboard for now.

Hi, I’m new to this code manager and smart locks. Bought Schlage 469zp, and installed the Code Manager from ethayer.
Codes aren’t updating to the lock, I’m doing this from the Classic app.
And if I go through SmartApps in Lock Settings it says 0% sweep is in progress. and stay there forever.
Thank you very much whoever can help me with this.

The codes won’t update until the sweep is complete. Try removing the lock and adding it again, but this time tell it to skip the sweep. It will sweep later on its own.

Hadn’t answered before to give it time to auto sweep, but it’s not working either.
I tried resetting the user but it didn’t work.

If you have any other suggestion I may try Please let me know.

Thanks for the help

I wish I could help, but that has never happened to me. It would appear that the lock is not responding to any commands from the hub. I have a Yale lock, not a Schlage, so I’m not sure how to go about troubleshooting. I know some people have used a DTH specific for Schlage, but I can’t say if that is the problem.

Whats the reasoning for not allowing the classic SmartApps in the new app? Seems so silly to me

I just purchased the Zigbee Yale YRD226 and wondering what is the best DTH to use along with Lock Manager.
Thanks in advance.

I use ethayer’s Z-Wave Lock Yale DTH but I have a Z-wave Yale lock. I don’t know if that will work for Zigbee lock, but it’s worth trying. Otherwise just stick with the standard lock DTH.

Anyone have 2 locks running on this DH? I have 2 of the Schlage century deadbolts with the touchscreen number pads. I’ve ran the 1st one for over 2 years. The new one I added yesterday… on this one you have the hit the Schlage button first before entering the code unlike my old one. I can’t get this one to take new codes even though it shows in the recent and logs “added code 1” and “added code 2”. In the app the lock always shows it’s in an unknown status as well.

The lock isn’t mounted yet, but every command makes the lock spin clockwise as well as the default codes. But I’m hoping that’s because it’s not mounted.

But here is the crazy thing… I unplug the batteries from the new lock to do a reset. The old lock locks, hook the back up… the old lock unlocks. Does it every time.

Well if anyone finds this… II have to mount the lock and cycle it once for it to start working.

You can copy the code then change the name of you want the locks to work on different codes.

You know, I hate to say this, because I’m a long-time user/supporter of ethayer’s lock management, but I finally broke down and purchased an Rboy lifetime license ($39) becuase I was continuing to have issues using this setup, and the long-term future was not clear.

My initial experience is “Wow, it all works, and there is a ton of options/features available.”

If you’re happy w/this setup and it works, stick with it. But if you’re not getting things going the way you need/want to, I have to say I am very impressed with what Rboy has to offer.


I am trying to install this. I set up the repo and installed the main “Lock Manager” SmartApp, but the other three child apps do not show up in the repo when I click on Update from Repo. Any suggestions?

@mikebian63 I’m following the pdf guide too and don’t see the child apps either.

Those instructions are out-of-date. The newest version of Lock Manager only has 1 smartapp to install. The 3 child apps were part of the older version which is what the instructions refer to.

I’m confused on how to even get past step one "From the IDE, click on “My SmartApps” how do you get to the IDE on https://smartthings.developer.samsung.com/?