[OBSOLETE] Lock Manager

Update: My notification started working! As fare as I know i didn’t change anything other the what i said above. They did not seem to work right away but just started working a few days after maybe.

I bought rboyapps software to replace ethayer’s great work – and it works flawlessly. Well worth the time I saved trying to debug codes being lost (though perhaps a zwave repeater would have helped that).


Glad you guys are getting along! A part of me is really missing since I’ve gone into a limbo. I’ve just been doing this for the fun of it and Samsung has made some moves to make me question what I’ll do next, so I’ve been in an indecision limbo.

First SmartThings was all like, Hey thanks for making this Erik, in a couple of months we’re going to be releasing our own internal implmentation of this. [[ LOL!! ]]

Then Samsung came in and tore up the place. The new API looks really cool in some aspects but super lame in other aspects. Looks like local processing is thrown out the window in favor of many micro services.

I’m not sure what to do and so I’m stuck. I have a VERY limited amount of free time to invest in these passion projects so the choice in what I do with it is super important. So far, I’m choosing to go mountain biking.

I think I’m coming to a point where I want to go ahead and learn the new node API. It looks neat and while I will VERY MUCH miss the opportunity to do local processing, I’m thinking switching to a non-user-friendly solution like OpenHAB or otherwise would mean I’m only pandering to a specific kind of person.

I’m not sure when the next update will come, but I think I’m getting closer to being out of this limbo. I’d like to do some fun things with code.


Finally got back to this (life has been in the way) and reloaded the clean DTH and then applied just the single change you note, @oksstech. I’ll wait week or so and see what happens.

@ethayer - thanks for the update. Your process sounds like a good one (mountain biking), thanks for keeping us in the loop, and whether you decide to come back or not the ST community owes you a lot already. :slight_smile:

I just updated the main lock manager app to v2.0 and I get this now:

e7ca395a-eeca-4e45-a5f9-d787b917f9bd 12:26:35 PM: error groovy.lang.MissingMethodException: No signature of method: script_app_46a41cc7357a47c306a6c900fd3f20a663bde07b1465b6da12b6a35870266ab3.theAppType() is applicable for argument types: () values: [] @line 598 (doCall)
e7ca395a-eeca-4e45-a5f9-d787b917f9bd 12:26:35 PM: debug Main Updated with settings: [enableDebug:true, overwriteMode:true]
e7ca395a-eeca-4e45-a5f9-d787b917f9bd 12:26:35 PM: debug Installed with settings: [enableDebug:true, overwriteMode:true]

Yeah me too. It has been painful for me to get this to work reliably and it doesn’t work with the new Smartthings app unfortunately. I see ethayers dilemma in a constantly changing environment.
Anyways I also decided to get rboyapps LUM which has been working brilliantly for me, the support is great and I’m able to use it with the new Smartthings app.


I am not seeing real time updates when manually opening and closing. Only way I can see real time updates if I go back to the default device type and not use this custom device handler. Is there a way to get this device handler to show live updates?

I have notifications working besides a manual unlock. Anyone have a fix for notifications on manual unlock?

See my post from May 20 (when I searched it showed as post 2140, but when I display it it appears to be post 2088). It includes the code change (among others) to have a notification on manual unlock. ethayer’s original did not have any code for that event.

GP I am trying to implement your changes but I am not understanding the lines. I think my version has different line numbers. Can you help me with the modification file. Here is the link to the one i am currently using. 2.0 file

I had trouble with your link to the file, but here’s what you need to do:

  1. Search for the line that says:
    message = “${lock.label} was unlocked manually”

  2. Eight lines below that is the line that says:

  3. The line below that is the closing brace for the if statement:

  4. Insert the following lines after that closing brace:

    if (notifyManualUnlock) {
    if (alexaManualUnlock) {

That should do it.

Does lock manager support configuring the lock settings such as beeps? I have a Yale YRD216.

I don’t think so, but I have not tried that. I don’t think my lock has those settings.

You’re pretty much right. The option for controlling beeps is there but they don’t do anything. I also can’t add codes in Lock Manager nor can I add codes with the ST app. So, I just removed LM and went back to the ST app.

Had to reset the lock anyway. A few weeks ago it made the sound that it rebooted and after that the master code stopped working and I know I had the right code.

I’ve been using lock-manager quite happily for a couple years. I’m now trying to move to a new phone, and all of a sudden I can’t see my “Thing” in either the new phone or the old one. When I log in to SmartThings.com, I still see my hub, my Schlage doorlock, and 4 entries in my SmartApps.
But I don’t see how to connect the phone app to everything.
Do I have to be in the presence of the Hub to do that? (I’m remote).

All you should have to do is in the app on the phone login to your SmartThings account. That should allow you to see the Lock Manager app at the bottom of the SmartApps tab of the Marketplace page (this is for the Classic SmartThings app, the only one I’ve used). You install Lock Manager from there. You may need to set up the Lock and Users again. I don’t know never having changed phones yet.

It is only letting me install the parent app. Can someone send links to the child apps so I can manually install them?

Same here. When I follow the install instructions in the User Guide

It enables me to install “Lock Manager” but it doesn’t show options for Keypad, Lock User, or Lock.

Any suggestions/guidance?

If you have installed version 2.0 (very likely), there are no separate child apps. The child apps are included in the Lock Manager code. The instructions are for the previous version (1.4).

Anyone tried using this with the newer SmartThings app? Just throws an error when trying to open. Works fine in the ST Classic app.