[OBSOLETE] Lock Manager

I was able to get it sorted. I got to the stage where the guide mentioned the marketplace and myapps. I couldnt find it in the new app but I did find it in the old app and then it appeared in the new app under automations.

Yet to fully test it but I did create a test user with access code and assigned it to a slot. I will test if the lock actually reaponds to it but so far looks good. Pretty easy to setup a user.

@ ethayer and friends - While I have the device handlers and apps installed for 2 Schlage Connect touchscreen deadbolts, and I can set the “kick” sensitivity from the SmartThings Classic app, I don’t see any way to utilize the Kick detection (or “wrong code attempted” detection) as an alarm sensor, similar to a window/door switch. What I had hoped was to add these “sensors” to the list of things that should be “OK” for “Armed-Away” and “Armed-Stay” modes within the SmartThings stock “Smart Home Monitor” widget in the “Classic” app.

Within Smart Home Monitor -> [Press Gear Icon for “Configure”] -> Custom -> New Monitoring Rule, I can select devices, but if I select “Lock”, my choices are “Lock” or “UnLock” the lock. It would seem that I need to set up both the kick sensor and the wrong code detection as new types of alarms to be monitored, but I can’t see how to do this. The goal here is to get more than just individual cellphone push notifications of events, the goal is to work up to a top level “NOT OK” mode, and trigger a siren, turn on the exterior lights, and so on.

I am clearly clueless on how to set this up, as I see no way to “integrate” the device handlers and apps with the stock SmartThings stuff. May I please buy a vowel? :slight_smile:

If it matters, there is a Samsung SmartThings hub of the 2018 (latest/greatest) version, the locks, which are Z-wave, and a bunch of sensors, which are zigbee. No voice commands, no integration with 3rd party services, no connected coffee pots.

I am getting an error “This user has been disabled. Reason: Controller failed to set user code”. I’ve seen a few people post this error but none received a response. I tried resetting the user and that didn’t work. I tried creating the same user/code in a different spot and got the same error. Can anyone help?

Also important to note, this is happening with all new users/codes I try to enter. I’ve been using lock manager for over a year and yesterday was the first time I experienced this. I’m going out of town tomorrow so I’m hoping to troubleshoot tonight as I’ll need to make codes remotely.

I have Lock Manager working with a Schlage BE469. However, in the notification when a user unlocks - the door name is “null.” I deleted and created the lock again, making sure it’s named appropriately, but I still get the message “Bob has unlocked null”. Any ideas?

Been using Lock Manager for over a year and it’s worked flawlessly. I stopped getting notifications months ago and have tried many things. I’m assuming it’s all related to the removal of contact lists, but I’ve tried everything I could find to fix and I’m stuck. I do not get push notifications at all. I followed all of the directions here: Removal of Contact Book Feature, I have made sure that I have updated all my smartapps in the IDE.

Any other ideas? Thanks.

I do my alerts in Webcore, by assigning a lock slot to a particular user. The piston says

Front door lock’s lock #3 gets unlocked
Send PUSH message “front door unlocked Joe”

front door lock’s lock #4 gets unlocked
Send PUSH message “front door unlocked Betty”



This exactly what I have been searching for!!!
I have the Schlage Z-wave Connect Touchscreen Deadbolt (BE469). In my SmartThings IDE, under 'My Devices, the BE469 Door lock’s ‘Device Type’ = ‘Z-Wave Lock’. I am new to WebCore. I just installed it recently and this is the first piston I am trying to build. Initially I am trying to setup the piston to notify me when the door is unlocked by people other than wife, kids, and myself. Eventually, I would like the piston to turn on all the lights in the entire house when the house keeper enters her code. I would also like to set the “Smart Home Monitor” to ‘Disarmed’ when a valid unlock code is entered into the pad. Any advice you could offer would be greatly appreciated! Or anyone else for that matter…


I’m using the ethayer Lock Manager app and device handler package. Have you installed that yet? Silly question I know, but I have to ask…

Once you install that, all the things you want become available.

Ha! Don’t even know what that is… Off to google to find. Thanks so much for the quick response!. I am literally building my first piston now in another window.


You don’t need to google it - it’s the first post in this thread

Hi, apologies if this has been covered. I had a quick search.
I’m just installing, following the instructions, I get to add devices and there are none. I can go back to my locations, select my office (location) and see my devices but there are then no installed smartapps. Although I can add a smartapp there is no option for GitHub. I’m sure there is a simple solution but its beyond me. Can someone please help?
Many thanks


Hi all,

I keep seeing all these poll commands and sentupdate codes in the activity feed and under recently in the device. Do you know what causes this and how to stop it?

I just installed this, which I’m pretty excited about, but I’m not receiving any push notifications when the users I have marked to do so are unlocking the door.
I also have the SmartThings SmartApp for the door lock installed, and I’m wondering if that’s causing a conflict?
Codes are being updated to the lock, I’m just not receiving notifications.

It looks like there is a recursive situation where “setCodes” calls “loadCodes”… I commented out line 546 in the lock.groovy: runin(30,setCodes) and it seems to be working fine.

Is this smartapp no longer being developed? I haven’t seen a code update in quite a while. I am having an issue where I don’t appear to be able to add new users properly. Once they are “partially added” I can’t remove them. I need a lock manager that works and if I am going to do a complete reload of this and probably factory reset my 1 lock (schlage z-wave) then I think it may be best that I switch to a different piece of software. Any recommendations? I know there is a paid smartapp out there somewhere.

Added the user “Samantha” twice. User doesn’t work.

Now I can’t remove “Samantha” either.

This appears to be the error in the log:
1ba7b758-d173-48a6-86bc-d5207d6cd5b8 2:53:22 PM: error groovy.lang.MissingMethodException: No signature of method: java.lang.Boolean.getTime() is applicable for argument types: () values:
Possible solutions: getAt(java.lang.String), getClass(), notify() @line 670 (isInCalendarRange)

Last I saw the developer was starting to look at what would be taken to migrate to the new Smartthings API’s. This is important because eventually all this groovy code is going to be deprecated. Rboy has the paid version in his suit of apps.

I have been using lock manager for couple of years and it worked great. But not until a few days earlier, my lock stopped reporting lock/unlock state if I physically lock/unlock the door. I can see the events like below in live logging, but there is no recent activity for the lock. Any idea what could go wrong here?

1a541116-8610-495b-9641-da74375b998f 11:38:21 PM: debug "zw device: 06, command: 7105, payload: 16 01 " parsed to [‘displayed’:false, ‘descriptionText’:Front Door Lock: NotificationReport(eventParametersLength: 0, eventParameter: , zensorNetSourceNodeId: 0, v1AlarmType: 22, reserved61: 0, notificationStatus: 0, sequence: false, event: 0, notificationType: 0, v1AlarmLevel: 1), ‘isStateChange’:false, ‘linkText’:‘Front Door Lock’]

This seems to be an issue with the latest firmware update. Mine updated yesterday, and since that moment this Lock Manager is not registering which user slot has unlocked the door.