[OBSOLETE] Lock Manager

Thanks for the great addition. I have a question. I can see that user codes and the like are reported to the app, but I would like them to also be reported to MQTT so I can track them in Home Assistant as well. All I see coming into my MQTT broker, though is:

smartthings/Front Door Lock/lock

I can see the state change between lock and unlocked. But apparently I can’t also set the state from here. Is there a way to change the apps I can track which user (even just the user number) unlocked at what time?

Or whether it was locked by the keypad, or a press, or whatnot?

I just installed it and although it seems to be working, I have 4 issues: (edited to included 2 more issues):

  1. The main SmartThings app shows my lock status as “Unknown” even though it’s locked. I tell it to lock and it does, and then it just reverts back to “Unknown” which is obviously a bit of a problem as I’d like to know that my doors are locked when I’m away from home.

  2. I set up all of my users and named my lock “Front Door Lock” but the app keeps referring to it as “null”. It sends me text messages “null was manually locked” or “user has access to null”

  3. The app is telling me the Front Door is locked, while simultaneously telling me the Front Door is Jammed. I have checked and it’s locked but not jammed. I tried manually unlocking and relocking, but the app still thinks it’s jammed.

  4. Randomly the lock just sent me a message to tell me one of my users no longer has access. This user hasn’t used the lock yet and I haven’t made any changes to my settings or added or deleted any users.

Any advice would be most welcome. I am not a developer - I succeeded in installing everything simply by following the instructions carefully, but I don’t know what most of it meant!

Many thanks in advance.

Hello all - i have having the same issue that hawtboi1 has. I am using a iPhone, if i click on SmartApps and Lock Manager it does not open.

I have done the following:

  • Gone into my IDE and deleted all instance of Lock Manager
  • Clicked on my smartapps, update from repo, lock-manger (master) and updated the repo
  • reinstalled the LockManager and still nothing

when i click on Lock Manager it does noting
when i try to simulate the app i get the following error: java.lang.NullPointerException: Cannot get property ‘id’ on null object

appreciate any help

also, same result on my ipad and 2nd phone running Android

so i got it to work, i had to also install the Keypad widget

now i just cant get the SMS to work nor will it arm the house on code lock

That actually worked for me, too. I could swear I tried it before but did not work. Anyway, all that matters is that it works now! Thank you, Sarcadi.

About your other two issues, if you don’t have Verizon, AT&T, T-Mobile or Sprint, make sure your Carrier supports email to SMS and that they are not blocking messages coming from SmartThings.

Your issues sound like a DTH (device type handler) problem.

What kind of lock do you have and have you installed a custom DTH for it? If it’s a zigbee lock, I would install [DEPRECATED] - Universal ZigBee Lock DTH with Lock Codes. For z-wave locks, you can find DTHs for almost every brand in the forums.

What a great app! Works great with my Yale Real Living Z-Wave (YRD210-ZW-605). I gladly donated to the author.

A question, though – as it stands, the lock Thing (which is using the custom “Z-Wave Lock Reporting” DTH is not reporting the battery level. Is something wrong with my setup or the lock itself? I do see that the DHT advertises and implements the “Battery” capability…

Thanks for your advice! I’m sorry - I don’t know what a device type handler is. I have the z wave Schlage lock which I’m using with Smartthings and Lock manager. Where do I get a DTH for this? Thank you!

@RBoy has a very clear set of instructions on how to set it up.

Where do I find out if I have a secure inclusion?

I am new to SmartThings. How do I go about adding a 3rd party App such as Lock Manager? some kind of step by step directions would be super helpful! Thanks

http://thingsthataresmart.wiki/index.php?title=Using_Custom_Code#Using_A_Custom_SmartApp

In Live Logging, you’ll see a message stating that your device included securely or insecurely.

About how long before I see the inclusion type? I am mostly seeing Lifx and smart apps

AFAIK, you should see it as soon as it pairs (or rejoins if disconnected). You might want to try excluding it and then rejoining the device to your mesh.

After upgrading from the repo to the latest version, the slots are messed up.
I have 3 user code using slot 1,2 and 3 but when i create a new user code, it shows 1,2 & 3 available.
It use to only allow me to show the slots that is not in use.

What would happen if you have 2 user code on the same slot?

In addition, when i revoke a user code, I still don’t get notification that user access has been removed even though the push notification is turned on for revoking user code.

I have a Schlage Camelot Touchscreen lock and was able to set up the user codes and notifications, however, my lock beeps multiple times before unlocking when a user code is entered or locking. The lock alarm is set to off. I’ve tried disabling the alarm both manually on the lock by holding the alarm button for 5 seconds and through the app but the beeping will not stop.

Any ideas on how to get the annoying beeping to go away when a code is entered?

This sounds like the stock low battery alert.

Just stopping by for a sec to explain my recent absence. I have a new baby!

He is very cute. I hope that one day, he will be an engineer. I will return to SmartThings hacking in a week or so.

19 Likes

Congrats!!! … hope he doesn’t turn into a politician or lawyer, we don’t need/want more of those IMO, LOL

1 Like