[OBSOLETE] Iris Smart Plug (3210-L) Zigbee Plug with Z-wave Repeater

I initially followed all the directions, including adding the Z-Wave repeater to smartthings. I guess I’m wondering if the repeater would be still be working if I didn’t “add” it to Smartthings? It is frustrating to go through my devices and see five Z-wave repeaters that serve no purpose for activating switches, etc. Is there a way to hide them from the app, or would deleting only the repeater part impact my smarththings behavior?

I believe you have to add them so they become part of the system mesh.

I do believe there is a way to hide items you don’t want visable in the app, but I personally don’t know how yet. Just haven’t gotten around to cleaning my list up.

If I stuble across how I’ll share.

I found this on Google, I’m sure Smartthings has it listed someplace too.

The repeater MUST be included in your network as a device to work.

And you want it to work that way too… Otherwise any rando could park outside your home with a device that claimed to be a repeater and record or inject ZWave commands.

A device that gets included in SmartThings, shows as a device in the UI.

Most of the people I talk to have ab automation or trash room where we park stuff like this.

1 Like

I have several of the Iris/Centralite plugs that I’m having an extremely difficult time with. They aren’t working reliably, I can’t re-add ones that have been removed (because they weren’t working right) I can’t delete either.

Right now, I’d like to start with just removing. I’ve used the Z-wave delete function (with exclude) multiple times. I go through the 8 button press exclusion process, the new ST app accepts it and says OK, then goes back to the delete pop up with a little spinning circle. It then says "A network or server error occurred. Try again later. I have multiple times. I can’t get it to delete.

So I went to the web interface hoping that would help. I thought I could switch to a different device handler (I’m still using the custom one) and maybe I could delete or improve things that way. I can’t seem to find any place to change the z-wave handler (maybe that’s normal) but when I tried to edit or delete the z-wave repeater, it says “You are not authorized to do this”. I’m fully signed in.

I think these are old as they are offline. But when I found the one that one that corresponds to a particular plus, it did seem to initially exclude the device (before giving the timeout error above). The plus also goes from the z-wave mode (different blinking pattern from the zigbee one) to solid blue.

I don’t know what to do. I need to completely get this out of the system. I don’t know what to do at this point after trying to many times and having the process fail. Any help would be amazing. Thanks in advance.

First… resist urge to delete them through the IDE. It will likely leave Zwave and / or Zigbee ghosts (or both (considering the 3210L technically shows as two devices) This should be last resort adn will also require you to do other network maintenance.

Second - device handler doesn’t matter in this case. Just pull the device off power before attempting to delete it. That way the system won’t see it as online and functioning when you try. When delete happens and the system can’t communicate with your device (because it’s off power) the app should offer to attempt a force delete. Wash Rinse Repeat as necessary until you get it out. Yes that means the device itself will technically still think it’s participating in the system even after ST removes it, but a factory reset on the device should fix that. (Yes that’s absolutely the ‘somebody else’s problem’ version - but it’s the easiest at this point.

Had a very similar issue trying to delete an app and its corresponding device. Nothing I tried would delete them and got the same "A network or server error occurred Try again later " message in the app. contacted smartthings support through the forum and they took care of my issue on their end. Youll probably have to do the same

Can you have this zigbee part disabled (removed from the app) but still have the z-wave repeater work? Rather, can you have this work as a z-wave repeater only? I have two and they don’t play nice with Aqara devices.

This is an oddball compound device - it actually shows up as two unique devices in the app - A Zigbee plug and a ZWave repeating device. And you have to join them independently.

Since repeaters must be joined to repeat for a network- just don’t join one side or the other of the device.

This is why I don’t use Aquara devices. I don’t want to have to engineer my mesh around them.

I would agree with regards to their sensors, but their double rocker has been bullet proof for me for months now. It’s routing through a GE switch too without a problem. I wish there was an easy way to figure out what was routing through my Aqura switch in the IDE.

This post got me to wondering if their switches, which are routers, would do a good job with their own sensors. I may have to get one and play around with it.


The new t1 line of aqara devices will solve your problems. They are Zigbee 3.0 certified like the mijia light sensor. They will not drop like the older sensors. I am offering free samples (for now just the vibration sensor, but temp humidity when I have stock) to anyone who wants to help with modifying the device handlers to support them.

Yeah, good point on the 3.0 spec. That lux sensor I did the DTH for hasn’t dropped at all and has been working great. I got your tag notification from your other post on the vibration sensor. That sounds like a good project I can work on with you.

1 Like

I’ll send you a pm

1 Like

How do you know or get these Aqara 3.0s?

I’m not sure when it happened but within the past couple months all (20) of my 3210-L’s have stopped reporting energy usage, it just remains 0. If I change the device type to another device and then back to the iris it will work for a while, maybe a day or so, then stops again. My peanut plugs are still reporting properly.
Any ideas what to try next? I’ve added a new plug, re-paired an existing one, re-saved the DHT, changed the device type to something else and then back to Iris.

in the IDE logging it throws this error in red " java.lang.NullPointerException: Cannot get property ‘date’ on null object @line 155 (calculateAndShowEnergy)"

that line in the dth is “def deltaT = (recentEvents[0].date.getTime() - recentEvents[1].date.getTime()) // time since last “power” event in milliseconds”

@blebson might not be supporting this code anymore as the iris outlet works with the smartsense outlet device type, but without the energy usage window.

Mine are all reporting energy usage. Im using the local DTH “SmartPower Outlet”.


i have that on some of mine, but it only shows “power meter” and not total energy usage.

That is correct @Awestun, that is all I see as well.
You could run Google sheets logging and add up that column to find out your totals.

To fix the energy logging, I changed displayed: false to displayed: true on line 134. I made a number of other changes, but I think that’s what finally fixed it; recentEvents on line 154 was always giving me null events back but once I made the power events displayed, recentEvents populated correctly. (@Awestun).