[OBSOLETE] Hue (Re)Connect - with scene handling


I just saw your other post in the CoRE thread…you seem pretty well versed, would you mind helping me? The documentation surrounding CoRE seems pretty light.

I created a Basic Piston called “Good Night Lights” so that:

If: Good Night Routine is run
Then: Fade to Level, Start Level (blank), Target Level (0%), Duration (120 seconds)

Every time I execute it it doesn’t do anything to my lights. Is that conflicting with circadian daylight too, even if it isn’t receiving a command at the time of execution?

If I recall correctly, circadian daylight is constantly sending updates (for the time appropriate circadian rhythm) to all included hue bulbs. You can watch live logging in the Graph API to see what I am talking about. It will most definitely interrupt any commands that you are attempting to send to the Hue bridge.

1 Like

I know a couple of people who put most of their bulbs on circadian pattern, but keep one or two near the bed that they use for good morning and good night transitions. So that’s another approach that works for some people.

As far as core, it’s definitely very complex. You can get peer assistance in the following thread on that. :sunglasses:

Yeah you’re definitely right. I thought it was setting temperature in 15 minute increments but I see that you’re 100% correct.

Thanks. That seems like the best solution I’ll probably find. The lights closest to the bed IMO are the most important to be on a circadian schedule - I think I’ll leave one excluded in the corner and have that dim with CoRE good night routines.

Thanks for your help!


@AlmostTan, @blong, @JDRoberts

Regarding Circadian Daylight (this may be better off discussed in it’s thread, here):

As far as I know (and definitely since I’ve taken over the project) since Circadian Daylight switched to a scheduled method rather than being event-based, it updates your bulbs every 15 minutes. But, if that 15 minutes falls within a bulb transition it will override the bulb.

That being said, Circadian Daylight allows for multiple setups with different options. Previously this was by simply installing a new instance, but with the version that I just bumped from beta to stable, it uses a Parent/Child configuration making setting up multiple configurations even easier.

If you want your bulbs to dim to off as you fall asleep, you have multiple options while still being able to use Circadian Daylight on those bulbs (and others). For example, if you put SmartThings into a specific mode when you go to sleep you could create a separate child setup with just these bulbs and select all modes except your sleep mode for Circadian Daylight to work in. That way, as soon as you enter this mode, you can begin dimming your bulbs and Circadian Daylight will never touch them. If you want to use the sleep features in Circadian Daylight, while still allowing the bulbs to dim to off initially, you could use a virtual switch that is turned on only while the bulbs are dimming, and have that selected as a switch for disabling that child setup.

If you guys have any questions about this, please bring them up in the Circadian Daylight thread. I’ve made HUGE changes recently, and added pretty much all requested features. Definitely post in there before just deciding you can’t use it for your setup because chances are there’s already a way to make it work and if not I will most likely update it to work for you!


Tried to get this working to no avail. The SmartApp and devices installed fine. Found my Hue Hub just fine and found my Lightstrip. I was able to add groups, no problem. But for the life of me, I could not get it to discover scenes. I went into the native Hue app and triggered my scenes both on and off. Still would not discover them. I only have three that I’ve built so far. I was able to test the bulbs and the group settings. I was able to trigger everything so I knew that I had the deviceTypes installed correctly.

Reading through the app there was mention of the Philips API debug tool. So I went into that and checked my scenes. Looked fine. So I deleted the smartapp and devicetypes and re-added.

The only thing I did not do was add on_0 to the end of my scenes because 1) I wasn’t sure where to do it from (Hue app or Debug API) and 2) I wasn’t sure if I would need the same scene named on_1 or something like that.

Again everything but the scenes were discovered just fine. However, this time I could not turn the bulbs off or on or anything else. At that point I called it a night and re-installed the Native ST Hue Connect app and for now I’ll have to remember to turn off routines in there when I am not at home.

Disappointing because I wanted the ability to schedule scenes based on my presence. I’ll probably play with this more. I just didn’t want to keep deleting the Hue hub and re-adding into ST.

Any ideas what when wrong?

Stacy, I had the same problem. I created a new scene using the format: short name + on + 0 (e.g. “scenea on 0”), and it worked. It is the only scene of approximately 15 on my system that can be successfully discovered . I’m in the process of renaming and testing others. Give it a try, and let me know if this cures your environment 100%.

1 Like

I renamed my scenes and created a new one all with the mentioned “on 0” I’ll get the smartapp and devicetypes up and running on the IDE and monkey around with it again either tonight or sometime this week. I’ll report back.


1 Like

UPDATE: Got in installed. Found scenes, groups, bulbs and the hub. No issues.


hope someone here can help me
I deleted my hue lights and bridge from ST app
tried to rediscover but ST app cannt discover the bridge
tried even factory resetting the bridge but no luck
I cannot get to connect my hue bridge or lights to ST please help

I feel your pain. It’s possible that you still have a “ghost” version of the Hue Connect service manager - which would prevent the ST Hub from displaying it again. It’s happened to me a whole back.

You can determine if that is the problem by ooking at your IDE - > Locations Tab - > then click on “SmartApps” (near bottom of the page). You should threeb see a page listing all of the Smart Apps you have installed. If you see it, click “edit” on the top of the page and then delete the ghost app.

If that doesn’t work, or if you don’t see a ghost, then you should contact ST support.

I’ve got the same issue in that I cannot discover bridge anymore, this happened a few days ago. I’m unable to detect bridge with ST at all with (re)connect, it works fine independently.

thanks for your response.
I tried your suggestions but there was no Ghost app that I could see on the IDE
I hope someone else can help us since ST support was not able to help me. I have 10 bulbs which is an expensive investment, hope someone can help.
Thanks again @infofiend

As far as I am aware its just an extended version of the official hue app. So tonight reluctantly I will uninstall the ReConnect app and try the official one and see if that helps. Hopefully ST support will help then if not.

Mine was working perfect then all of a sudden the scenes don’t work, check the discovery app and the bridge can’t be found. Bulbs can still be controlled though, something odd is going on

I spent the time to remove everything from my instance and rediscover them, all worked fine. Strange to what of happened but I would not be keen to do that again, took ages.

Wish there was an easy way to remove devices, ploughing through all smart apps, routines and removing each association then adding it all back again is a pain especially as your infrastructure gets bigger

I am using the factory connect app and a few days ago all of my lamps had
disappeared so everything was still in place but nothing was working with
the echo. the Hue app and other apps I use were all fine. I ran through the
discover process and let smartthings find the lamps again, enabled the
lamps I wanted to use, and everything was back to normal. This was during
the last events noted on the smartthings web site for some changes hey made
that had caused some apps to quit working. I’ve had this up and running for
over a year with 32 bulbs and no issues. I’m moving away from the echo and
using cubic directly with our smart lamps. so far so good… just waiting
on the cubic hardware to be released.

echo and hue has worked perfectly for me without ST. Added the scene handling on top with ST works well though in my opinion. Cubic looks interesting and looks to do somethings well but too much in its infancy for me

I have removed all my other hue related apps however i can add the hub and even detect the bulbs. My issue is when i go to add a bulb i get the message

“An Unexpected error Occurred”

I’m getting the same error, I just went back to the old app