[OBSOLETE] Hue Accessories and rooms using Hue Bridge (TAP, Motion Sensor, Dimmer Switch) [DEPRECATED]

Is it possible to manually set the IP and serial number?

1 Like

It would require to completely recode the app, as I am relying on the selected devices and that properties exist on these devices which is not the case anymore. The ST subsystem has changed in multiple ways, and I do not see any documentation changes.

Hi Martin,
Thx for you nice work on the Hue motion integration. Since I have my ST setup I’m using your smartapp to connect my Hue motion sensors without any issue.
A few days ago I cleaned up my Hue bridge authorizations (thought myhue) and now I have troubles getting the Hue Sensor (Connect) operational again.
I already removed the app from IDE and the phone-app and started over, but each time I enter the Hue Bridge username (grabbed from the IDE) the phone app seems to freeze and nothing happens.
The next time I try to open the smartapp on my phone I gives a message: “er is een fout opgetreden. Probeer de smartapp opnieuw te installeren.” Reinstalling doesn’t solve the issue, tried it several times.

Live logging in IDE after install and after tryping to open the app on my phone:
4:35:10 PM: error java.lang.NullPointerException: Cannot invoke method indexOf() on null object @line 977 (pollRooms)
4:35:10 PM: trace [pollTheSensors] entered
4:35:10 PM: trace [pageBridges] bridges present canPoll!}

Another log, different line in code:
17:44:13: trace[pollTheSensors] entered
17:44:13: trace[pageBridges] bridges present canPoll!}
17:44:12: errorjava.lang.NullPointerException: Cannot invoke method indexOf() on null object @line 840 (poll)
17:44:12: trace[pollTheSensors] entered

My location > Smartapps > Hue sensor connect, it also finds no devices:

Application State

Name Value
devices {}
pollSensors true
refreshCount 5

Do you maybe have some advice on how to troubleshoot further?
Thx in advance!

I am using the bridges that are connected to the ST hub. That means I am depending on ST to authorize these. You should check the bridge device or it is still connected correctly it you deleted some of the authorize apps in Hue. Maybe you have to redo the add of the bridge.

But if you read this thread you notice that problems are occurring currently with the devices returned but the platform, those I cannot solve.

Thx for your reply.
Yes I do as well. Bridge was indeed reconnected again to ST after deleting the authorizations. Lights are working fine.
I understand, it might not be smartapp related.

I’m trying to install this for the first time but after I add my bridge username the app freezes up, I can’t get back into the settings and can’t connect anything.
Seems I’m not the only one having issues, has anyone found a way to resolve it?

Hi @dudz40,

I am experiencing the same issue that I think @lenabanana is experiencing. I can add the hub to the Add New Things, it shows up in SmartThings Classic app and in IDE, then when I go to add it to the Hue Sensors App, it crashes.

The only way to fix it is to force remove the Hub from SmartThings Classic App.

Here’s what I think changed. I am looking and I have it working at a friends house, so I took a look at his configuration in IDE. In HIS IDE, the hub device has a Data sections that shows IP, MAC, Port, ssdpTerm and username.

In My IDE (brand new SmartThings v2 hub, brand new Hue v2 Hub), the data section only shows IP, Model, Port and username.

What is missing in newer configurations is the MAC Address of the hub. When I look at IDE - My Locations - Installed Smart Apps - Hue Sensor (Connect), I notice that what I think you are doing is keying the hub to the last six of the MAC address…


For newly ‘added’ hubs, is it possible that SmartThings may no longer be getting the MAC address data, and maybe that’s why you can’t key on it? This results in a z_BridgesUsernameAPI_null instead of z_BridgesUserNameAPI_XXXXXX. I notice in the code, it appears that there is something called Serial Number. (Line 129 “Serial:${serialNumber}”) which is how the hub seems to be generated. Is it possible that this is no longer accessible to your code, and thus resulting in NULL?

I think that might be the problem with what’s going on.


That is correct. The hub devices do not give back any of the fields anymore b that the app needs to do it’s thing. I have tried to repair it but cannot find an easy way. I need to think if it is worth the effort as I have left the ST platform and only have a small config running for helping out users of my apps. But these platform surprise changes are not helping.

Verzonden vanaf Samsung-tablet.

-------- Oorspronkelijk bericht --------

1 Like

What a great app. I was looking for a way to use these Hue Switches I got without having to buy the Hue plugs (to control non Hue Lights). This set-up is “working”, I set up two new hue switches connecting to two plugs, and made ST routines to use button 1 for on and button 4 for off. Problem is, it takes 30-60 seconds for the button press to be executed. Is that normal?

1 Like

Your app is fantastic and did work very well for my for some time. I need a way to keep the Hue Dimmers connected to the Hue Bridge but also connected to the Smartthings app which you had managed. I’m having the same issues as others now, I’m getting the message 'Error saving unnamed page. Please contact SmartApp developer". Any ideas if I can fix this somehow? I appears after typing in the ‘Username for API’. Any help would be welcome.

1 Like

Man I really need my motion sensors back into st, this seems to be the only solution minus not using a bridge, anybody find a work around?

The Hue motion sensors connected to a hue bridge will be visible to both Alexa routines and HomeKit, so those are two possible alternatives. If you aren’t already using homebridge, I recommend looking into Alexa routines. :sunglasses:

1 Like

Looking to use them to trigger home mode in smartthings. My Samsung motion sensor is burning batteries hard lol

You can do that via Alexa routines: have the hue motion sensor connected to the hue bridge trigger an Alexa routine (not a smartthings routine) that turns on a smartthings virtual switch, and have that virtual switch coming on trigger an automation that changes the mode.

1 Like

Any idea what happened here? These used to work fine and, in the last few years, something has happened to them and they destroy batteries in a matter of hours.

I believe I stopped noticing it, not sure what changed

1 Like

Did you ever get the busch jaeger hue link working from ST?

Unfortunately no. IF I remember correctly, I had issues with buttons mapping (the numbers detected when pressing the buttons didn’t make sense to me). I couldn’t figure a logic out of it.

A different community developer has created an edge driver which works with the new architecture and has some similar features. It does require a hue bridge, it runs locally, it can access rooms and scenes created in the hue app, and supports a number of different devices connected to the bridge. So it may be a good substitute for the new architecture.

[ST Edge] Philips Hue LAN [BETA]

Thanks for the link @JDRoberts . It also utilizes the new Hue architecture as well so it supports their newer hub (square)

1 Like