[OBSOLETE] - Hive (Connect) V3.2c (British Gas Hive)

Odd that it was tripping over that line, the unschedule should remove the “5 minute poll” before we re-create it. I assume to stop any running concurrently from from creating too many polls.

I’ve been having a 1:1 chat with barron and was going to do some live logging together but we haven’t found a time that works. After that hopefully will have a “stable” version.

re polling too frequently & affecting battery - this isn’t an issue because we are polling the Hive web service, not the TRV’s themselves. So the TRVs via their hub update Hive web, we update against Hive web…

Hi All,

I changed the line in the TRV DH as above and so far so good. We’ll done to all and thank you.


No problem, took me a little while to figure it all out with being new to this but once I figured out how to use the IDE etc, it was pretty straight forward.

@bibbleq I agree it is strange why it trip over on this line of code, now that I understand what it is for. Still, removing it seems to have done the trick

Tried your code alternation and my TRVs are still going offline after 15min
But when they are online I’m getting no data from the TRV’s so makes little difference I guess.

Infact it seems anything on Hive Connect now goes offline randomly even the Thermostat and Hotwater which used to work flawlessly.


Did you change the code in the smart app or in the TRV?


With or without the modded line they go offline within 15mins.

Since removing the TRV’s from Smartthings the Thermostat/Hotwater have become stable again.


That’s very strange. Are you saying that smartthings made Hive act incorrectly? If so in what way?


No, devices in the Hive App were fine only in Smartthings App did they report offline.
Wonder if the device has changed, only purchased mine last week.

Code is modded…


The devices have not been updated yet. If you check in the hive app you should still have hardware version 1

You should also have firmware 10D. If you don’t then get hive to push an update. That might fix your issue.

Figured out what was causing it, never had problems before but it turned out to be proximity to other hubs I have. By moving the Smartthings, Philips Hue and Hive hubs apart instead of stacking them all is well now.

Great that you’ve figured it out. They are all Zigbee if I’m not mistaken so I’m guessing they were getting all confused being so close to each other.

Glad you got it sorted.

anyone got an update on this NULL issue, I seem to be getting it now.

I believe it has happened as I have removed a device from HIVE before removing it from the hive (connect) Smartapp, this left an orphan device in Smartthings, which I removed manually, however this has left a NULL device in the connect app.

Anyone know if there is a way that I can clean up the device list so I can add a new bulb that I have added?

@Alyc100 or @bibbleq do you guys have any ideas?

Hi All,

Has anyone managed to incorporate the Hive quick tap functions into smart things?

I have a quick tap set for bringing all trvs into manual and it would be handy being able to use that from Google etc.


Have you looked at hive (connect) v3?

Edit: Lol. Silly me. I just realised this is a post on that page :slight_smile: doh. Sorry.

I’ve tried the feaute inside the connect 3 app but it just says the page cannot be displayed!

the what? Not sure I know what this is, or is it a typo

Typo… Feature

says page cannot be found… where does it say that?

In the Hive app.

My apologies I’m not being accurate at all.

It says “something went wrong”
“we can’t load your screen right now”

I’m guessing you have tried to remove the Smartapp and reinstall. are you also installing all the device handlers that are required?