[OBSOLETE] GoControl Smart Wireless Light Switch WA00Z-1 (see post #79 for Nov 2020 version)

Hi @mtnbrit,

The GoControl Smart Wireless Light Switch is just that; a Wireless Light Switch with 2-Buttons and 2-Actions per button. So IMHO/experience you can only perform the actions I listed above. I actually do that. But if you use WebCore, you can also have a Piuston perform actions on the button push/hold based on time of day or mode your house is in.

E.g., Mode morning
Button 1 - PUSH -> Light upstairs is ON @ 30%
Button 1 - HELD -> Light upstairs ON @ 50%

I’m new to Smartthings. How do I pair this WA00Z-1 with Smartthings to use to control Phillips Hue lights? Any step by step instructions available? Thanks!

I can’t seem to get this one to work. I’ve tried installing from the GitHub repo and also creating manually by pasting the code.

The device pairs, but I don’t see what I expect. When I view the device in SmartThings and go in to the properties, there is a big blue button on the left, two electrical outlet icons on the right. Beneath that is a dimmer slider. When I used this device in SmartLighting or other smartapps, nothing happens. I’ve removed and restarted several times. Am I missing something?

Note, steps I’m taking is as follows.

1.login to IDE, select location and hub.

  1. Add Repo. Owner: ajpri, Name: ST-GoContWirelessSwitch, Branch: master.

  2. Add device handler in IDE… either from code or from GitHub ST-GoContWirelessSwitch. (same result either way). Save and publish for Me.

  3. Add device in SmartThings, press button on GoControl and let them pair. Device adds and is as described above. Does not show two buttons, just the one button, the two electrical outlet icons and a dimmer slider. The device does not function.

1 Like

Which version of the SmartThings app are you using?

1 Like

I use both apps. The behaviour I described is in the classic app. It’s even more broken in the Samsung app.

1 Like

Any thoughts? I’m eager to get this working. :slight_smile:

Does anyone actually have this working?

Hi, is this DHT still working? I’m thinking about buying some of this switches but I want to make sure they’ll work with smartthings.

I just got it working after a lot of trial and error. All I ended up needing to do is (in device, in the ide) switch the version from published to self published and then change the device type to gocontrol wireless remote switch. Once done the switch works fine. I was able to setup my automation using smartlighting with no issues and with both buttons pushed as well as held.

1 Like

Once it is set up the device will still not give you any options but you will be able to set it up to work as expected in the smartlighting app.

Hmmm… my “type” drop down doesn’t show GoControl. Any suggestions?

Install the DTH and self publish.

Also, custom stuff is at the BOTTOM of that alphabetical list. So don’t look in the Gs, just jump to the end.


Anyone figured out how to get a long press to trigger in Webcore? I can only get single presses to register. Holds trigger as normal presses.

Wow, that was complicated!
Thanks to the developer of the DTH and all the people who answered our questions but…
Is there a place where all the correct information is gathered so that users don’t have to go through an entire thread of comments to make things works?

I just bought this and connect it. It is working, but sometime need to press two times for the button to act after a long inactive period, possibly like a wakeup issue.

Here are the simple steps I followed.

  1. Add the device to SmartThings (follow steps from the device’s manual)
  2. Load the DH in the top of the thread into the Smartthings system using IDE.
  3. Edit the device in IDE and assign the new DH. Now the device will show up as a two button controller with both push and hold event capabilities.
  4. Create different smart lighting policies (using individual device or using scenes) for all the four button positions (Button 1 : pressed and held, Button 2: pressed and held)
  5. That is it.

This button also has double-click ability. How would you use this feature with webcore? In webcore, I can only see press or held for a switch action. How could I know if a button was double-clicked?

1 Like

Has anyone figured this out? Not sure why it should be this complicated. Can one not add as a device with 2 buttons without anything else? I can pair this and I have added the DTH before and after as both published and self published, but still cannot get any buttons or anything to simply turn on or off either at the device or in any app.

Help would be much appreciated!

Additionally, I am guessing, this won’t physically turn a switch on or off, correct? If so, then it won’t work for me.

I struggled with this for a long time. The posts after mine in this thread pointed me in the right direction to get this working.

I have this switch working well, and it was super easy to setup and control using Advanced Button Controller (much easier than the Smart Lighting app for what I needed in this particular instance. I linked it below but my steps were:

-added the github for this DTH
-Install DTH
-Add switch to classic Smartthings app
-Added Advanced Button Controller (ABC) app
-setup what I needed through the ABC app.

I paid 15$ on Amazon for this switch. I’m not sure how long it will last but first impressions are great. 15$ for a battery operated switch that fits over existing switches and essentially has 4 buttons for 15$ is well worth it. Good luck to anyone setting this up!

[BETA] Advanced Button Controller (ABC)

1 Like