[OBSOLETE] GE/Jasco Z-Wave Plus Dimmer Switch With Double-Tap

Greatly appreciate you keeping tabs on the conversation and continuing to help out when you’ve already moved on!


Thx Chris!

PR has been merged


Really appreciate this! Any way we can get the update done on the similar on-off switch DTH?


^ this plz

@mwav3 Tim -

Do you have time to check and see if the same intervention works on the other DTH @RobL lists: [RELEASE CANDIDATE] Jasco/GE Z-Wave Plus On/Off Switch (14291) With Double-Tap and Associations
and then send Chris a PR for it? He’s being nice enough to host and pull the changes in, the least we can do is help him out. Also - there may be an additional fingerprint to add:
[RELEASE CANDIDATE] Jasco/GE Z-Wave Plus On/Off Switch (14291) With Double-Tap and Associations per @Jimmy8881

There is a complication with that switch - see [RELEASE CANDIDATE] Jasco/GE Z-Wave Plus On/Off Switch (14291) With Double-Tap and Associations
Apparently Jasco went off in a different direction with the newer switches using scene control vs basic commands for double tap. The poster of the linked comment wrote a new DTH for the updated version.
So, technically two different DTH’s might need to be updated. I have updated one of my older ones using the Nuttytree DTH and similar lines of code added to the dimmer, and it is working. I may have one of the new switches that @gobio wrote his code for in my garage - I never had a need for double tap on that switch. I can check with that switch when I get home.

In the meantime, I’ll send Chris the pull request for what I changed on the On/Off switch, but just be aware it may not work with newer versions of that switch.


So I just created an automation in the new app. It appears “Pressed” is equivalent to a double tap with this updated DTH. There is no way to choose which button like with Smart Lighting. Is that correct? I am going to move this back to Smart Lighting since it seems to be the more configurable way to do double-taps. I did notice for my on-off switch the DTH actual does expose double tap on and double tap off as options in the new automations screen. However, they aren’t working as we know. Would there be a way to do the same with this dimmer DTH?

Correct, use the smart lighting app or webcore. You can’t pick the buttons on the automations page. That seems to be a bigger problem with the actual UI in the new app. Developers that have been writing code on this platform for years can’t get their DTHs to display buttons properly in the new app. My Inovelli switches don’t allow me to pick button numbers in the automation screen either and they know what they’re doing over there. So if they can’t get theirs to show up…


Please see my related post under the on/off switch for an update on the DTH and that switch [RELEASE CANDIDATE] Jasco/GE Z-Wave Plus On/Off Switch (14291) With Double-Tap and Associations

Can now confirm this allowed me to create new SL automations with double-tap in the new app. Thanks guys!

1 Like

We should’ve fixed this :slight_smile:

Appreciate the compliment – I’ll pass it onto @erocm1231!

1 Like

Thanks @Eric_Inovelli! You guys are great and I love your products, I just ordered two more of your switches.

See everyone, that is the difference between a company that continues to provide support and assistance for their products, and one that doesn’t. Could anyone imagine the CEO of Jasco commenting on this board about their switches?


I ABSOLUTELY buy based on the quality of support. EVEN if they’re a little more expensive.


@mwav3 and @nathancu thanks guys – we really appreciate it!

1 Like

I’m making the switch to the new app, and trying to figure out the option formerly associated with Double Tap Down/Button 2? I’ve gotten the double tap up action to successfully trigger a scene by using “Pressed” as the option for the switch, but which trigger option do I use for Double Tap Down/Button 2?

I’m only showing one device, and no option to select a particular “button” number

If you update to the newest device handler here https://github.com/nuttytree/Nutty-SmartThings/blob/master/devicetypes/nuttytree/ge-jasco-zwave-plus-dimmer-switch.src/ge-jasco-zwave-plus-dimmer-switch.groovy you will be able to access both buttons now, but you’ll need to use the smartlighting app or webcore to do it. The automations part of the new app at the moment can’t recognize multiple buttons.


Thanks - really appreciate it. So, yeah - it seems like I’m up to date then. I was able to get the device handler updated, and now can access it via the smart lighting app - a bit of a pain as the automations aren’t on the automations page, but I only trigger them with switches anyway, so all good. Thanks again.

I’m struggling to get this working with a Hue bulb. I had it working fine in the Classic App (double tap up/down to turn Hue bulb on/off) now nothing I configure seems to work. I can get the double tap to work if I assign a z-wave switch.

I’ve gone as far as creating a virtual switch --> assigning the virtual switch to double-tap --> creating an automation to run and turn on Hue bulb. Well it all works until I assign it to the double tap.


Here’s a few things, some you’ve probably already tried but just throwing them out there.

First, I would assume you have the latest handler - available here https://github.com/nuttytree/Nutty-SmartThings/blob/master/devicetypes/nuttytree/ge-jasco-zwave-plus-dimmer-switch.src/ge-jasco-zwave-plus-dimmer-switch.groovy
The old one had issues working with the new app

Also, Jasco made a bunch of different switches. The older non-zwave plus swithes don’t support double tap. There were a lot of “in between models” that do through an association on group 3. This DTH works for those. The brand new ones, from what I’ve read on the official Zwave listing page, use central scene control for double tap. I don’t have the brand new ones so don’t know for sure how those work, but assume this DTH would not give you double tap on a new one. If you go in your IDE, and go to the “raw description” under the device, copy that entire line, and paste it into here as a reply I can confirm if the model # works for this DTH.

If this worked before, it probably is a compatible switch though. The way Zwave associations work are when you associate two devices, it sets up direct communication between the devices and bypasses the hub. Multiple devices on association group 2 mirror each other - ie they act in unison. Association group 3 is double tap. When you associate two devices on group 3, they will communicate directly by double tap and bypass the hub. Its a nice feature as these associations still work even if the internet is down or hub is unplugged. However, this will only work with Zwave devices, and not Zigbee or virtual swithes as those are through the hub. So if you try and add a non-zwave device to the association group by entering in its device ID, it definitely will not work.

What the Nuttytree DTH does is take the hub itself and puts it in association group 3, and then create virtual buttons that can be used in various other automations. It’s a bit complicated, and also impressive coding by @nuttytree that he was able to figure that out and make it work. As mentioned above, you need to use the smart lighting app or webcore, as the new automations section of the app won’t let you select different button numbers.

I have a switch that controls a virtual device with Double tap (the virtual devices sends an IFTTT command), and I have one that controls a scene, using the new app and new DTH. I don’t have any Phillips Hue but I can’t see why this wouldn’t work with those.

Another thing to try is create a scene in the new app with your Philips Hue light. From the home page of the new app, click the menu option at the top left. Click “scenes” (it should be a picture of a sun). Create a scene adding your Philips Hue light to do what you want it to do - color, on/off, etc. You can create two scenes - one for button 1 up, another for button 2 down. Then go to your smart lighting app by clicking “smartapps”, then “smart lighting”. Delete out any automations from there that aren’t working. If the automation is corrupt and won’t open, you may need to delete them from the IDE. Click “new lighting automation”. From there it asks what devices you want to control, or activate scenes. Click “activate these scenes”. Click the scene you created in the previous step. Under “select trigger”, select “button”. Under “which button” select your Jasco switch. Button number should then show up - button one is double tap up, button two is double tap down.

Hope this works but if not let me know the model info of your switch from the IDE so I can look into it more.