[OBSOLETE] Fully Kiosk Browser Controller (DTH)

Forgive my ignorance- wouldn’t setting the password requirement to “false” in line 71 be sufficient? I am not sure what would need to be edited in the other two lines. So far still not getting a response from the device and trying to identify the roadblock.

I was using LANnouncer before this but got tired of it randomly stopping. I got It working but I am struggling with something very simple. Is there any way to send a chime to this in the new SmartThings app? I was using BigTalker2 using the @#ALARM=chime command on door open events. Is there any particular code I can use in BigTalker that will invoke the chime in the FullyKiosk talker? Or maybe there is a different easy way to do a door chime?

Searching for chime in this thread.

So i have followed instructions to the T. but cannot get the sound file to work with just a plain beep test.

Full Kiosk is configured correctly with Plus settings and remote admin
The file has been transferred correctly to the tablet download folder
the play beep function on my smartthings mobile app sends instructions to the FK tablet however:

file:///sdcard/download/chime.mp3 on Amazon Fire tablet gives an error “failed loading sound: wrong url or unsupported format”

Anyone have any clue? I am guessing the URL format has probably changed for Amazon Fire tablets somewhere

I’ll have to take a look at it, I’m getting the same thing but my smartapp commands using the chime do play the file.

Likely a code error or Fully changed something.

All this app’s commands that play sounds give this error, but it’s working in Hubitat where most of my system running. Probably why I did not notice it when it began failing.

Update1: This worked when I set it up a while ago, and the ST vs Hubitat code is the same. I suspect what may have changed is ST URL encoding.

Thank you so much for looking into it.

After a bit of detective work, including:

  1. installed the outdated version that worked in Hubitat, but it failed in ST. fixed the error but continued to get error message on Dining Room Fire device where did my initial test when this problem was reported.

  2. tested on my 3 devices with new and older device handler versions
    results: always worked on Android phone, always worked on Hallway Fire tablet, always failed on Dining room Fire tablet—WTF???

  3. Hallway Fire was running Fully 1.30, Dining room Fire 1.29.something., Android device 1.36.1

  4. Updated Fully on Dining room Fire to 1.36.1. Sounds produced, no error messages.
    Please check the version of Fully on the failing Fire tablet, update Fully if needed, then post your results

  5. For the record I am currently running with the latest version of this Device Handler, V2.03

After this experience, it feels like it’s time for another glass of New Year’s prosecco!

My Fully was already on 1.36.1 on the fire tablets with this issue and the device handler is also V2.03 (its tied to github and updated).

In that case, it’s likely that:

  • The files are not installed on the device or
  • The name of the file is incorrect in the settings.

Please verify and post your results.

I recreated the error by changing the name of the Tone audio file setting from
saved it then tapped Beep, creating no sound and an error message

Just found this in an earlier message
please change download to Download
File names are case sensitive

I figured out the issue:

  1. First i needed Fully Kiosk 1.36.1 for fire (i was using Android version)
  2. the syntax for url that works for me is just /sdcard/Download/chime.mp3 (no file:///)

So all working now. Thanks for the support and help!

All my devices use the standard Fully android version 1.36.1 or 1.30

It plays the tone with either
file:///sdcard/Download/chime.mp3 (the documented format)
/sdcard/Download/chime.mp3 (this is new for me)

but not

Hi Arnb. First of all… thank you for the DTH and all the support you give. Its amazing.

Second, Im having an issue getting my latest Android tablet setup. I have 3 tablets running great, but this latest tablet I cant seem to get remote access working. I have followed the steps above (just like my other tablets) and cant seem to active the remote access features (launch app, turn off screensaver, etc). I have the device created, IP entered, server password set, but I just cant seem to reach it via webcore or the ST app. Any ideas what could be different than my other tablets (Galaxy Tab A 10" 2019, Fire HD8, Galaxy Tab A 8").

Device: Samsung Galaxy Tab S2 10" (SM-T818V)
Android Version: 7
FKB app version: 1.36.1
DHT version: 2.03

Thanks in advance!

Hello Bellevino

Here are a few easily overlooked things that may cause this type of failure:

  1. IP address mismatch. Verify the tablet is actually using the fixed IP specified in your router, or perhaps a MAC id mismatch.

  2. Fully is not installed and active in the tablet?

  3. The tablet’s volume is muted or zero

Other than that, no idea why.

PS last week I experienced issue 1 for a day or so, after moving a Fire Hd8 onto a Wifi extender and the thing went silent.

Thanks for the tips.

  1. The IP and network password are correct. How do I check if the MAC id is mismatched?
  2. Fully is installed (and Plus paid for). When you say “active” do you mean running in the background/foreground?
  3. Volume is up. Im pressing every button on the device page on the Classic app to test the connection (including screen and screensaver on/off - no volume needed).

Any other ideas are helpful if you think of them. Not sure why Im having issues with this tablet and not the others. Could the OS be too old? (Android 7.0)? I did just buy and setup this Galaxy Tab S2.… but Im not sure why that would matter.

On my Android 9 go to settings

  • Search for MAC or
  • go to Wifi Preferences or
  • go to About phone
    Compare to what is in the router IP reservation table

Does not matter where, must be running. Paid and Unpaid both work.

Don’t think so, I have older Samsung phone working with Android 6

Also in a regular browser you can check connectivity.

Just put in
http://[fk ip address]:[port]
and you will be presented with a logon screen. Put in your password and verify all works.

If this doesn’t work then the driver probably doesn’t work.

1 Like

I just got this set up on a fire tablet and its awesome. What im struggling with, though, is figuring out the syntax to open an app. I want to have an IP cam viewer app or chrome open, depending on the device, but im not sure how to launch it with the config. I searched and couldnt find anything in this thread, though i could have overlooked it. can anyone shed some light on how to figure out the syntax for an app to open it? also am i limited to one app per device? and if so, other than creating more devices would there be any issue with creating multiple devices for one fire tablet, but configure each to open a different app? Chrome, IP cam viewer, Ring, nest, etc, depending on whats going on and when in the house?


Go to the web version of play store. Look at the URL. See how this says org.mozilla.firefox? That’s what you enter in the device settings to open an app under the setting application to launch.

@arnb can you create multiple devices in SmartThings all pointing to the same Fully browser? Reason being so you’re not just limited to one app you can open? Or is it possible to change the handler to add more options for apps?