[OBSOLETE] Foscam Camera Device Handler Universal DTH with Motion Detection - SD (FI89xx), HD Ambarella FI98xx, FI99xx, Cx, Gx, Rx, Ex, Zx, Fosbaby

First let me say I am so excited to find a group of home automation people like me and would like t thank you all for building this site and writing all of this great custom code. I had a Vera and I returned it for a ST. So happy now I have a Harmony and an echo too. I guess now all I need is a hue :slight_smile:

RBoy I will PM you the logs.

Thanks again for such a great community

1 Like

I should have seen this earlier, there in lies your problem. You’ve entered your ip/hostname incorrectly:

All you need a simple

myhost.com

or

X.X.X.X

EDIT: Updated the DH to use the words Hostname instead of URL in the input description to avoid confusion.

No in the screen shot and picture I sent you I blanked it out. It was set correctly. I will send it to you with the username and password since I can change them later

I do see that my Wifi is dropping the connection every once in a while. I will hard wire the camera later but it only goes down ocassionally. Looks like the wifi unit in the camera is going bad. :frowning:

Your issue is that you’ve entered the full URL instead of the hostname, your logs are showing it. I would suggest delete the device and start over since it also caches the address to reduce overhead on the platform and improve performance.

The hostname is http://nysaint.com

Can you tell me what I should be using I don’t understand

Actually it is http://nysaint.com:6500

In the IP Address field:
nysaint.com

In the port field:
6500

Should I just use my external IP address with no http

Yes you can do that also

I just tried with my external IP address only.

No luck. So frustrating

.

I can try to do the entire process again if you think that will help.

Do you noticed your “Settings”, “IP”, it’s showing that you’re entering the FULL URL instead of just the hostname or IP address. That’s your issue.

BTW you’re also publicly posted your username and password in the same image, I would delete it.

I will change it but I think I understand just the IP address. OK let me try that

OK that fixed the IP errors but still the NULL error and no video. I surrender. :slight_smile:

Your settings looks like they’re really messed up. Your video stream is returning null for it’s address. Like I said delete your device and start over, it’s working for everyone else. Give it a break and start over fresh with a clear mind :slight_smile:

OK thanks so much. I will start the process over later.

1 Like

Just to clarify - I have my hub replaced, but it isn’t due to the firmware or anything related to Foscam. The hub was dead/offline - when I turn on the hub, it has red light on for 1-2 seconds, and no lights after that. The hub is always in offline mode.

I guess it probably won’t get replaced if it isn’t dead.

Thank you for your patience. I reisntalled and now I connected and get video. The IR night and color button works and the image is now live. The Pan and Tilt controls are not working and when I click and make it full screen it is black but I am finally making some good progress.

Any ideas why the pan and tilt dont work? and why when I make it full screen it does not work?

I will play with the settings on the camera but finally I have an image.

1 Like

I lowered the camera resolution from 720 30 fps 4M to
720 12 fps 20k and now I can get full screen on my iphone its no longer black !

Also tested and the cruise controls are working !

Still no response from the up, down, left and right.

So glad you guys wrote this plugin it looks great.

1 Like

That’s the part which the FAQ’s referred to as highly dependent upon the phone’s capabilities. Some configurations work on some phones and not others.

That’s just a communication issue, sometimes the connection drops packets or times out. Try to reboot your camera/router and that usually fixes it. Camera is very sensitive to the communication.