[OBSOLETE] Foscam Camera Device Handler Universal DTH with Motion Detection - SD (FI89xx), HD Ambarella FI98xx, FI99xx, Cx, Gx, Rx, Ex, Zx, Fosbaby

If I set the interval for the Foscam motion check too high can it cause my hub to disconnect frequently? I set it to 5 seconds yesterday and got bombarded with “your hub is disconnected” notices. I have 3 internet connections that round-robin and fail safe onto each other so I’m quite sure I didn’t actually lose any connections (also my pfsense logs show nothing as well).

If I disable motion detection the issue seems to resolve itself. Any ideas?

I’ve been using mine on 5 seconds, tried one second as well and didn’t notice any major issues. @RBoy would probably find this interesting.

UK or USA hub? Someone higher up in the thread was having the same problem with their UK hub if they went below 5 seconds.

They also had problems below 60 seconds sometimes during the day.

US Hub, and even at 30 seconds or 60 seconds it still does it. I’m using the Foscam C1 if that helps.

In regards to my post directly above this

I’ll add some more info in hopes that it will help:
I’m running the latest version of both the device handler and SmartApp (but the issue has been ongoing for a month or so, I’ve just relegated myself to not using it).

The C1 is running the latest firmware, and it’s hardwired to my network.

The camera has two smart apps, security and the motion sensing monitor.

Here’s a picture of the notifications (and how frequent they are…) I get. From what I can tell the Smartthings hub is crashing and restarting, staying up for 15 or so min and then crashing again.

I’ve tried all the troubleshooting I can think of, uninstalling all of the components and re-installing. multiple camera factory resets and re-positioning. I’d be willing to give access to RBoy (to either the camera or my smartthings setup… or both, whatever) if it would be beneficial. Otherwise I’m all ears on suggestions.

Wow, really strange. I have 2 C1s and a 9821and all 3 are being checked every 5s with no problems.

I think at this point contacting support would help, send in as much info as you can or you might ned up going back and forth a bit. In the meantime what shard are you in? (server shard when you login to IDE).

1 Like

So at this point here is my thought. The only think that you’re doing is increasing the polling frequency I.e. Reducing the timer period from 60 to 5. What this is means is there is increased frequency of communication between the hub and the cloud, that’s about it.

If this increased communication is causing a crash and reboot there are one of two things happening here. Either the firmware in the hub is buggy or the hardware could be defective.

5 seconds is what everyone else is using for a very long time and there are only now two reported cases of this. This would lead me to believe that likely the firmware isn’t an issue (or if it is its a boundary issue or a race condition which I believe it will be hard to get ST to accept / investigate) and its possibly a bad piece of hardware.

When you approach ST support they will first ask you to uninstall the app and then say community apps are not official apps and hence just stop using it, it’s not a ST hub issue.

All I can say is that with the first user they replaced the hub on insistence from the user and IMHO justifiably. If calling an official API is causing it to reboot and if only two folks have reported the issue amongst a vast number of users it likely isn’t the app but an underlying issue. As @ZebraBlinds would say I would talk to support and give them as much information as possible including sever shard etc and if they truly interested they will try to track down the real issue why increased communication with the hub causes a hub crash.

The only annoying bit, highlighted below:

1 Like

Could it be an internet speed issue too? If it doesn’t receive a response from the cloud before the next 5 second poll?

1 Like

possibly, but highly unlikely since if that was the case, normal web browsing would be affected as well (on your pc or phone)

EDIT: it also wouldn’t explain the hub restarting

1 Like

I installed the program and am using a Foscam FI9828P in SmartThings. I have installed both the Motion Piece and the SmartApp. I am using an iPhone 6S and when I click on the camera I get a Black Sceen with a message in the upper right corner that says Active but there is no picture. I then click the white play button in the middle of the Black screen and then I get a spinning wheel and then an error that says “There was a problem retrieving the livestream” The Camera is set on port 6500. when I use this URL http://IPADDRESS:6500/cgi-bin/CGIStream.cgi?cmd=GetMJStream&usr=xxxx&pwd=xxxx in a chrome browser it works. I have been banging my head against the wall. I really love SmartThings, but its camera support is lame. Any ideas ?

I have three redundant internet connections that fallback on each other in case of a disconnect (and also use round robin in data handling). Two are hardline one is 4G LTE. Basically, I’ve never lost internet connection in my home… even during a power outage. I’ll contact ST support and see about getting my hub replaced.

Please see the first post for basic troubleshooting steps, it a good place to start.

did you change the port for the video stream itself or the camera admin interface?

I got sent an email to support with all of my troubleshooting tips and any information that might be useful, I was also careful to generalize the issue so they can’t blame it on a 3rd party app. So, my issue is “The hub crashes during increased API calls” not stating specifically what app I’m having issues with, as I’d have issues with all apps that require this. We’ll see what they reply with. I’m considering running up to Best Buy tomorrow and buying a second hub just to verify to them (and myself) that it’s a hub side issue and not the apps causing it.

1 Like

Hello RBoy. OK I deleted and reinstalled everything still Black no video but I did go to the logs and here is the error
error java.lang.NullPointerException

It gets the IP address and says request was successful now if I can just figure out what this error is I think I can fix it

error java.lang.NullPointerException

Thanks so much for writting this. I am excited to get these working I have 3 of these cameras.

Not anything I can fix. This looks like a coding error

error java.lang.NullPointerException

Can you please PM me the IDE live logs. Also hit refresh once to ensure it picks up the latest settings.