[OBSOLETE] Fibaro Motion Sensor - New device-handler with all settings and auto sync feature

Where can I find the code, is not on the github anymore…

I cannot it this post no idea why… I just reorganized the repo to be compliant with smartthings GitHub integration.

1 Like

I cannot find the code on your repository… What am I doing wrong?

@Simone_Bruno One you click the link above go to the one that says Devicedrivers and you will see the Fibaro Motion Sensor Code. Click to open and copy to your IDE. Again you will see the devicetypes/cyrilpeponnet that the link you want. Hope that helps.



@CSC Why I can’t edit the first post?

I’m sorry, previously I thought it’s depreciated but didn’t realized it’s for different version. I can’t change as as well.

@JDRoberts, can you help us to update the subject, remove the [Depreciated]?

Because it’s two years old. Only @slagle can change that.

I think your handler is the best one still… Anyway I was adding and removing my two fibaro (ver 2.6) that first I got stuck into a constant motion and now I cannot get temperature or luminance… just motion… any fix?

tried take battery out, reset the fibaro



Thank you for your work on this device. I have installed the Device handler and nothing on the SmartThings app when looking at the device has changed. Am I missing a step? I have version 3.2. The motion sensors seem to be working but I don’t have the nice UI.

Did you switch the device to use the handler in IDE?

I thought all I had to do was save and publish. Was there another step? I was reading that I am supposed to use the simulator to install the new handler. I tried doing that then motion froze up on me with the new UI. It didn’t seem to work right.

Okay I changed the device type under my devices. Now it says needupdate YES. Looking for an answer for that now…

You need to check yr Fibaro motion sensor version before deciding the correct handler to use

I’m looking for some help here. I’ve been reading through different pages related to DTH for my Fibaro Motion Sensor ZW5 v.3.2. I’ve tried a handful of different DTH for this motion sensor, as I would like to be able access the device’s configurations without needing to purchase the Fibaro Home Center (that would be my last resort).

The problem I’ve run into is each DTH seems to come with different variations of flakey readings: one will say my battery life is 100%, one will say it’s 1%, some will read 200 lux, some will say it’s 10 lux, some won’t sense motion, some will say there’s permanent motion.

It’s very possible that I’m missing 1 important step somewhere in the process of publishing the DTH and associating it with my device. Using this CyrilPeponnet’s DTH as an example, here’s what I’ve tried.

  1. Add the Fibaro Motion Sensor to SmartThings mesh.
    Go to https://github.com/CyrilPeponnet/smartthings/blob/master/devicetypes/cyrilpeponnet/fibaro-motion-sensor.src/fibaro-motion-sensor.groovy.
  2. Copy the code from this page.
  3. Log into my SmartThings device IDE (I don’t know the proper name to call it - sorry!) at https://graph-na04-useast2.api.smartthings.com.
  4. Go to My Device Handlers.
  5. Click on Create New Device Handler
  6. Click the From Code tab.
  7. Paste the DTH code into the blank space.
  8. Click the Create button.
  9. Click Publish --> For Me.
  10. Go to My Devices.
  11. Click on my motion sensor device.
  12. Click the Edit button.
  13. Select the custom DTH from the Type dropdown box.
  14. Click the Update button.

This is where things feel like they go all over the place in terms of any next steps. At this point, the interface in the SmartThings app reflects Cyril’s DTH. The problem is that it’s permanently reflecting that it senses motion and that it’s in a “Pending” sync status. I’ve tried facing the motion sensor at a wall to ensure that it can’t possibly see motion, and yet it still reads that it’s sensing motion.

I’ve read that you either need to wait 2 hours for the auto update, or you can wake the device up and force a refresh. I’ve tried both, and neither the permanent “Motion” status nor the “Pending” status update. I’ve basically left my motion sensor in this state and went to work today, came back, and it’s still reading these same states.

Am I missing something? Or do I just need to cave in and purchase Fibaro’s Home Center so that I can have full control of this motion sensor without sacrificing it accurately picking up motion and light levels? Also, I currently only own one motion sensor, as I wanted to work out the kinks. I do plan to buy more motion sensors to cover the rest of my house, once I figure this thing out.

I just wanted to follow-up on this post, in that I’m astounded that 3 months later I never got a reply to my question. I posted my question in a very well thought out manner, which made it very clear that I at least made some effort to solve the issue on my own before reaching out to the community. I had heard that this community was incredibly helpful, but this experience has made me question the relevance of the claim. Needless to say, I’m very disappointed.

1 Like

For v3.2, you should not be using this device handler.
Cyril DTH doesn’t work with the v3.2 sensor.

Use the below device handler.

can you set the wake interval?

Hi to all,

I’m having two FGMS 001 (old version not +) connected for which I’m not able to touch the parameters as they do not appear anywhere (mean SmartThings app or IDE). The default DHT which is loaded is the Fibaro Motion Sensor. Anyone having any idea if this should be the correct one or do I have to use anything else ? I tried to download the DHT on the top of this post but the link is dead.

Thank you

Ive started using the stock dh to get local processing and use [BETA] Z-Wave Tweaker
To change settings

1 Like