[OBSOLETE] Enerwave ZWN-RSM2 (v1 & v2) & RSM2-Plus —Smart Dual Relay Switch Module

I did have all of that configured, but am trying to recreate everything to catch what I missed. First question is which version of the DH should I be using? These are brand new RS2’s running 5.12fw.

The issue I am running into on this effort is that it will successfully include the switch, and create the child switches, but the SmartApp doesn’t detect the endpoints.

Thanks, Erik

If you are using a device handler with child devices, then you shouldn’t have to install the SmartApp.

Thanks, I actually figured that out (finally) after digging around. It turned out really good because someone has also created a SmartApp for a whole house fan that takes care of what I was trying to automate.

Just to tell Eric that I installed his virtual device sync and device handlers and my old RSM2 is working like a charm. Thank you. Is there a way I can buy you a beer from Uruguay?

I appreciate the offer, but I’m just glad that it helped you out. :slight_smile:

1 Like

I have the RSM2-Plus but the device handler is not working for switch #2. I have read this post and the forum up and down and I cannot get it to work. Somebody please help.

Just installed and it works, but does it support a dimmer switch? When I turn it on, goes to full brightness, not the previous dimmer state

Didn’t know that Enerwave had a dual relay dimmer device.

I installed the dual relay to a double dimmer switch and tried to use the Simulated Dimmer setting

@erocm1231 Does firmware v5.12 require updates to the DHs?

I’m not sure, I don’t have these devices anymore.

DTH for them still good and working properly.

FYI, this handler does not behave properly when installed with the new SmartThings app. I found that it was necessary to uninstall and reinstall with the Classic app.

When installed with the Classic app, switch status updates are not accurate in the new SmartThings app. However, everything works fine in the Classic app.

New to SmartThings here. Nice work, Eric, and thanks for coding the DTH and SmartApp for dual relays.

For those who are using the Enerwave RSM2-Plus (mine is v5.10, purchased in 2017): ST now seems to support this device. However, it did require some fiddling to get mine to work. After I paired the device to ST, it was identified as a “Z-wave Device Multichannel”. This did NOT work properly – ST could only operate one of the two switches. I went into SmartThings IDE (https://graph.api.smartthings.com/), found the RSM2-Plus device, and edited its Type to “Z-wave Dual Switch”. Automatically, a second device was added of type “Z-Wave Binary Switch Endpoint”, representing the second switch. Both switches can be controlled in the SmartThings app, and both are also recognized and can be voice controlled with my Echo.

Hope others can confirm that this works for them – this is much simpler than installing DTHs and SmartApps, and the integration should be smoother.


Hi Eric, thanks for this!

I have a RSM2-Plus. I installed the Parent and Child device handlers for the plus device. I now have three devices shown - the RSM2-plus device and then two switches are shown. However, the two switches are showing as disconnected. I can turn the main device on and off, which turns on/off both devices at the same time.

I don’t know if this matters, but I don’t have it connected to two switches - I’m only using it as a relay to turn two lights on and off.

I was having the exact same issue. Spent all night reading through Eric’s different posts. Eric is amazing and did some excellent work. It may depend on if you are using the new SmartThings App or Classic App. The new app works better if you follow the instructions from @styg88 the post right above yours. That is what finally solved my issues. Might be something with the new firmware handling something differently.

Steps I did for the new SmartThings app.

If you have already installed all of Eric’s device handlers remove them from IDE.

Delete the device from the app.

Reinstall the device. DO not choose Enerwave choose ZWave for the device type. (This is at least what I did. Scan Nearby or Enerwave may also work jsut giving my steps.)

Go to IDE select My Devices find Z-Wave Device Multichannel.

Click the name and scroll to the bottom and select edit if the field Type change it from Multichannel to ZWave Dual Switch.

There will be a new device that shows up at the bottom of SmartThings called Z-Wave Binary Switch Endpoint.

So You 1st switch is named Z-Wave Dual Switch and the 2nd switch is Z-Wave Binary Endpoint.

Hope that helps the folks with the new app save some time. I am not strong in coding or with SmartThings and only recently had to start using the device handlers to get functions out of other devices. But if you have the newest Plus device and the handlers are not working correctly for you you should try this.

Glad this worked for you too, @Distinguished. Note that my device is not the newest RSM2-Plus – it is version 5.10 which I bought in 2017. So others may want to try this method with older devices too.

I also didn’t bother to remove Eric’s device handlers from the IDE. They didn’t interfere once I designated the RSM2-Plus as type “Z-wave Dual Switch”. So if you want to try this method for a new device, while continuing to use Eric’s device handlers with existing devices, that should work.

You are probably correct about being able to leave the handlers for the older devices. This is the first Enerwave I bought and it is the newest. My devices would get discovered as the Enerwave devices with them installed. My installation instructions included getting the device handler from github the enerwave-rsm2-plus.groovy but only that one handler. WIth that Handler I got 3 devices and neither of the individual switch devices actually worked. Only the main device. The 2 switches would just be stuck checking for updates constantly. The icons even looked like outlets not switches. Followed all of Eric’s other recommendations, Parent and Child Device etc and they still caused issues. So I am assuming the newest firmware breaks something. However if this works for 5.10 that also means somewhere along the line ST got the device integration better.

My enerwave stopped working for one of my switches last week. I removed everything and reinstalled with no luck. I then switched the device type like @styg88 mentioned and all was well for a few days. Now The same switch is not working again. The endpoint switch continues to work. It is the other one that quits.

I am on smartthings classic.

Ok i have Eric’s main code and child device code loaded, however my problem is that my physical switch some times works some times doesn’t i have to tap the device with screw drivers back and it starts working, if the button is closed then i have to punch it some times it works some times it doesn’t i have 4 rsm-2 all have the same problem, right now i only have 1 rsm-2 installed. what could be the issue, also under smart app i have a switch but i never installed any smart app? where can i find erics smart app and what am i doing wrong?