[OBSOLETE] Dome Water Main Shut-Off (Official)

I’ve created the device handler in smarthings and it seemed to connect just fine. I tried to operate the valve via SmartThing, but it doesn’t actually move, the icon changes like it should be tho? How do I get this thing to start responding?

Did you create the device handler before adding the device?

Does the device open and close when you push the physical button on the top of the device?

If you log into the IDE and open live logging and then try activating it through the mobile app it might provide additional information about why it’s not working.

I attempted to connect it before I knew you had create the device handler for it, but it did not connect to the network. Then I created the device handler and added it.

The device opens\closes fine when pushing the physical button on the device.

When I check the logs it shows it as follows, but it never actually moves the valve unless I press the physical button(status updates properly when button is physically pressed)
8:07:02 PM: debug Requesting valve position.
8:06:48 PM: debug Valve is Open
8:06:38 PM: debug Closing Valve
8:06:36 PM: debug Valve is Open
8:06:26 PM: debug Opening Valve
8:06:24 PM: debug Valve is Open
8:06:23 PM: debug Requesting valve position.
8:06:21 PM: debug Valve is Open
8:06:12 PM: debug Closing Valve
8:06:06 PM: debug Valve is Open
8:05:57 PM: debug Device Checked In
8:05:56 PM: debug Closing Valve

Anyone have a clue as to how to get this thing to respond to zwave command’s? Kinda defeats the purpose of having it when it doesn’t work lol

Sounds like you got a dud. Get a replacement.

Remove the device and then reset it by holding the open/close button for 10 seconds. A flashing light indicates that it was successfully reset.

After doing that, add it back to SmartThings and if it still doesn’t work you’ll need to get a replacement.

this did the trick for me! it is now working!

*** it did take several attempts of removing/resetting if anyone else reads this and it does not work for them

1 Like

@krlaframboise Thanks for this DTH. I have a problem with the device that is not an issue with the DTH, but I wonder if it’s possible for you to compensate in the DTH?

The arm has no adjustable limit capability and mine tries to swing too far, in both the open and closing cycle. I’ve tried everything that’s been suggested here to solve the physical incompatibility between the motor and the valve arm. The motor tries indefinitely to complete the close (or open) operation. I’ve just accepted that in an emergency I’d prefer to close the valve 99% and probably have the motor burn out.

So, finally, my question: Is there a way for the DTH to recognize that the cycle is running too long and stop the operation after some period? I wouldn’t want it to revert to open, but to just leave it in a mostly-closed state. Thanks!

When you execute the “close” command all the DTH does is send an off command to the device. If I remember correctly the device immediately reports that it’s off so the DTH has no way of knowing if it finished closing the valve.

To prevent burning out the motor you could attach it to a smart switch. When water is detected have one rule that closes the valve and another that waits 1 minute and turns off the switch.

Brilliant! Thanks for the idea. Will do.

1 Like

Thanks for the DH. I have it up and running and it seems to be working spot on.

On a side note … is there a way to change the reporting on the “my things” screen to still say open but be white? I ask this because, I frequently check my apps (both IOS and Android) looking for lights left on and problems. When this shows up BLUE it draws my eye and makes me think something is wrong. Maybe I’m the odd ball out, but I would rather only have some type of notification if something is wrong meaning the valve is closed. Otherwise when it is open I’d rather it just blend in …

Just swap these values in the code: “#00a0dc” and “#ffffff


Thanks! That worked.

You’re a good guy … no matter what people may say about you! :grin:

Is there a post or topic about me that I missed…?

Trying to be funny … thanks again! :+1:

1 Like

in smartthing app i don’t see the status changes.
It’s ether open or no status at all.

Opening and closing works fine.

I am having the same problem with the status on the app. No indication of it’s open or closed, but hitting the open or close button in the smart things app will actuate the unit correct. Just no indication of open or closed in the status window.

Attempting to attach a screen shot of what it looks like on my iPhone.

Just tested mine - working fine w/ a brief (maybe 2 sec) delay. Also on iOs with this DTH. Showing ‘CLOSED’ when closed, ‘OPENING’ while opening, ‘OPEN’ when open, ‘CLOSING’ while closing. Also when it’s open the ‘CLOSE’ button is highlighted, when it’s closed the ‘OPEN’ button is highlighted.

I seem to remember seeing this though - I know I had to pair a couple of times when I set it up a few weeks ago to be sure it was working smoothly.

1 Like

Based on that screenshot you’re not using my DTH which explains why you’re having problems. (see the first post of this topic for screenshots of what this DTH looks like)

If you didn’t install and publish my DTH before adding the device to ST you need to open the device in the IDE and change the type to this DTH.

Another iOS/Android issue I believe. I don’t get the colors on the smaller tiles like you have in the first post (and I can’t see in the code where you have anything but white and blue for those tiles btw so not sure if things changed at some point) although my icons match yours on my iPhone. And then on my iPad the icons are as Andrew posted … The icon difference between iPhone and iPad has always made me wonder as I do not see that on any other handler/device. I cannot figure out how that can happen.

EDIT: I see now you updated the color scheme in December so ignore my comments about the colors.

All that said, Andrew’s main tile is odd showing grey and no text.