[OBSOLETE] D-Link Camera Manager (Connect) [Requires Classic App]

I believe the commands will be slightly different but there’s no harm in trying it out :slight_smile:

I’m still a little new to all of this. Where do I find my external video IP address? I put in my in the camera IP field, but what do I put in the video ip field? Can I find it in my d-link’s advanced settings?


The easiest way to find it is to go to mydlink.com and go to your camera’s advanced settings (assuming you’re not on your local network at the time). Keep in mind you’ll need to also set up port-forwarding on your home router in order to allow remote access.

unfortunately, I am on my local network, and all I have that can be off the network is my iPhone at the time. So, logging into mydlink and seeing that won’t work. I’m guessing I might be able to find it from my router’s settings?

Ok, just google “what’s my IP” and it should give it to you… The port will be whatever port you’ve forwarded (554 is default video port for the DCS-5222L)

I’ve been able to get the DCS-934L working except for video. I’ve tried the default port as well as 80. I am able to get streaming video through the web interface of the camera using http://ipaddress/video.cgi so I’m assuming that this camera should be able to stream video to the Smartthings app. I get the error “Camera cannot be found. We are trying to connect” when I press the play button.

Can you try to use VLC media player and connect to the following network stream:


Video Port should be the same as your Camera Port (assuming you port forwarded and didn’t change it)

That gives me a prompt to re-enter the username and password. I’ve reset the password on the camera to a simpler one and retried and it still prompts. I get the following error after canceling the login prompt.

Your input can’t be opened:
VLC is unable to open the MRL '

ok how about this URL:


That works, although it does redirect to I get live video with either URL

does it prompt you to put in your username and password?

No, it just shows the live video feed

Ok, can you update your Device Type Handlers? There should be a new version of the DCS-934L DTH available in the github repo. Try it out and let me know how it works.

I updated/republished the device type hander and restarted the app on my phone. Still not working, but not sure if there’s not something else I should do to make sure I’m using the updated handler

Are you using the GitHub integration? If you look at the URLs in the start() function they should look like the second URLs I had you to test (the one that worked).

Yes, the GitHub integration seems to be working, although after trying to delete the device handler, it still shows in the list, but I get the following error when clicking on it:

	Access Denied
	We're sorry, but you are not authorized to perform the requested operation.

I’ve tried deleting the smart app and camera from the phone app and reinstalling. I get up to the point of setting up the camera, but it never shows up as a “Thing” The smart app sees it, but nowhere else. Seems to be related to the permissions error

You shouldn’t have to delete the DTH, only update it. When it’s out of sync from the github repo it will let you update it by clicking on the “Update From Repo” button. If your DTH is out of date it should show up as purple, if it’s currently up to date it should be black. Try pulling all the missing files from the Github repo directly through IDE and see if that fixes it.

I deleted the next device handler in the last after the 934 and it seemed to fix the permission error and I was able to update the correct file. Still not getting live video, even though the start() function is using the correct URL, which I tested in a web browser. I appreciate you checking into this. If you have any other ideas, I’ll give them a shot

Are you using the local IP for your video? And is your phone on the same wifi as the camera?

Yes, local IP. Same wifi. Just tested the URL on the phone in a browser and it works. Device handler is v 1.0.1 and published.