[OBSOLETE] comments on Dome siren DTH

Remove the device and hold the action button for at least 10 seconds to factory reset it.

If you run into the same problem after doing that then try joining the device without my handler installed.

The built-in handler for that device is “Z-Wave Siren” so if it doesn’t get assigned that handler during inclusion and the raw description is still showing 0000 then it’s either a problem with the device or the hub so you’ll need to contact SmartThings or Dome.

Ok, same result after default factory reset, with and without your handler installed.
I had just ordered a replacement, I’ll keep you posted when I get the new dome siren.
Thanks a lot for your support so far!

1 Like

I’m seeing exactly the same problem as Andre. Seems unlikely that it is a device problem.

If the custom handler isn’t installed and the device isn’t getting assigned the correct built-in handler then the issue isn’t the custom handler.

Have you tried factory resetting the device by holding the action button for at least 10 seconds?

That model is probably doing something during inclusion that ST doesn’t like so I doubt getting a replacement will fix it.

Is the device functional if you change the Type field in the IDE to z-wave siren?

Kevin, good news!
The replacement dome siren just worked perfectly.
Thank you so much for all your support.

Hi Kevin, just a note to say thanks for your time and effort. I was able to use the device handler to add a Wink chime/siren to my network.

I am posting this on another discussion specifically about the Wink siren, but I am posting it here to help anyone who stubbles upon this:

After several failed attempts, here is how I was able to perform a clean install of a Wink Chime/Siren I am using the new app, and have an Aeotec hub:

Reset the Siren:

  • In the ST app, go open the siren, select the 3 dots, select edit, select delete device.

  • While the app is working on deleting, I opened the siren and held the button for 10 seconds, until it does one slow blink.

  • Then I took the batteries out, and when I replaced them the unitl blinked 5 times slowly to confirm that the until is reset.

  • The app indicated an error, and could not delete device, however after closing the siren device the icon disappeared from the ST app after a minute or two.

Install a new device handler:

Added siren back into ST

  • Sat next to my ST Hub

  • Opened the back of siren to get ready

  • In the ST app, + add new device by brand: DOME, siren

  • When the app was searching, I tapped the siren button 3x quickly to get into pairing mode

  • After until stopped blinking, again I tapped the siren button 3x quickly to get into pairing mode

  • I may have done this a third time as well, but if the app status went past the preparing stage, then the siren would have been added successfully.

Manually Change the device handler on the siren in the IDE

  • Go to location in the IDE and select the one where your siren is

  • Go to devices, and look for the siren

  • Select the Siren (it might be called Switch, if so, select)

  • On the device page, select EDIT on the bottom

  • Change the ‘Label” to the name you want the siren to show as in your device list. I named mine ‘Siren’.

  • Change the ‘Type’ to ‘Dome Siren’. It will be at the bottom for the scrolling list. Any device handler added manually always shows at the bottom.

  • Save the changes, and go to My Devices to confirm the siren shows as Type: Dome Siren

  • Close the phone app and restart. Your siren will have a lot more functionality than before.

Note: Put the siren under a pillow to test so you don’t scare or annoy the wife😉.

Worked perfect for $18 eBay WNK-SIR1.

Hello! I have a DMS01 Dome Siren/Strobe.
I believe I have this DTH installed correctly as I followed the instructions carefully and I see what I believe is the new UI. But something is not quite right:

  1. I can’t get it to just strobe the LED. If I go into the device, in the “Alarm type” box, if I select (Strobe), the button “spins” for a few moments but then the siren AND the strobe go off and the (Siren and strobe) button lights up as if it had been that button I pressed. Pressing the (Siren) and (Siren and strobe) buttons behave as expected.

  2. Also, if I set up an automation to trigger the strobe and/or the chime it doesn’t work (nothing happens). If I set the same “If” to “then” trigger a siren instead, it does work.

I’m not ruling out me having done something wrong (in fact, I rather hope that’s the case and someone can help me figure out what). Where do we start?

The only way to turn on the LED is to play a sound so there’s no way to use the device as a strobe.

You can’t activate a device in the “if” section of automations.


I believe that I asked this question previously but I am unable to find it in the thread. Have you or will you be developing an Edge Driver to port the capabilities of this Custom Device Handler over to the new architecture?

I’ve written the driver, but I’m still waiting for Dome to approve it and post it to their channel…

1 Like

That’s awesome! Thank you Kevin! Where can we look to check and see if it’s available?

Also, I’ve been wanting to learn the new architecture. I have looked for links to good documentation, but found it seemed to go to the old stuff. Do you have any links to a good source of documentation on the new stuff? - Jonathan

That’s great news Kevin! I thought that I had read that you intended to update the handler. Thank you Sir.

The new edge Driver is now available in the following topic:

[RELEASE] Dome Siren (Official 2.0)