[OBSOLETE] Aeotec Home Energy Meter Gen 5 composite DTH

I think mine is a gen2 also

Do you have a link to the device handler code? I’ve tried a few with that name but the options dont match

1 Like

Does that link work ok

can’t get the link to work. Pulls up smartthings but then just the spinning wheel

1 Like

unfortunately it doesn’t work

1 Like

How about this one, im not sure if its because im in the beta group, are you in the beta group.

How about this one

yep that worked

1 Like

Great stuff

I installed the driver it associates but does not read the consumption always remains at 0! what can I do? do you have a picture of how exactly the clup should be connected? I would not like him to be doing something wrong

What have you got the setting setup as

I managed to install this no problem but still have the problem that it is not refreshing on its own.


Sorry I’ve managed to get it to work now… after installing your new edge driver I then unpaired by long pressing the button on the back and then re paired them using the normal way. It connected running on the new driver and was updating correctly. I changed the refresh time from 300 to 27 and this has also worked

Only problem now is I have the old install hanging around but not in use. This really isn’t much of an issue though

1 Like

Good to hear its working now, ive found with z-wave devices, remove and re add does seem to sort it out

The only problem I’m having now is that I want to turn on my heat pump when my house solar panels are making the correct power ie. My house is importing -2500w but in the routine it won’t let me put the negative sign in.

I know I can get the full range by buying a second one and installing it the other way around but this seems a little silly as I can see that it is logging the negative powers in the history when it is sunny. It is simply that smartthings won’t let me make the routine I want to.

Ok I figured this one out now … I just copied the negative number I wanted from notes and pasted it into the smartthings routine

I dont see the neg sign on mine which confused me a little, ive been thinking of doing the same thing, if over 300 watts switch on a electric towel rail, just testing it out at the min

Can anyone comment on whether the Aeotec Gen5 edge driver reports negative values in the app’s device page?

I’ve discovered that the stock ST edge driver (zwave-electric-meter, which I’ve modified to support my Gen2 device), has a limitation such that negative values report “out of range” on the device page, although the values are correctly reported in the history section and IDE. I’ve been looking for a workaround to that limitation, and am curious if the Aeotec driver might have solved that and could be a better starting point for me.