[OBSOLETE] Aeon SmartStrip Device Handler


You seem to have a typo in your handler. Under the layout of the tiles you have switch5 & switch6 but you used outlet1 and outlet2 above. Should be:

			 "temperature", "refresh","reset", "configure"])

I’m confused, mine looks exactly the same as that. I once created a special version upon someones request to look like what you have described, but it is not the one linked in this thread.

I pulled from your github I believe. I already had you added for something else and I believe the version I grabbed showed “switch5” and “switch6” instead of “outlet5” and “outlet6” which meant I had no label tile.

Here’s what I pulled from:

Looks like this is my bad, I grabbed the wrong one. The linked one doesn’t have that, and maybe this is the special one you did for someone…

Yep, that was something I made special for a user that had some specific requirement that I don’t remember.

Hi Eric, I have just purchased the Smart Strip and installed this device handler as well as the app and handlers here. This is the first custom anything I have installed for my smartthings hub, so apologies if I missed or misunderstood something.

After installing everything, I am able to control main power and switchable outlets, plus I get power readings from all the outlets. The “reset kWh” button works as well. Unfortunately the strip doesn’t seem to be reporting the outlet state. If I turn off the strip with the button or simply unplug it, it’s not reflected in the app. Also I don’t know if the Configure button at the bottom is supposed to do something or not, but pressing it has no effect.

I am using the strip and your app primarily to get an alert if the power goes out. I have four refrigerators connected to the strip and if the breaker pops or power goes out I want smartthings to send me a text immediately and attempt to turn on the strip. My smartthings hub and internet router are on a battery backup so it’s able to alert me if house power goes out. If the outlet state isn’t reported I obviously won’t get any alert.

I appreciate anything you can tell me.

I just added your device monitor app in addition to what’s there. I powered off the strip with the button and it immediately ran my custom automation to power up the strip and send me a text. It happened so fast I wasn’t able to watch the original app to see what it saw. When I did get in, it was reporting 3 of 4 outlets were powered on even though they all were on.

It seems like something is reporting the correct state of the outlets, but it’s not displaying in any of the My Home/Things.

There are a couple things going on. First, when you use the button on the strip to turn it on/off it does not always send a report that all of the relays are on or off. All the channels may be on, but the strip itself may only report that 3 of them are on. The other problem is that handlers with lots of tiles sometimes do not update until you back out of the device page and go back into it. So it can look like the relays didn’t turn on, but then you hit back and then go back into the device and see that they are all on.

Also, if the power goes out, the strip will not be able to send a report that the outlets are off. This is typically how these kinds of devices work. The good news is that the strips outlets return to the state they were in when power is restored. So if three outlets were on when the power went off, those three outlets will be on when power is restored.

Is the goal to make sure that all the fridges are on even after a power failure?

1 Like

I’ve been out of ST for a little while, are there any instructions on connecting this strip to ST?

Hi all. Brand new to ST (just got the hub today) and I needed to make this power-strip work (actually 2 of them). I got this all going finally and have virtual switches set up. I only have one problem:

  • Both strip act the same way.
  • When I switch outlet 1 there is a short delay and then the rest of the outlets on that strip powers up sequentially.
  • This happens with the standard as well as 2 different device handlers I installed.
  • Sometimes turning outlet 1 off does the same for the rest, sometimes not (seems linked to device handler version).
  • If I power up #2 or others everything is normal.
  • After outlets turn themselves on, I can still control them with their respective virtual switch - hit on and nothing happens (already on) and off turns them off.

Any suggestions?

Hi Eric,

I am trying to update my Aeon handler with your 2017 version but when I tried to create the smartapp from the code, it generated the following error. Can you help? Thanks!

No signature of method: script_app_metadata_6f6a8366_a0b1_42cd_85f1_8ac6a787dd1a.metadata() is applicable for argument types: (script_app_metadata_6f6a8366_a0b1_42cd_85f1_8ac6a787dd1a$_run_closure1) values: [script_app_metadata_6f6a8366_a0b1_42cd_85f1_8ac6a787dd1a$_run_closure1@4311e38f] Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure)

Make sure you are creating a device handler not a SmartApp.

1 Like

Oooops :stuck_out_tongue: Thanks Nezmo!

1 Like

has anyone looked into creating/converting this into a composite DTH? ST seemed to have promised us they’d do this for us but seems to have fallen off the edge of the earth on that one…especially now that this thing is discontinued, the zooz zen20 thing seems to have gotten more official love…

I’m guessing it might be worth skipping the tile auto-creation for the switches because it probably can’t handle the wattage/output display as nicely as the current DTH. maybe we can just add in the bits for the composite device creation and call it done?

OK so I did that. I basically copied a buncha the bits from the zen20 strip. I converted the existing 1-4 switch tiles to be just a dumb status tile like 5-6, then i used the child outlets to display the switches for 1-4. it’s not quite as pretty, but now you don’t need the virtual device stuff anymore! it will natively create Aeon SmartStrip Outlet Ch1 through 4 automatically in addition to the main switch device now.

1 Like

When using it in conjunction with smart lighting I get this:

java.lang.NullPointerException: Cannot get property ‘location’ on null object @line 74 (df)

1 Like

Thanks for this!

I am able to get this to work and show the 4 outlets on the SmartThings Classic app, but in the new SmartThings app, it just shows a single power toggle to control the entire power strip.

I tried binding to the power strip too but the SmartThings Classic app won’t let you create anything new.

Any suggestions?

Install the virtual device sync app and its required device handlers and use the app to create virtual devices for each endpoint.

Wondering this myself…

Did you try to use the virtual device sync app mentioned above?