[OBSOLETE] Aeon HEM v1 DH Discussion (DTH link in post 411)

Could be a route issue, I have seen the HEM show as “device unavailable” in the app occasionally.
Checked the livelogging and also the hub event log, did not see any non-responding error messages. Updates seem quick right now, I’ll do more testing and log checking tomorrow to see if I can capture one of the “long” response delay events.

BTW, does the “REFRESH” tile have the same effect as pushing the main tile screen?

Checking the device log this morning, one thing I notice is that the HEM sometimes goes “offline”, during which time it does not report a change in power that happens (example below). It then came back online after a bit, but did not report any updated power value. When I refresh it via the app, it then sends the updated power value.

I don’t see any error messages in the hub’s event log related to non-response to messages.

Wondering if I should switch to interval-based reporting rather than power-change to trigger updates?

Does the “going offline” imply a problem in the network? Not sure how to further track that down (falling on my limited ST debug skillset sword).

Yep, sure does.

Are you running on batteries instead of USB by accident (cable not plugged in right)? The HEM should technically never go offline if it’s USB powered and your mesh is healthy. I’ve only seen mine go offline when I’ve had zwave mesh problems.

Is the LED solid red, blinking, or off?

In your event log image, it looks like you were offline for 22 minutes. If you don’t have batteries installed, did you loose power?

Is the HEM far from the hub? If so, what other routing capable zwave devices do you have in between the HEM and hub? Perhaps check on those to make sure are working fine.

Its USB powered, not batteries installed. No power outages to my knowledge.

The LED is solid red, at least when I’ve checked it. Next time I notice it being “offline”, I’ll check then.

The HEM is the farthest device from the HUB, but there are several intervening powered wall switches that should be acting as repeaters. The nearest ones are <20’ from the HEM, with the HEM one level below them (i.e. wood flooring in-between). I originally paired the HEM next to the HUB, moved it to the final location for install, and then repaired the ZWAVE network afterwards.

The nearby switches respond pretty quickly to the ST app, a bit slower when I trigger them through ALEXA but I think that additional delay is ALEXA induced.

I’ll also try a repair of the ZW net again, and livelog during the process to look for any odd responses.

1 Like

Change 03-27-2017:

Added a new device Preference that allows for selecting how many decimal positions should be used to display for WATTS and kWh. Min/max values still use 3 positions, as well as what’s stored for the actual meter reading that’s seen in the IDE for Power and what’s sent to SmartApps (like ones sending data to logging apps).



I had a prior version ‘no battery in title’ decided to use latest one of 03/27 but now i have tiny text.

I hit refresh on all the buttons/tiles and nill results.

I even did a z-exclusion to remove then readded the device but No dice.

Hit configure, then all the reset buttons, then refresh.

I finally got around to cleaning mine up. It’s almost relaxing to look at now.


Tried that on my iPhone does’t change the text, so small can’t even read it.

Mine is small but not unreadable. Wish ST could get this figured out between Android and iOS.

No dice. Top row shows ‘min was null’ and second row is empty.

Using ios if that matter…,

Have you tried re pairing it? Exclude it completely first though.

Mine is really small take a look.

I have the same issue on my Android.

Same. Unreadable now.

It was fine before the last update.

Yes here to.

FYI @joelw135, @Nezmo, @spyd4r

@Smartphi Your numbers will come back, or you can just tap on the three reset tiles to make it happen faster. The tiny text has nothing to do with the DTH. You can thank ST for that when they released v2.3.1 of the mobile app that made text/image rendering problems on Android and iOS even worse than it was before. You can see that by just looking at the 2 images posted above. Exiting the device and coming back, or even going to the SmartApps tab and back to the Right No wtab will sometimes clear that up.

For some reason ST decided to change the way standardTile and valueTile work, and probably a few other things we won’t ever know about. If/When they decide to fix that, who know’s. I’m just tired of having to constantly work around their poor quality of testing in these releases - even though many of us in the Community are on their beta programs to help them.


im pulling data from this DTH to an influxDB instance… any reason why the polling is so different from my previous DTH? it appears to be updating very infrequently… I have it set to 0 or time interval reporting with watt reproting every 15 seconds and Kwh every 60 seconds.

I’m still having issues with my HEM going “offline”. I’ve changed the reporting to be interval-based every 5 minutes. I’ve also added a powered switch close to the HEM to act as an intermediate repeater (I’m assuming all compliant powered switches must provide repeater functionality.) I’ve repaired the ZW net a couple of times as well.

When the HEM is “offline”, its LED is still constant red.

Attached below is an example event log from the device.
I’m wondering if the activity “offline” message is from the HEM itself, or from the ST system (based presumably on lack of response to a ping). Hours later the HEM sends new updates, and the “online” activity message is seen (again, is this from the device as the logs imply?)

And is the “cost” calculation done by the device or by the DTH/ST system - wondering if its accurate or not based on the reporting gaps.

Not sure how to further debug the problem, to figure out if its network related or something else - any other suggestions would be appreciated.