[OBSOLETE] ADT Tools 2 for Smartthings ADT alarm sytsems

My understanding is that the bell+, and bell- terminals are what is involved. I haven’t done it myself though. I did a few searches for info and there seems to be a good amount of information about doing this addition on a GC3 panel(what thr ADT Smarthings panel is based on). Seems a bit of wiring with a external siren, relay, and power supply.

If you do it it would be great to have something written up for the community.

I have officially update this thread with the new version of ADT Tools. I have tried to do allot of consolidation and cleanup. This is largely to make the app easier and cleaner to install. Please upgrade when you are ready to. Going forward I will only be adding enhancements to the new version. If you have any questions or concerns please let me know.

Thank you for providing this tool. Do you have a tutorial anywhere where I can use to set up the ADT panel? I published the codes to my IDE, but not sure what to do next. Any help will be appreciated.

Sorry i am still working on the documentation after the release of the 2.0 version. If you have everything loaded in the IDE right you should be able to just install the app just like any other from the SmartThings Classic app.

Open the Smartthings classic app. Click on the Automation button at the bottom of the screen. Now click on Smart Apps on the top right. Scroll down to the bottom and click on “+ Add a SmartApp”. At this point click on the bottom option for “+ My Apps”. Now you should see any apps that you have loaded in the IDE and are published. You should see near the top of your list “ADT Tools 2”. If you don’t see it go back to the ide and check that you published that specific app. You only need to publish the parent app and the device type handler.

Hopefully I will get the documentation completed soon. sorry for the confusion I have started to work on it at Things that are Smart - ADT Tools 2 but it isn’t complete yet.

One more thing. If you want the it to create the buttons for you do not forget to turn the flag to create the buttons back off. I haven’t added logic to handle if they already exist yet. If you forget to you will get an error when you go to save as it tries to recreate them.

Thank you for the info. I did not go all the way with the Classic App. I dont know why they made this ADT hub so difficult. When smartthings first came out, I was able to automate my home using tasker & sharp tools. I even created a custom alarm panel from the help of this forum. Prior to posting on this thread, i reached out to Samsung & ADT tech support. They were not able to answer my questions. The ADT tech told me that the panel did not make “audible voice” alerts. Thank you again. I will follow up with your instructions

@Mavrrick58 thanks so much for building this. I have a seemingly stupid question that i could not figure out the answer to.

Does your app work with the ADT Pulse system or just the DYI SmartThings/ADT panel? I just switched to ADT predominantly for this reason, but the ‘standard’ Pulse plan does not allow you to add Z-Wave devices, so I would have to upgrade to a higher plan - [rant] BTW, I never thought I would find an industry more opaque and backwards than the cable industry, but I just did, even their tech person did not know why I could not add z-wave devices on my own[/endrant]

Here is the post I found with what I’d need to do to integrate the two hubs: Using SmartThings hub in parallel with ADT Pulse

Thanks a lot in advance.

ADT Tools is for the ADT Smartthings Panel only.

That link is really about integrating a ADT Pulse system with a Smartthings v2 hub. I really doubt ADT Toools would work at all in that situation.

Thanks, that’s what I am trying to do…will follow-up in the other thread.

Getting an error when I try to add smartapps/mavrrick/installerManifest.json
500: Internal Server Error
Reference Id
Sat Dec 15 21:15:29 UTC 2018

All the others added but I’m having mixed results, when my alarm is tripped Lights don’t come on but I am able to use buttons to change alarm status

What version of ADT Tools are you using. The file you are referencing in your error is not part of the app. It was put there to support the community installer smartapp but unfortunately I don’t believe the guys managing that finished adding it.

Anyone know how to get SHM on the ADT Hub? I have it on my V2 hub and want to use it on my ADT Hub so I can try using it with User Lock Manager and a Lowes Iris Centralite Keypad that Ive been using for quite some time. Figure with SMH, I can use the Centralite keypad as a 2nd keypad and utilizing ADT Tools.


Thanks to @Mavrrick58 for this app and thanks to @themajesticking for his YouTube video that led me here. Both of you do fine work!

Chris, what did you have to do to get SMH available on your ADT Hub? Seems Samsung doesn’t want us to have it on an ADT Hub. Is the code in a GitHub repository somewhere so I can publish it and make it available on my ADT Hub?


Nevermind, I found the solution here. I had to delete my location and follow the procedures below and I was able to get SHM back. Now ADT-Tools-2 is working and I can do everything I want to do with one hub. Thanks again for this app Mavrrick!

That thread is a work around for SHM on the ADT Smartthings panel.

Simply put when you create a location from scratch you get a generic set of apps. SHM is part of that list and will be everytime. The issue is when you add the ADT Smartthings panel the list of Smart apps is changed and significantly reduced. If you ever remove SHM it will be gone again until you go back through the process of wiping your config and location and starting over the same way. So just be careful with it.

I actually took this concern to support and that was their answer.

1.1.1 10/27/2018

So first thing is that you are using a older version of the software. I would suggest you follow the link in the beginning of this thread and update the software to ADT Tools 2.

The light action is configured in the Alert app. Make sure it is set properly for the action you want to happen. The light action needs to be either 2 or 4 and you need to have lights select for the type of action you wan to do

Thank You! That worked,

One thing I’m running into on the ADT Tools 2 is on the Home/Life Alert my smoke detector is not showing and I’m getting “there are no devices of this capacity”. I have the switch turned off to enable generic, my smoke detector is a first alert zcombo with the device type of z-wave smoke alarm

I am having this same problem but with a Halo+ smoke detector

@bdimsdale @Dgramling

i found a typo that prevented the selection of smoke detectors. Please update the home/life alert child app and try again. you shoud be able to set it up now.

Thanks! I just updated! That did the trick. (all because of a missing “e”)