OAuth2 connection not allowing to load the UI page to enter user or pass in developer mode

I have configured call back as https://c2c-us.smartthings.com/oauth/callback in my OAuth2 page and all fields are configured correct as per the documentation. When I try to add a device with the project name from SmartThings it directly takes me to “https://c2c-us.smartthings.com/oauth/callback?code=

Couldn’t link account.

Error code: 7HD3F44

Close your web browser and return to SmartThings.

Please help as we have Google Assistant and Alexa both integrated and working fine but not able to understand whats wrong with SmartThings.

Hi, @LycheeThings. Welcome to the SmartThings Community!

Can you provide more details about what you’re trying to do, please?

Based on the URL you mentioned, I’m guessing you’re working on an ST Schema integration.

So, when you go to add your device, it should redirect you to your OAuth server configured in the developer workspace, for example, https://yourdomain.com/login. After the user authenticates, you need to redirect the response to the callback with the generated auth code by your server.

Hi @nayelyz, Yes we can see it goes to our server URL with the callback configured to SmartThings US (https://c2c-us.smartthings.com/oauth/callback). At the time of adding the device, instead of showing the login UI of our Auth page for the user and password it directly jumps to the callback link and throws an error with a different error code every time.

Just one confirmation as Lambda has the restriction for the Virginia server, is there any limitation on user pools to be in the same region server for AWS?

We have the same process working with Google Assistant and Alexa with a similar configuration but with SmartThings we are not able to get past the Auth process. Are there any logs on SmartThings to check what is the error?

For a user to install the Connector, the SmartThings Location’s region needs to match the one from AWS, for example, you cannot install a Connector that belongs to a region in Asia if your location is in Europe. And, also, if you have it in another location different than us-east-1, it could be an issue.

Can you share the following info to ask the engineering team to check the logs related to the error you see, please?

  1. Last error code
  2. App ID, is located in the Developer Workspace, for example, viper_xxx...

Hello nayelz,

Following are the details requested

  1. App Id : viper_2d688260-d441-11ed-8f0f-e7a212580f59
  2. Error code QDG6MVF

Is there a way to enable debug logs on SmartThings developer console.? Any specific settings we have to do on congnito side ?

We see similar issue reported last year
Authorization URI not landing while selecting the devices from “My Testing Device” - Developer Programs / Support - SmartThings Community

what was the solution to this issue ?

Thanks,
LycheeThings

Hi, @LycheeThings
Following up, the team checked the error based on the code you provided and the message shown specifies that the OAuth URL is trying to use invalid scopes. They must match the ones you specified in the Developer Workspace.
Could you share over a DM or by email to build@smartthings.com the current configuration you have for the connector in the Developer Workspace, please?
This is to check if something else could cause an issue.