oAuth Issues all cloud to cloud integrations broken (02/05/16)

Me and my work colleague are back in as well

Support were able to get my mobile App back up and running.

Here is the response I got from them

You're not the first person to get in touch with this issue today, it seems to be an authentification error.

I've managed to get this resolved by uninstalling the SmartThings app or the devices that you're getting this issue on, and then freshly reinstalling the app. This should then allow you to log in using your existing user credentials.

In terms of accessing the App that worked I can now focus on the Oauth issues, I’m not seeing any consistency yet though with some of my Oauth devices reporting and some are not.

yup, i was never locked out of the app, i got the prompt to log into my account very early this morning, which i did, it didn’t prompt me for the welcome code.

Support havent even responded to my email yet and it was sent in hours ago… I have Alexa back up and running, but Sharptools, Home Remote & IFTTT are still broken, all report error 500, cannot complete login to the IDE because as soon as i log in i get error 500.

Lifx, Smarttiles & Alexa are now working. so they are obviously working on something and have been since just after 8am this morning as the behaviour and issues have been changing all morning which i why i think its possibly a botched patch/installation

1 Like

I have had a response:

Thanks for getting in touch.

We have been experiencing issues this morning regarding authorisation issues.

I’ve just had a confirmation through from engineers that the issue has now been fixed, all that you need to do is close down the app completely, and log back in.

If this doesn’t resolve the issue, do get back to me and let me know what device(s) you’re having the issue on.

yup i just got that, replied that SharpTools still is producing a 500 error immediately when logging into the IDE when attempting to authorize. But the fact remains that was a 4 hour outage affecting all UK users (lots wont have noticed as they would have left for work) and status.smartthings.com again has no record of the issue…again.

i think its time to remove status.smartthings.com as it patently serves no purpose other than incorrectly giving good PR for availability even when issues are present

1 Like

I’ve had no problem getting into the IDE today and IFTTT connect is working fine at the moment I’m not seeing the errors in the log I was before.

It might be fixed but I’ll no for sure when I get home tonight

Looks like this might be wider the the UK as the US is just waking up

Sharp tools is broken for me (error 401 when clicking on a widget, error 500 when trying to auth).

Smart Tiles seems to work though!

Smarttiles is also OK for me but when I look at the tiles the weather tile is showing me snow @ 1C when its currently sunny @ 13C so something is definitely still not working. In the IDE the weather tile reads 13C.

Just checked sharp tools and while i can get in it won’t update or refresh my things…(exclamation mark in App)

yup i think they have killed sharptools. maybe worth replying back to the everything is working response everyone got from Support and tell them…no it aint! :smile:

hopefully this is something they are going to fix and not just state its something @joshua_lyon has to fix as its 3rd party etc…, because i imagine he wouldn’t be a happy bunny if this is the case.

could just be the result of the crazy UK weather at the moment, right now the sun is shining and it is glorious but in the last 3 hours we have had rain, sleet, hail and snow…so you never know? maybe the weatherman just ain’t keeping up

1 Like

Also having issues in the US.
Every morning I have a Smart Lighting automation turn on 2 hue Lux bulbs at 5:25 and off at 6. They turned on correctly, but had to manually turn them off, since there were major delays. (~30sec). Was able to turn off with Minimote.

SharpTools wasn’t working for me. Kept getting Error Code 401. OAuth is definitely messed up in the US.

I have emailed support with a screenshot of the IDE error I get when trying to authorise Sharptools.

Just a curiosity… anybody tried to uninstall/reinstall Sharp tools?

yup, i uninstalled cleared cache and app data, removed the Smartapp… cannot authorize because of the same issue once re-installed

Maybe related - 4 days ago ?

My sharp tools worked yesterday and I am quite sure this morning before ST turned itself inside out…?

i dont think that was exactly it, changes for that were completed as you said 4 days ago, this however is a day after news reports of security vulnerabilities…which they didn’t respond to directly prior to the stories running.

I personally know Sharptools was working fine up until just after 8am BST as i was using it fine after setting back up my phone after a factory reset and then five minutes later it broke and has been down since.


My Sharptools worked at 7am when I left the house this morning (I use it in combination with tasker to perform exit routines). So clearly broken from mid morning.

1 Like

I guess that might depend on whether the original UK OAuth fix was just a workaround or permanent. I can’t find a definitive answer but I do remember people commenting at the time that it would fall over when the system changed

maybe @tgauchat might know where we finally ended up with this. As he had some good insights at the time.

At the moment it looks like we are playing wack a mole as integrations are up one minute for one person and then down the next.

I’m planning on doing a system by system check when I get home to see if what is happening in reality.

SharpTools had a UK workaround in place in November and the official Global OAuth implemented on January 13th. I’m looking forward to some of the SmartThings employees coming online this morning so we can sort out the issue.