NST Manager Real-Time Events

So I think I have this all set up correctly, however I am still seeing around a 20s delay from the log-file noticing an event to when webcore gets a notification. Do I need to use something else as the trigger for webcore, ie. something that comes directly from this real-time event stream rather than the nest-camera itself detecting a motion?

I have rest streaming but do not have “use local network to send events” turned on as I found when I did nothing got picked up.

Any thoughts?



Completed all steps on apple iphone XS. installed nest manager version 5.5.8. update 12-27-2018. says enter login to nest click to enter creditials. once clicked it opens a nest page and i sign in. it says nest oops! ve’ve encountered an error. please try again. i have over and over. i click done on top right.and next. now it wont let me go further without entering nest location tap to set. there are no available options. i click done. i am in the same reeat steps without being able to complete.

You should check you created your nest token/secret correctly

There are notes in the main nest thread about ensuring no spaces, proper permissions, etc.

Accepting the permissions request in the nest mobile app is also important if it asks.

Hi Everyone,

I wonder if anyone can help. I’ve installed everything as stated above on a Raspberry Pi B+ sitting on my network and everything seems to be working, apart from the person specific motion. As soon as I turn this on within the individual camera settings, all motion event stop. I’ve debugged using webcore as well and it seems that if the person motion toggle is turned on all motion events stop.

I’m pretty sure that this is what Sven a couple of posts is also getting, but has anyone managed to fix this? I just need a light to turn on if a person enters a particular zone on my driveway.


I’ve not gotten any updates on this, and at this point I don’t think it works or will work the way we want it to despite the creator of the app claiming to use it this way. I have mine set to turn off the light after five minutes inactive, so a typical night for me is it randomly turns the porch light on (probably due to some change in light that it senses–but for some reason not a person) then five minutes later goes off. Then sometimes immediately after it goes off or sometimes a short while after that the light will come back on. It just repeats this process endlessly throughout the night. It’s pretty annoying because my cheaper and less effective RING doorbell worked flawlessly for this use case.

I had a similar issue with my Nest Hello. The problem was that when the light turned off, my Hello triggered a motion event probably due to most of the pixels it monitors changing. No fault of anyone here…

Not necessarily blaming anyone, but I am pointing out that no less than three people in the above comments claim to be using this service to turn on a light after motion by a person, one of them being Tonesto7 the creator of the app. Even yourself used the past-tense verb “had” in your most recent comment when referring to this issue, which would lead me to believe you now have it working or just decided to scrap it because of bugs.

If the former is true, I’d love to know what you changed to get it to work as one would expect. If the latter, then I’ll just give up hope of it working.

Which gets to the root of my comment. People claim to have it working properly, but no one up to this point has shared anything they’ve done to get it to work. That’s all I would like to know. If it is working where it turns on a light when someone steps in front of the hello then please share what was done to achieve that. I’ve combed through every conceivable setting and had no luck, which makes me think the people claiming to have it working are incorrect.

I got it working by not using my Hello to trigger motion. My real motion detector doesn’t care about light.

I assume there is no real IR motion detector in the Hello, which means they can only use the camera. So my guess is that you’re not likely to get this ‘fixed’.

Have you had a chance to look into this yet? :wink:

Sorry I wish i had time to work on these items. But it just has been a priority lately

1 Like

I have been reading several of the issues above. They seem very similar to my issue. My issue is that motionPerson event is triggered inconsistently and it always comes back as inactive. Therefore, if I use it to turn on some lights, the lights will never turn on. I tried to solve this by setting the MotionOnPersonOnly to true, but this only resulted in having the motion event to be always inactive. I really want to use the motionPerson event as it was designed. Currently, the only solution is to use Stringify. It lets me trigger my lights when a person is detected, and it usually takes about 3 seconds to turn on the lights. This is a wonderful solution, but Stringify is going away July 1. There is no other product on the market that lets me do this with my WeMo light switch. I really hope the NST Manager with the Real-Time-Streaming can be made to work. This is not a Nest issue. It works fine with Stringify.

I’ve followed the instructions, but why there is this error? I couldn’t understand where I’ve to put the endpoint and the token.

I’m not sure. It looks like the manager app has not detected the service and sent the endpoint info. Did you run the detection process inside the NST Manager smart app

Nest Streaming has start to fail for me. I’ve tried updating to the latest script version to no avail.

Here’s what’s in my logs:

Jun 30 19:23:03 raspberrypi node[1456]: 6-30-2019 - 8:23:03pm - #033[32minfo#033[39m: Activated SSDP Broadcast for SmartThings hub to detect…
Jun 30 19:23:03 raspberrypi node[1456]: 6-30-2019 - 8:23:03pm - #033[32minfo#033[39m: Waiting for NST Manager to send the signal to initialize the Nest Event Stream…
Jun 30 19:23:07 raspberrypi node[1456]: 6-30-2019 - 8:23:07pm - #033[32minfo#033[39m: Request to Start stream Received… | PID: 1456
Jun 30 19:23:07 raspberrypi node[1456]: 6-30-2019 - 8:23:07pm - #033[32minfo#033[39m: stopSsdp: (PID: 1456)
Jun 30 19:23:08 raspberrypi node[1456]: 6-30-2019 - 8:23:08pm - #033[32minfo#033[39m: Nest Connection Opened!
Jun 30 19:23:08 raspberrypi node[1456]: 6-30-2019 - 8:23:08pm - #033[32minfo#033[39m: New Nest API Event Data Received… | PID: 1456
Jun 30 19:23:08 raspberrypi node[1456]: 6-30-2019 - 8:23:08pm - #033[32minfo#033[39m: myMeta changed
Jun 30 19:23:08 raspberrypi node[1456]: 6-30-2019 - 8:23:08pm - #033[32minfo#033[39m: myStruct changed structure GFi9-awY70SiO9ypr8MLjyfNAJEWThBC5QsXNw5GzAmc5xLetR6DXg
Jun 30 19:23:08 raspberrypi node[1456]: 6-30-2019 - 8:23:08pm - #033[32minfo#033[39m: protect changed “Yn7MVti4SqNLuNU_-nRT3o3e9cGgWEB2”
Jun 30 19:23:08 raspberrypi node[1456]: 6-30-2019 - 8:23:08pm - #033[32minfo#033[39m: protect changed “Yn7MVti4SqPegJ7ZaS0ac43e9cGgWEB2”
Jun 30 19:23:08 raspberrypi node[1456]: 6-30-2019 - 8:23:08pm - #033[32minfo#033[39m: protect changed “Yn7MVti4SqO8DKSMS_gXoo3e9cGgWEB2”
Jun 30 19:23:08 raspberrypi node[1456]: 6-30-2019 - 8:23:08pm - #033[32minfo#033[39m: protect changed “Yn7MVti4SqPGr1lYg9lgao3e9cGgWEB2”
Jun 30 19:23:10 raspberrypi node[1456]: 6-30-2019 - 8:23:10pm - #033[32minfo#033[39m: Sent Nest API Event Data to NST Manager Client (ST) | LocalHub: (true) | Event#: 1 / 1
Jun 30 19:23:16 raspberrypi node[1456]: exitHandler: (PID: 1456) { exit: true } 1
Jun 30 19:23:16 raspberrypi node[1456]: 6-30-2019 - 8:23:16pm - #033[32minfo#033[39m: exitHandler error 1
Jun 30 19:23:16 raspberrypi systemd[1]: nst-streaming.service: main process exited, code=exited, status=1/FAILURE
Jun 30 19:23:16 raspberrypi systemd[1]: Unit nst-streaming.service entered failed state.
Jun 30 19:23:26 raspberrypi systemd[1]: nst-streaming.service holdoff time over, scheduling restart.
Jun 30 19:23:26 raspberrypi systemd[1]: Stopping NST Manager Node Streaming…
Jun 30 19:23:26 raspberrypi systemd[1]: Starting NST Manager Node Streaming…
Jun 30 19:23:26 raspberrypi systemd[1]: Started NST Manager Node Streaming.

Any ideas on what i can try?

turn off local hub, as ST disabled that from working.

This is a setting in NST Manager around event streams

When did they disable this? Is it all hubs or just the new v3 hub?

Thank you, @tonesto7 for publishing this script - installation on a Raspberry Pi was super easy. One question:

The installation script creates a directory in the user’s root (nst-streaming-master). Can that directory be deleted after a successful installation? I’m guessing that since the event-listener is installed as a daemon the repo directory is no longer needed?

Thanks for your help,

i’ve searched high and low for the option to turn of local hub but i can’t see anything in NSTManager.

Would need to see IDE “live logging” to see what is going on.

Turn this on in a window, then on your ST classic mobile app, go into NST manager and hit done, and let us see the logs for NST manager and the devices/stream. Likely want to send this as a private message for privacy reasons.

I don’t know what happened but after the smart hub firmware push today the crash error is gone.

1 Like

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.