[NOT WORKING] Echo Speaks v3 + Actions

As we should all be doing.

Not to knock Tonesto or ES at all - it’s been a good run, but I never really got it updated correctly after the first shutdown on Sept 8th.

Having said that - I’ve been slowly moving things over to Home Assistant. Is there any similar functionality specifically for the “Announcements” function for Alexa that anyone is using? If it’s not cool to post this in the ST forum, I apologize in advance

Hi All,

I’ve had this problem before but still not been able to solve it. I’m deleting the Echo Speaks App. I have deleted the 3 devices that were created and the Device Handler. However, when I try to delete the App from my IDE Page I get the message below.
"This SmartApp can’t be deleted at this time because it is installed by one or more users"

How do I delete this app completely from my Smartthings?

Thanks,

John

Delete smartapp from your mobile first, after delete from ide …

Thanks Giamma… that did not work. However, I did delete my browsing history and relaunched the IDE Page. Then using the Locations - My Home - List Smartapps - Edit - I could delete the Echo Speaks Smartapp and it is gone from everything.

I don’t think its inappropriate to discuss what the alternative options to Echo Speaks currently are on this thread while the program is not working. What would be best though is that once the alternatives are pointed out, any further discussion on how to use them should happen under their relevant thread or forum if on another platform. Also, the multiple posts a day of “its working, oh wait, its not working”, probably aren’t helping anyone. I’m not here to judge and they don’t actually violate any forum TOS, but, I’m sure others will agree, they’re annoying and not necessary when we are all trying to monitor this thread for some real updates.

That being said, if using HomeAssistant along with Smarthings, you definitely need to check this program out https://github.com/custom-components/alexa_media_player , which is the equivalent to Echo Speaks on HomeAssistant. It appears to be able to do everything and more that Echo Speaks could. Be warned though setup (not of just the program but Homeassistant itself) and then actually using it are EXTREMELY complex. Also, think of this Smarthings forum like a nice Goldfish aquarium, where the Homeassistant forum is a shark tank of network engineers and software developers, that will roast you if you don’t know how to make an encrypted SSL server or install a docker container. Currently, I am only using Homeassistant for automated Guard control (arm and disarm) until I am more comfortable with it.

Echo speaks on Hubitat continues to be an option - Alternative Hubs

The voicemonkey skill continues to work - I wrote up a user guide here Alexa Voicemonkey Skill

Even the Samsung Alexa skill that originally was totally useless has been improving, using the virtual contact sensors to trigger announcements on the Alexa routine is the easiest option for announcements, when it works of course. I have one of those just as a test to monitor if its working, and it has been working reliably now for two weeks since they retired the old skill. Still no official announcement from Samsung so can’t say for sure if the fix is long term. New SmartThings Alexa skill (2020)

I can’t speak for @tonesto7 , but from a developer perspective on my end, the new platform remains not ready for primetime to develop apps. There are two massive hurdles that Smartthings has not corrected - digital buttons created in the new app do not work. They either don’t draw, or pressing them does nothing. That must be fixed before the new version of Echo speaks can even be coded. Plus there is a cache issue - what that means is anytime you need to change something, or make a mistake, the old version sticks around in the Smartthings server like a ghost, ruining your code. Not to mention you have the looming IDE phaseout, and might spend all this time writing a new app to work with all this mess only to have to redo it entirely in a few months. Therefore, I haven’t used the new CLI and developer tools at all until this is straightened out, and have focused on just making orphaned DTH’s, mainly the GE/Jasco’s, work for basic functions in the new app. Long story short, I just don’t see these long term issues being fixed in the immediate future, so we may not have a “lite” version for some time. One glimmer of hope, @rboy seems to be having luck with the new developer tools, and has put out a new DTH using them, so I don’t believe all hope is lost. It actually looks really cool - [RELEASE] Ring Alarm Keypad (2nd Gen) Device Handler

12 Likes

Some people are reporting the latest update for ES allows it to still work - can anyone confirm? It’s not working for me.

Sigh. For real?

image

5 Likes

Really!? All I’m asking is if the update is worth applying.

It is an update for hubitat. I did it as a matter of course while in the ide for something else.

It did immediately start working but only for a few hours.

It’s certainly not going to make it work long term as Samsung is still actively blocking it.

1 Like

Has anyone tried changing the name of the app and device handlers?

Not that it matters to me really. Just curious.

Yes and it doesn’t work. Samsung didn’t block the app by its name.

It’s not possible to do some echo’s announcements I had to create:

. 13 simulated contact sensor in ide

. menage opening and closing of contacts sensor in every piston

. connect this contacts in alexa app

. create 13 routine to trigger this contacts and create the announcements,

THIS IS NOT SMART-THINGS, THIS IS MIDDLE AGES-THINGS

1 Like

I’m not sure what to say to this.
I’m pretty sure that ST only blocked the requests of the constant polling to Amazon for track, volume, etc. I don’t believe the outbound calls are being blocked so they should work.

3 Likes

They aren’t specifically for hubitat. The only thing specific to hubitat in the last few updates is adding in support for buttons which ST already supported.

3 Likes

Yes it’s worth applying if ES is still working for you

4 Likes

Ok main reason I wanted to know was because I’m going to have to copy and paste code o we. Community installer said it was applying updates and thinks they were installed correctly not actual smartapp says it’s still old version. Not sure when the actual sunset date is on your brilliant work but I’d like to ride it out till the end.

2 Likes

thats great news for my setup! I only use it for announcements. Since the constant status checking was their biggest conern, hopefully they will leave the rest alone :slight_smile:

1 Like

Same here. Going to enjoy it again while it lasts.

1 Like

Updating ES app and devices made it start working again for me. It had stopped working after the hub firmware update.

(!!!)