*** No longer supported *** [RELEASE] Best Zoned Heating/Cooling smartapps

Their support was no help, but I figured out how to do some stuff with webcore. Thanks for the idea!

I just installed scheduleTStatZones and I am bit confused about how to do what I want to do which seems pretty simple:

  1. Maintain manual control of Nest setpoint from the Nest app/NST Manager
  2. Adjust Keen vents in various rooms around that setpoint during heating or cooling

Basically I don’t actually really want any schedules… I just want the vents to be adjusted appropriately for comfort in the rooms where I have smart vents.

Hi @David_van_der_Bokke,

The smartapp has been designed so that you can configure your rooms/zones/schedules: you’d need to define at least 1 schedule (24h) for your thermostat’s setpoints.

I’d recommend to look into the concept of zones and schedules a little bit deeper as usually people want to set up different combinations of zones/schedules at their home (ex. only heat/cool the upstairs bedrooms at night, and direct more airflow towards the ground floor rooms during the day).

As indicated in the zip file, please refer to the ST community wiki for more details on how to configure the smartapp. All use cases have been documented here:

http://thingsthataresmart.wiki/index.php?title=ScheduleTstatZones#Configuration

For your vent settings, please refer to use case #4:

http://thingsthataresmart.wiki/index.php?title=ScheduleTstatZones#Use_case_.234:_I_want_to_control_my_smart_vents_to_create_my_physical_zones_using_the_smartapp

If you have any further question, please email me at services@maisonsecomatiq.com.
Regards.

Hi yvesracine, so I’m having an issue I’m not sure how to resolve. It seems like the app always wants to keep the temperature at 71 degrees during one of my schedules and I don’t know why. This is what the running config looks like…

I haven’t been manually adjusting the thermostat at all. Any ideas?

Hi @Hollajandro,

If you want to set your thermostat to some specific setpoints (cooling 67F, heating 65F) in auto mode and stick with them, you should not set the following flag to true in GeneralSetup:

AdjustTstatVs.indoorAvgTemp

as this flag allows the smartapp to make adjustment to your setpoints based on the average of all your temp sensors in your zoned rooms. A positive delta can then be applied (ex. + 4F) to your setpoints as your zoned rooms are probably cooler/hotter than your thermostat’s ambient temperature (and the smartapps tries to compensate for cooler or hotter rooms in heating/cooling mode).

If you still want to adjust your setpoints at your main thermostat, be aware that you can also set a maximum temp adjustment in each schedule (ex. 1F instead of 5F by default).

Of course, it’s hard for me to tell you what’s going on without any logs. You’d need to send me some logs at services@maisonsecomatiq.com in order to get the complete picture here.

To get detailed logging, refer to

http://thingsthataresmart.wiki/index.php?title=ScheduleTstatZones#Use_case_.2314:_I_want_detailed_logging.2FNotifications_or_I_want_to_enable_Ask_Alexa_Notifications

And you need to filter the logs by clicking on the name of the smartapp at the top of the IDE.

I’m pretty sure that’s the reason for this target temperature of 71F. You should also check out your routines (good morning, goodbye, I’m back home, etc) and other smartapps to make sure that there is no conflict.

Regards,

I’ve been using ecobeeSetZoneWithSchedule for a while now and it’s great. But I’m finally getting into settings schedules and I just don’t get it. How are the schedules in the SmartApp run? Are they based on the ST Hello Mode? The EcobeeClimateSet? EcobeeProgramSet?

I tried using ST Routines but they don’t actually change the EcobeeClimateSet or EcobeeProgramSet. It works fine if I set a temperature change in the ST Routine, but specific fan run times act weird and don’t always change.

I tried using Ecobee Schedules, but Home/Away are variable and I don’t use Ecobee Sensors. I’ve allowed EcobeeSetZoneWithSchedule to change Ecobee from Home/Away, but I don’t know how it’s triggered as I see no “Inactive for XXX minutes” settings in the app.

Basically I just want to know what everyone else is using for the schedule workflow.

My basic schedule is:

Night - 11pm to 7am, Fan 0 Minutes, 19C.
Morning - 7am to 8am, Fan 5 minutes, 20.5C
Home - When Sensors active within 30 minutes, Fan 5 Minutes, 22C.
Away - When Sensors not active within 30 minutes, Fan 20 minutes, 20C

Hi,

As indicated at the ST community wiki under the configuration section, ESZWS uses the ecobee climates (or comfort settings) for triggering the schedules in the smartapp. So, the schedules are run based on the ecobee scheduling. For every climate set at ecobee, you may associate 1 schedule in the smartapp.

The ST location modes are just secondary triggers for the smartapp.

Refer to the ST community for configuration & troubleshooting tips:

http://thingsthataresmart.wiki/index.php?title=EcobeeSetZoneWithSchedule#Configuration
http://thingsthataresmart.wiki/index.php?title=EcobeeSetZoneWithSchedule#Troubleshooting

P.S. ESZWS will not be able to trigger your fan for 5 or 20 minutes when you sensors are active or not active, those are custom rules that you can set in Core/WebCore or any other rule engine.

However, ESZWS can trigger your fan when the temp differential in the zone (between all your room sensors) has reached a threshold set in your schedule. Or, you can change the ecobee’s fanMinRunTime (which is the minimum fan time in an hour) in every schedule…

Regards.

Thanks for the reply. I’ve read through the documents and am still a bit confused.

In the ESZWS, I have 'Set Main Thermostat (away,present)? set to TRUE, but it doesn’t seem to do anything. The EcobeeClimate/Program remain at the last run Ecobee schedule. In the SCHEDULE settings, I have the ‘Which Ecobee Climate’ and ‘Choose Mode’ set to whatever (Home/Home for HOME Schedule). I don’t know if this is correct because I don’t know what Mode is referring to (Ecobee Mode? ST Mode? ESZWS Schedule?)

I can’t use the Ecobee Home/Away because none of my sensors are Ecobee. Do I need to use WebCore to change Ecobee to Home/Away, which will change the ESZWS ‘Last Running Schedule’ to whatever the EcobeeProgram is?

Basically my ESZWS dashboard reads:

ST hello mode: Home
Last Running Schedule: Null
EcobeeClimateSet: Morning
EcobeeProgramSet: Morning

Hi, you can use any room’s motion sensors (as long as they are connected to ST) to set your thermostat to Away or Home. The switch to the ecobee’s Home or Away mode is done only based on the motion sensors configured in the smartapp.

If no motion is detected in all your rooms (according to the occupied threshold in each of your rooms), then your main thermostat is set to ecobee’s Away mode.

And, the mode inputted in the Schedule setup is the location mode set for your ST hub. As I wrote to you earlier, the ST mode is a secondary trigger (ex. you may want to run the schedule associated to your ecobee’s Morning climate only when your ST location mode is set to Home). This is an optional, by default the schedule will run in all ST modes.

I strongly recommend to read the use cases documented at the wiki.

If you need further assistance for the configuration, please contribute to the support packages at my store. I can configure it for you provided that you give me access to your ST account.

P.S. The dashboard will display the last running schedule as defined in the smartapp.
Regards

Hi,

Just to let my contributors know, I have new versions of my zoned Heating/Cooling smartapps available at my store :

  • I made a small change to ecobeeSetZoneWithSchedule (v8.2.6), ScheduleTstatZones (v8.2.6) and ScheduleRoomTempControl (v4.1.6) to avoid opening/closing the vents in rapid succession when in fact they need to stay open as the main tstat’s OperatingState is fan only (even though there is a schedule change at the same time).

You can download the new versions at my store using the original sellfy link.

The new code is available at my store.

www.ecomatiqhomes.com/store.

Regards.

So I installed this yesterday, and it seems to keep resetting my heat/cool setpoints to 72/75 and I don’t know why.

I went into the TstatZone and set it there, and it seems to have stopped. I had them blank before.

Hi,

Just to let my contributors know and all Sensibo users, I have new versions of my zoned Heating/Cooling smartapps available at my store :

  • I made a small change to ecobeeSetZoneWithSchedule (v8.2.7) and ScheduleTstatZones (v8.2.7) to be able to support the Sensibo thermostat capabilities (custom DTH) in order to control window/mini splits.

  • With the new release, you can automatically turn on/off the Sensibo according to your schedules and even control the fan speed based on the concepts of rooms/zones/schedules just like the Remotec ZXT-120 and the Flair HVAC Units.

You can download the new versions at my store using the original sellfy link.

The new code is available at my store.

For more info about supported features and use cases, refer to the ST community wiki:

http://thingsthataresmart.wiki/index.php?title=ScheduleTstatZones

http://thingsthataresmart.wiki/index.php?title=EcobeeSetZoneWithSchedule

www.ecomatiqhomes.com/store.

Regards.

Hi,

Just to let my contributors know and all users who would like to do targeted heating/cooling in their home that I have new versions of my zoned Heating/Cooling smartapps available at my store :

  • I made a small change to ecobeeSetZoneWithSchedule (v8.2.8) and ScheduleTstatZones (v8.2.8) to use the app.updateSetting() method in order to keep the virtual zone devices in sync with the values (temp delta, active zone or not) in the zoning smartapps.

You can download the new versions at my store using the original sellfy link.

The new code is available at my store.

www.ecomatiqhomes.com/store.

Keen home vents at 40% discount.

Use KEENCLEARANCE promo code.

https://mailchi.mp/keenhome/x-1241333?e=9c7640bc90

Hi,

Just to let my contributors know and all users who would like to do targeted heating/cooling in their home that I have new versions of my zoned Heating/Cooling smartapps available at my store :

  • I made a small change to ecobeeSetZoneWithSchedule (v8.2.9) , ScheduleTstatZones (v8.2.9), and ScheduleRoomTempControl (v4.1.9) to introduce an optional delay (set in GeneralSetup) before opening all vents when the thermostat’s OperatingState is fan only.

You can download the new versions at my store using the original sellfy link.

The new code is available at my store.

www.ecomatiqhomes.com/store .

Regards.

Is the promotion no longer available? KEENCLEARANCE

Yeah, it’s over… Was for a limited time.

Hi,

Just to let my contributors and all ST users know and all users who would like to do targeted heating/cooling in their home that I have new versions of my zoned Heating/Cooling smartapps available at my store :

  • I made a small change to ecobeeSetZoneWithSchedule (v8.2.9a) , ScheduleTstatZones (v8.3), and ScheduleRoomTempControl (v4.1.9a) to correct the zone’s active flag when set using the virtual zone devices.

  • Also, in ScheduleTstatZones (v8.3), you can now indicate in each schedule if you want to synch the rooms’ slave thermostats (ex. eTRVs, portable heaters/coolers, mini/window splits) with the master’s thermostat’s setpoints or use the corresponding scheduled setpoints.

You can download the new versions at my store using the original sellfy link.

The new code is available at my store.

www.ecomatiqhomes.com/store .

Regards.

Hi. I’m trying to figure out if your app is going to work for my situation.

I’ve got a heat pump system that has three thermostats. Each thermostat controls a zone. When a zone calls for heating or cooling, dampers in the ducts are adjusted.

While it’s possible to set one thermostat to heat and another to cooling, the results would be kind of unpredictable since the single heat pump can only do one or the other.

My main need is to ensure that the three thermostats aren’t changed to conflicting mode settings. And to easily set all three to a given mode as a group.

Beyond that, I’m intrigued with the idea of automating mode changes based on outdoor temperatures.

The only temperature sensors I have are the thermostats themselves. No directly controllable smart vents, the dampers are controlled indirectly by setting the thermostat modes and setpoints.

Hi,

The vent settings are optional.

As I wrote to you before, you can elect one thermostat as the master and the slave thermostats will sync with the master in terms of mode (cool, heat, off, etc.) and setpoints. You can even specify a delta temp for each zone for finer control of colder/hotter rooms.

See the list of supported features and use cases at the ST community wiki:

http://thingsthataresmart.wiki/index.php?title=ScheduleTstatZones#Supported_Features

http://thingsthataresmart.wiki/index.php?title=ScheduleTstatZones#Configuration

The look and feel of the virtual zone devices and smartapp are described with screenshots here

http://thingsthataresmart.wiki/index.php?title=ScheduleTstatZones#Look_.26_Feel
Regards.