I am so glad you got this working…I plan on releasing an update on Monday, and unfortunately, it will require to you overwrite ALL of your code. However, that is rather easy compared to starting from scratch. I have updated the instructions and the Setup Variable links will give you the proper items to update in the developer area.

I knew you could do it!

1 Like

Michael, thank you for your help. I have been able to get Ask Alexa to work for the main account on my Echo but it will not work when I switch accounts. Alexa tells me "Sorry. I can not find a device called ‘My home under cabinet lights’ in Mike’s account.

When you say ‘switch accounts’…are you referring to SmartThings account or Amazon accounts. Either way will require you to duplicate some of this functionality into the other account.

Let me know which you are referring to and I can help as I have had both situations myself.

I am switching between Amazon accounts.

In that case you need to have the skill (and a developer account) that matches each Amazon account you have.

Version 2.2.1 has been released-[Deprecated] Ask Alexa 2.2.1

It requires overwriting most aspects of your code, but if done correctly, you won’t lose any of your settings. Enjoy!

Thank you for the new rls and enhancements.

I am getting an error in the utterances in the Amazon Developer portion of install.
My error, or something else
? SS:

Did you add the new slot (List of followups) as required by the new version? Go to Settings>>Setup Variables and run though the slot setup again.

MY ERROR ! ! ! I did not do the steps in sequence - all is well. Thank you !

How do I set it up so that a pin is required when unlocking the door or opening the garage door but locking/closing no pin required ?

The PIN is on a device basis…you either have it on for all commands for a device or off for all devices…You can also turn off specific commands on a device basis, but the combination you are envisioning is not available currently.

Okay thanks I just tried the option to turn off specific commands this should work for now :). Next will be trying to use the multiroom setup

Ok…the instructions are rather raw right now, but I got this working in my house…Let me know your experience and areas of the documentation that could use improvement.

Sounds good I wil give you my feedback

I’m almost there Michael but here’s where I’m at. Every account is the same and all my previous issues are resolved. When I pull down the drop down box in create lambda code it does not show me the alexa skill.

Here’s what mine looks like. I’m at the same area but no skill option

That probably means you are not set up in N Virginia (US-East). That is the only AWS datacenter doing the Alexa skill at the moment. Be sure to look here when setting up the code: http://thingsthataresmart.wiki/index.php?title=Ask_Alexa#AWS.2FLamba_Code

1 Like

Got it. I’m using Oregon cause I thought it was the one that’s closet to me. I’ll check that out

Yep…unfortunate Amazon only have Virginia as an option for the skills.


I’m a new user and got Ask Alexa all setup and working very well. Thanks!

Similar to idioffo89, I’d also like to turn off the unlock capability for my door locks. The wiki says:

In addition, you can disable commands like “Open” Or “Unlock” for additional security.

but it doesn’t say how to do that.

Do I do that in the skill setup by removing the “Unlock” Operator or is there some way to do this in the settings of the SmartApp? Or am I missing some key instruction? :wink:

Ultimately, I would prefer that you can ‘lock’ the doors via the Echo or macros, but I don’t want anyone to be able to unlock them via voice.


1 Like

Within the main menu for the doors and locks it will allow you to turn off the individual commands.

Let me know if that helps.