Nexus 5 as presence device


(Jim L) #1

So I am back posting about issues with using my mobile phone as a presence device. My wife has a Nexus 4 and it has worked from day one with almost zero issues. I had a Galaxy S3 that would NOT work reliably. Randomly the S3 would go away and within minutes show back up. This was slightly dangerous because if I leave my phone in my house when it does this, I can get locked out of my house.

With the Nexus 5 getting released, I got excited. I got it, and installed smartthings and immediately registered it as a presence device. Ultimately does very similar behavior to the S3. The device would “leave” and if I turned the screen on then open smartthings, it would come back.

I fully believe there is some defect in the smartthings use of the location API. The odds of two different phones exhibiting the same behavior is very unlikely. I am hoping my wife’s Nexus 4 gets upgraded to Kit Kat soon so I can see if the problem starts showing up for her.


(Tlange) #2

Android 4.4 added some new settings in the Settings->Location menu. What “Mode” are you currently using?


(Jim L) #3

The default mode of “high accuracy”.


(Thomas Bohmbach, Jr ) #4

I have the same issue. My wife had a Galaxy Nexus with unreliable location events. My Nexus 4 had no issues. We both upgraded to the Nexus 5 and are having the same problems as reported above.

  • Galaxy Nexus and Nexus 4 running 4.3.
  • Nexus 5s running 4.4.
  • Location modes set to "high accuracy" all around.

(Thomas Bohmbach, Jr ) #5

Any update on this issue?


(Cory S) #6

I have the same issues, with the same phones. Nexus 4 works great. Nexus 5 & GS3 randomly come and go. The Nexus 5 however sometimes never reports as gone when actually leaving.

I am set for high accuracy, and my other Geo location apps have always worked fine.


(Mike) #7

Seeing the same thing here with my wife’s Nexus 5. She’s been home for an hour but not according to ST. My GS4 works fine.


(Darryl) #8

Actually, my LG Spectrum 2 has the same issues. I was at a friends house, 30 miles away, for over an hour before it realized I was gone. Of course, my garage was already closed (I manually closed it), so it opened it…


(Thomas Bohmbach, Jr ) #9

There’s been a lot of silence on this issue from SmartThings. Any updates on if/when this will be fixed? It kind of prevents us from using the best features of the system (e.g. security). In fact, now all I can use it for is a fancy light switch. Disappointing.


(Ben Edwards) #10

I know this is an old thread but saw a post of yours come up in a search. So, @gumptionthomas did you ever get this working after the series of Android updates this year?


(Patrick Stuart [@pstuart]) #11

Mine has been flaky as of late as well. Using a Nexus 5 4.4.4 location services on, gps mode in any of them. I am always home.