Nexa AD147-2 Dimmer Mini-plug problem

Hi,

I have a problem connecting my mini-plugs to Smartthings hub v.2.

I have 2 Nexa AD147-2 Dimmer mini-plugs and had them used with Smartthings hub v2 and the classic app. Everything worked perfectly.

I then migrated to the new smartthings app and still everything worked fine. Then I accidentally removed location in the classic app and now I’m in trubbel.
First of all don’t delete location, unless you want to start from beginning!

The problem that I have now is that when I set the dimmers in inclusion mode, by pressing the button 3 times during 1,5 sec and push and hold within 1 sec until the buttons light turns off, the Smartthings finds them as “Everspring remote control” !!!

This make no sense. I have repeatedly removed them, by exclusion process, and add them again but with same result.

Does anyone else have the same problem? I welcome all tips and tricks.

Thanks in advance :slightly_smiling_face:

You need to go into the IDE and change the Device Type. If you don’t know how to do that, just do a search. There’s lots of references and How To’s.

That’s a great advice @7andy. Thank you.

I’ll check and will give you how it went.

It worked almost perfectly.

In the IDE I changed their type to Z-wave dimmer switch.
In the classic app it works perfectly but in the new smartthings app it keep saying “Checking status…”.

If I change the name in the IDE it show same name in the new app but still prompt “Checking status…”.

Killing the app and restarting it won’t help.

Any ideas?

Hi,

I had the same issue as you. Have one “dumb” lamp, which I can’t put a smart bulb in, and would like to be able to move it around (and be able to dim the light).
So I was searching for simple smart plugs with dimmable feature and ZigBee/Z-wave connection, to be able to include it to my Smartthings Hub V3. Found this Nexa Plug, and added it as instructed, but wondered like you why it connected as an Evergreen remote, so I started shuffling around with the different IDE, and looked for any possible custom device handlers… That’s when I found your post, and assigned the standard Z-wave dimmer switch IDE. Now I am also able to control it from the Classic Smartthings App, but stuck with the “checking status” message in the new app.

My workaround has been to create a Virtual Dimmer Switch, and simply configure the Nexa plug to mirror it through the Smart Light Smartapp in the Classic ST app (perhaps it could be configured through the new ST app as well).

And now I am able to switch on/off and dim the light through the new app, using the Virtual Dimmer Switch, which I have renamed the Lamp name originally planned, and moved to the room in the dashboard overview, and just hid the Original Nexa tile.

Don’t know of there is a better way to do this, but it works for me, for that one Dumb lamp :slight_smile:

I did the exact same thing as OP and i must say i hate the new Smartthings app but i managed to get my Nexa plugs running. For me it was not enough to change the device type after inclusion because when they get included as “Everspring remote control” they had 2 child devices on them and that screwsed things up. What i did instead was i modified the “Z-Wave Dimmer Switch Generic” DTH and added this

fingerprint mfr: “0060”, prod: “0003”, model: “0003”, deviceJoinName: "Nexa Dimmer Switch"

at the bottom of the device fingerprints at this is the fingerprint for the ones i have(probably for all Nexa AD147-2 plugs) and then published that modified DTH for me and then i scanned for the plugs

You are the man!
Thank you soo much. it works!!! I have 5 AD-147 and I really needed this fix. 5 stars!

Hi Edvald,
I’m struggling with the Nexa AD-147-2 too.
For me it showed up as a Z-wave device when I scanned for it in the new app. I tried editing the Z-wave Dimmer Switch Generic like you described. Now when I scan for it it showes up as Z-wave Dimmer Switch Generic, but clicking the power button or changing the dimmer doesn’t do anything. It just times out.
In the ide, the raw description shows this:
zw:L type:1101 mfr:0000 prod:0000 model:0000 ver:0.00 zwv:0.00 lib:00 cc:5E,86,72,5A,85,59,73,20,71,70,26,27,7A

Should the mfr/prod/model/ver have the values from the new fingerprint?