New Zigbee Device (Securifi Key Fob)

Have you installed and published the custom device type I posted? Once you do, I open the ST app, go to add new and once it’s searching, hold the * press and release the arm. The fob should blink green once and then ST should find it. If you haven’t installed the device type, you may see an unknown thing in your devices list

3 Likes

Yeah, i’ve installed the custom device type, and i did the * and it isn’t connecting or showing any devices.

Is it the press and hold the *, and then press and release the arm, and keeping holding the * until it sees the device?

You definitely release both. I can’t remember if you release the arm first or both at the same time, but when you do, it should blink green once when you release and then repeatedly blink green while it’s searching

What zigbee firmware are you on? I don’t know if it matters, but I am on 1.5.4

1 Like

I’m on 1.5.4 as well.

I’m not sure why it wouldn’t work. I removed my own device and re-added as a test before I posted the device type and I’ve added a second one since then that paired without issue. Is the keyfob repeatedly blinking green when you put it into pairing mode? Maybe try the reset function and then re-try pairing

> To pair the key fob, press and hold the star button, then quickly press the lock/arm all button for less than 1 second, then release the star button and the key fob should go into pairing mode. The LED will show green momentarily if this succeeded.
> To reset the key fob, press and hold the star button. While keeping the star button pressed, press the unlock/disarm button for 10 seconds. Then release the unlock/disarm button, but keep holding the star button pressed and the key fob will reset. The LED will show green momentarily if this succeeded.
2 Likes

Yeah, i’ve tried both. I have 2 different ones, i must be missing something really dumb. I’ve done this w/ a bunch of other devices so no idea why it wouldn’t work.

I finally got it, i seemed to have to hit the Home button. They are paired now, thanks @kevintierney for your patience.

2 Likes

Good to hear. Glad I could help

What are you guys going to use them for? Just trying to get ideas.

I’m using 2 of the 3 to toggle HH actions and the 3rd to toggle all my lights. Here are all the things you can control via the standard button controller app

Lights
Locks
Sonos
Modes
Hello Home Actions
Sirens
Custom Message
Message
Push Notifications

1 Like

Thanks! I’ll be ordering a few :smile:

Great Job @kevintierney.

I gave it a try and it worked for a short moment (maybe 4 commands) and stopped. Not sure where the break may be.

I also tried to incorporate presence detection into this, but I think there needs to be firmware changes to the fob to send commands of when it’s in/out of range.

Try to see if you can get double press or long holds events from this. I’m assuming since there’s no public docs for this, it’s all parsing of messages.

I would guess that most Button Controllers do not make any attempt to message the network unless a button is pressed. This way battery use is minimized.

I make this assumption for the Aeotec Minimote, since it claims a very long time between recharges.

The feature lost, of course, is true “presence”, as you can use a button to indicate you are back, but toggling isn’t workable without a feedback mechanism. You’d have to reserve another Button, to be pressed before you leave range, to indicate you are no longer present.

Hmm, not sure why it would stop working. One thing I did notice is that if I pressed the button once I had to wait a few seconds before pressing again or the second command wouldn’t take

I tried long pressing, but best I could tell when I released the button it was sending the same message. I may take a look again. I think double press will be the same. This truly was designed with the intention of being used with an alarm system

I think that’s the case too. Beyond the initial pairing, the device appears to sleep until a button is pressed. That would make sense from a preservation of battery life.

1 Like

@kevintierney just got mine this morning. Will try it tonight when I get off my late shift.

Good morning to All,

Let me first say @kevintierney…You did a great job on this! The pairing was not as easy as it should be, but it is the Key Fobs fault. However after it paired, the setup was a blast. One thing to point out is that the count of the buttons is backwards. They “Unlock” button is the first button, the second button is the “House” button, and the third button is the “Lock” button. That being said, you got a Winner here! Tell @Ben and @April about this product and its potential.

It saved my sanity this Sunday when ST maid my Smart Alarm fire off due to Hello Home not changing from Armed at Night mode to Disarmed at Morning mode.

I could not do anything with the ST app, so I grabbed the Key Fob and hit the “Unlock” button and the mode change fired off and killed the Siren.

Your idea of getting this Key Fob is great! Keep on coming up with great ideas. And if you need another test dummy, I volunteer for it after this thing saved me.

Glad it worked out for you.

Yeah, I debated about reordering these. In the end I used the order they came in based on the number the button returns (0-unlock, 2-home, 3-lock).

I plan on submitting it to ST, I just need to clean it up tweak a few things.I based my code on another button device. I’m thinking about either getting rid of the button tiles or modifying them to mimic the same button presses

Can you also have a category “Remotes” created in the main screen of the ST app after the Key Fob is configured for actions. As of this point, it shows up in “Convenience” category on the main screen and “Things”.

I am ordering a second Key Fob for myself today and will stop using my phone and my wifes as Presence sensors for the house. ST phone Presence has officially been decommissioned in my house after your great idea put them in an early retirement. :smile: They are unreliable.

Thanks again for all of your hard work. Looking forward to your next idea. :thumbsup:

Got this up and running just fine, but it doesn’t seem to trigger my door lock. I can use the buttons to control my lights, but I get no response from the lock at all. I checked the event logs and the button press is registering, just no action from the lock. Any ideas?

Thanks for creating this!

Just a quick note: @obycode has added a modified device type that will cause each of the 3 working Securifi buttons to be linked t a separate virtual button, allowing you to access them individually from either the mobile app or through a rules engine like SmartRules:

If someone tests it, leave comments for Brice in the topic linked above. :slight_smile:

2 Likes