New Zigbee Device (Securifi Key Fob)

Hello Kevintierney, yes I am using your device type code for the securify fob. 3 out of the 4 buttons are assignable, but all 4 buttons show up on the activity feed as you press them!

I think the upper button is working as a pairing button. The Swannone key fob has its own pairing push switch inside.

Am I right in thinking that the star button could be freed up from being a pairing button, and can be assignable to a chosen command, just like the other 3 keys.

If not, I would like to disable the star button from working as a pairing button. If it can’t be done by omitting lines from the device type code, I could always put a piece of tape on top of the metal contacts under the button to stop the button from working.

OK. My device was specific to the securifi fob which only 3 of the buttons are usable. Try this one and check the activity feed.This will tell us the number sent when pressed. It would also be good to know the other numbers and which buttons they correspond to and I can make a more specific device handler

2 Likes

Many thanks Kevin tierney, annoyingly I am working away from home until Thursday, I have the Swannone key fob with me!

I have ordered another to arrive sometime tomorrow in the UK. I will get a family member to pair the device to the hub, and I will get the codes produced from each of the four buttons.

Hi Kevin, I deleted the securify device type and created a new device type from your latest Swannone code.

The key fob still works but unfortunately when you press the keys, it still says button 1,2,3 and null button pushed.

Hi @NHENRY, thanks for discovering this device and that it works with SmartThings. I bought one for testing and I’m really impressed with the quality and form factor. It’s the best Button Key Fob that I’ve tested so far.

I’ve created a new Device Type for testing based on @kevintierney code (Thanks @kevintierney for this great code) and I’ve mapped the Buttons as follows (names as mentioned on the device manual):
1 - Home button
2 - Away button
3 - Night button
4 - Panic button

Here is the new Device Type code:
Swann-One-Key-Fob.groovy

I’ve also tested this device using the Button Controller smartapp and I was able to use all 4 buttons.
Cheers :wink:

Thanks for the support guys!

I have done extensive testing with my Swannone fobs. I have 3 of them to test! I have all 4 buttons working now, but I have an intermittent problem!

My devices intermittently unpair once they are idle for a short while and mostly if I am out of range and then come closer to the hub! I had all three keyFobs working at one time, and one by one, they unpaired!

I am now testing only one keyFob, as I thought the other key fobs were causing the others to unpair somehow!

This was not the case!
A single keyFob on its own unpsirs once idle for a short time, and when re-entering an out of range situation!

Rudip, is yours still perfectly working?

Hi @NHENRY, Yep I’m having the same issue here.

I’ve tested this Key Fob for a day last week, went away from Home , came back and everything worked fine.
Since I’m using the Aeon Key Fob for testing I left the Swann One Key Fob at home. Yesterday when I saw your post I picked up the Swann One Key Fob and pressed the Home button (button 1) and it worked, and I could see the commands in the Logs, but right after that when I tried to press any other button it did not work anymore. I’ve waited a couple of hours and saw the light blinking on the Swann One (meaning that it was not paired) and I then I’ve started the connection process again and it started working again. This morning it was not working again so this is a big issue for sure.
The weird thing is that it seams that the Swan One remote thinks it’s not connected to a ZigBee controller anymore, and I have no idea why.

If somebody else in the community have any idea about this issue please chime in.
I’ll also try to collect some logs and compare the code for this Device Type to other button controllers to see if there is any refresh or something that we can use.

1 Like

I’ve got the fob device up and running with @kevintierney code in conjunction with the ST Button Controller smartapp in terms of being able to set the Home Monitoring to ARM or DISARM from two of the buttons. I am trying to use the optional third button to open my garage door via Linear Z-wave controller. The smartapp Button Controller doesn’t see anything from the Linear to toggle the garage door. How do I enable the optional 3rd button to toggle the garage door controller? Do I need to build a virtual momentary switch that triggers the garage door control?

Chip, I loaded your app but I am not exactly sure why yours is different in triggering the routines compared to the ST Button Controller app? Can you help me understand the difference?

Yes, if the linear device type doesn’t show up in button controller, you have 3 options

  1. Modify button controller
  2. Modify linear device type
  3. Install virtual momentary and write/install an app that triggers the door when pressed

His app is specifically designed to run hello home phrases only and also the field text is specific to the securifi key fob so it’s easier to use

Yeah, that’s pretty much it.

Thanks Kevin! I also saw that @chipr had put in a feedback loop which I thought was kind of cool. He triggers his porch light on/off to show the system is changing modes, nice.

So I did so more searching through the forums and @garyd9 modified the ST default Z-Wave Garage Door Opener so that it could work perfectly with the Securifi Key fob! I used the one that @Ron modified and replaced the default one. [RELEASE] Enhanced Linear GD00Z-4/GD00Z-5/GoControl/Iris/others Device Handler with Switch and Automated Garage Door Open/Close when People Arrive/Leave
It works like an absolute champ! You developer guys are just geniuses :grinning:

Thank you so much Kevin, Gary and Ron for getting all the pieces together that allows non-dev people like me to experience the full potential of the SmartThings system. :+1:

I created a new linked topic for the SwannOne device discussion:

Many thanks Rudip, thanks for confirming your findings. I am fairly new to smartthings, therefore my help to resolve this is fairly limited! It would be great to get this keyFob working. It really is made really well and beautifully designed.

I am keeping my Swannone keyFobs for future testing.

Sorry for hijacking the securify key fob thread guys! I will continue from now on in the new Swannone keyFob thread

Hi @RudiP
im using
https://github.com/RudiP/SmartThings/blob/master/devicetypes/RudiP/Swann-One-Key-Fob.src/Swann-One-Key-Fob.groovy

however how i can map my routines on the button click?or exactly what routine call when i press the lock, unlock and panic? Thanks

Nevermind i installed smart app to control the routines :smiley: awesome
One quistion Long press is not working right?

Hi @ZeN_KuN. Long press (Held) is not implemented for this Device.
More information about this device on the thread SwannOne Key Fob Support

awesome, thanks and sorry for inconveniences :smiley:

Does anyone know what the range is on the Securify Fob? I’m looking to use this to arm the system when I leave. Ideally I’d already be inside the car in the driveway or at least outside the house.

I’ve had no problem using in my driveway