New sonoff zigbee

I’m on V2 also, having some success.

Try changing the type then without removing re-add it. Worked with one of mine :+1:

Thanks I’ll give it a go. Did you use the eZEX handler?

1 Like

Thanks again, worked first time. Appreciate the help.

1 Like

just got a sonoff snzb 01, ST sees it, but no joy when using the default device types. Anyone know of someone has a dth for these?

How do we re-add it?

I’ve already got it listed in my device list, changed the device type so now what?

When I did it, I changed the type to eZEX then - add device - by brand eZEX - multi purpose sensor and it eventually found it

Same way you added it in the first instance. But don’t delete the device first

So, after a bunch of tries I got this sensor SNZB-02 to actually get humidity and temp data.

What I did was, I added it at first as a eZEX Multipurpose Sensor. Then added a custom DTH as described with the modified code above and assigned that to the device as a “Self Published” version. I then re-added the device in the Smartthings app, without first deleting, as a eZEX MultiPurpose Sensor, also as stated above. I could now see data coming in on the device.

However - when I looked in the SmartThings app on my phone it was displayed as a Switch and only stated “connected”. No data, nothing.

After force stopping the app and then starting it again, it worked!

Figured this could maybe help someone experiencing the same weird “connected” thing in the app.
Many thanks to y’all here.

Yeeee thanks. Both working now :grin:

I’m also looking for a dth for snzb 01. I have tried all possible default dths, none of them works. Has anybody managed to get this to work with ST v3? thanks

No, but I did buy some IKEA buttons for £6 and they work fine.

oh ok, thanks. hoping a compatible dth will be found soon.

Hi I’m trying to integrate the new sonoff SNZB-03 motion sensors, in SamrtThings.
I search from “add device” it finds me a device called “Thing” it recognizes the Ziggbe id (00124B001FAF55B3) the staus is ONLINE.
But if I try to manage it from the app on the phone it gives me the error “impossible to connect to the device …”
Has anyone tried this positive and have my own problems?
I would not take the sonoff zigbee hub to handle these sensors

THX
Enzo

hmm, mine paired right the first time. Try logging into the IDE and changing the type to “Zigbee motion sensor”. That’s what mine joined as.

Sorry for my delay… work …
on SmartThings Groovy IDE there are two entries:

  1. zigbee motion detection
  2. zigbee Motion/Tem/Humidity Sensor
    I tried the first one but doesn’t work !
    The second work… it works quite well, I mean, it recognizes the movements but the battery status is wrong, it gives me 0% but I’m sure it is 100%.
    there is a long delay between motion detection and lamp ignition. I still have to do some testing!

many thanks for your suggestion it was crucial

P.S.:

I attach the screenshot regarding de config and the status on app, sorry in italian,

Just received a sampling of Sonoff Zigbee devices. Last night, I tested the motion (SNZB-03) first.

I tried to add with “Scan nearby” and “By brand, eWeLink”, but could only pair as “Thing”. Within IDE, I changed Type = Zigbee Motion Detector. Detection is working as expected. Battery also shows 0%.

This morning, I realized that my ST app is showing TWO entries of eWeLink in the add “By brand” section. Tonight, I will try both to see if I can get the proper native handler.

@enzozerbi - no reason to apologize for showing in Italian. It adds a touch of class to the app.

EDIT:
I don’t speak Zigbee, but does the raw data shown in the post below indicate how the devices want to be added?

EDIT2:
Motion sensor went off-line last night. This morning, I put it into pairing mode and ran “Scan nearby”. When it re-added, it suddenly showed battery status also. Unduly complicated setup, but working as desired for now.

About Sonoff ZB temp sensor: do you guys see temperature in main screen tile? Do you see battery status at all? I’m using eZEX device type (thanks for the tip!) but it’s without battery info and ‘default view’ is humidity.

SNZB-02 (temp/humidity) with Type = eZEX Temp & Humidity Sensor …
App tile shows humidity percentage.
No battery status shows … I had not really noticed that before. Battery does not show in the IDE either.

Had no issues in discovering them in the app, just held the pair button and they popped in. To get the to properly work though you need to then change their Type. Pair them, then logon to the smartthings online portal, and change the Types to zigbee motion/humidité/température sensor… then repair the devices (by using the pair button on them), don’t delete them before repairing.