New sonoff zigbee

I’m very happy to hear it :+1:

So you made these settings in the app and then did what to get the settings to stick?

I totally reset the device and deleted it, i re added(as a switch). I then set the settings and they seem to have stuck. It’s closer to my hub, but still on a repeater (lidl smartplug).

I ended up just hard coding mine with the values I wanted (60,3600,10) and (60,3600,100) since changing the settings and getting them to stick is a pain anyway

2 Likes

Thanks for everyone’s help on this one, glad it’s working (more or less) now. And thanks for helping me understand the IDE more.

1 Like

Today I received a few of sensors, let me share my experience with them:

  1. SNZB-01 (wireless switch)
    I used the DTH from Darren Blanchard (mentioned here in the forum).
    It is supposed to run local, however if I configure the related automations in the SmartLighting app, then it has a strange behaviour:
    a) if the Target device is a local device (for example a local Zigbee bulb), it doesnt trigger it at all. It doesn’t work.
    b) if the Target device is a cloud DTH device (for example a Sengled RGB bulb), it triggers it correctly.
    c) if the Target devices are a mix of more devices, for example one local and one cloud device, it triggers both!
    However, from the the above mentioned scenarios only a) would have a chance to work without internet, but it doesn’t work at all (even with internet).

If I configure it in the Automations (not via SmartLigthing app), everything works (however, all Automations need internet).
Anyone experienced the same in the SmartLighing app?
Another strange issue, that to achieve the “HELD” state I need to hold it really long (cca 4 seconds), independently on the settings (1 second configured).

  1. SNZB-02
    I use the SmartSense Temp/Humidity Sensor, it seems it is running local (however, I didnt try any automations yet).

  2. SNZB-04 (Wireless Door/Windows Sensor)
    The Hub automatically recognized it as a Orvibo Contact Sensor, works locally, tested via SmartLighting app. (works without internet). The detection of the “open” state may take up to 1 second, but it seems it is a physical limitation of the sensor itself, not the processing time. The “close” state is literally immediate.

All of the mentioned sensors are currently connected via repeaters (bulbs, switches, etc).
Lets see how stable they will be. (my currently existing Xiaomi sensors are pretty sensitive for any change in the mesh topology).
If anyone can share his findings related to 1), i would really appreciate it. I really wish to find a locally working “button”. Many thanks.

Does the SNZB-02 report humidity changes? I had issues with this driver for humidity. I’ve just ordered a SNZB-04 so I’m glad that looks to be working OK.

Yes, the SNZB-02 reports humidity changes with the SmartSense Temp/Humidity Sensor.
Make sure you select the “SmartSense Temp/Humidity Sensor” (with the word Sensor at the end) and not the very similar “SmartSense Temp/Humidity”.
I would say the humidity report is rather too frequent. (I think it was discussed in this forum earlier)
(By the way, my experience is that if i play too much with the handlers (trying more and more continuously), sometimes the tested device just stops working. I used to remove the problematic device completely and then add it again, it usually helps. This is related to any devices, not just Sonoff).

Thanks, yes, it took some playing with a few DH’s, but in the end I used the one where you can specify the intervals. But as you say, the note i played the more devices broke. I found deleting and re-adding fixed alot.

For me, the smartsense never reported humidity and had conflicted battery reports because the device sends both 0x0001 20 and 0x0001 21 (voltage and percentage, respectively)

The ezex worked, but it didn’t display battery at all and the tile showed humidity instead of temperature.

So the only way for the device to work as intended was to use my own driver.

This is the driver I am using and it’s still working perfectly, no battery drain and it’s running through about 3 repeaters, and reporting to how I filled out the criteria.

The SNZB-04 added as an EwELink open/close sensor and has worked fine, no issues at all.

Did anyone have a chance to test the SNZB-01 (wireless switch), if you experience the same behavior I described here?

I got my SNZB-04 sensors today (2 of them). I have a V2 hub, they were recognized as eWeLink Open/Closed Sensor and the DTH type is Orvibo contact sensor.
Unfortunately, none of them updates the open/close status. Also, the battery % is way off (one shows 0% battery, the other one 34% and I know both batteries are new and fully charged). I have tried removing/re-adding them several times, switching to a different DTH - same outcome - random battery % and no open/close update. Any advice is appreciated.

I’m using this device handler since nov/20 without any issues, and is reporting about the same values as the smarting a motion sensor, the BroadLink IR temp/humidity sensor and as the Netatmo weather station.
In 3 months the battery dropped 10%, it’s between the expected battery life.

@mvevitsis see if there is something you can use from this.

Tried this? New Sonoff zigbee devices - #29 by pablopoo

@mvevitsis: I use your DTH, thank you for creating it. I set it to 60,1800,10 for temperature but it still reports every 60 min instead of 30 min. Any suggestions?

Triggering the settings to update can be finicky, so I stopped using variables and hard coded all the values. You can download the current version of the DTH from my github and then just change the numbers to your desired ones.

I just want to confirm that I just added my new SNZB-03 Motion sensor to my Smartthings hub and all is working perfectly, battery level and all. The instructions that came with it says to download the ewelink app and use that to add it to hub but i never done any of that. I just did a “add device” in my ST app, then I selected “motion sensor” then I selected the Ewelink brand and then went on from there. The only hiccup was that when it said for me to put it in the add mode by pushing in the hole with a pin…the first time it timed out and said try again which I did and then it picked it up after about 30 seconds and all went well. This sensor saves battery life by taking about a minute after being activated by motion to work again.

I wanted to add to this thread, about paring the SNZB-02 temp./umid. sensor, that the solution which worked for me was found in another similar thread:

EDIT: But, for the temp. to show properly on the tile and not only when entering the device, use the type “SmartSense Temp/Humidity Sensor” instead.

I don’t seem to be able to get my SNZB-02s to send temp changes any more frequently than the Max reporting time, regardless of my reportableChange setting.

I have set my Temp to 120, 1200, 10 (2 mins min, 20 mins max, 0.1% change) and my Humidity to 240, 3600, 200 (4 mins min, 60 mins max, 2% change). Humidity will (faily) reliably post every hour if the variance is less than 2%, or more frequently if more than 2%, so that’s good. Temp however will only post every 20 minutes and the variance between 20 minutes can be 1 degree or more, so it should have reported closer to the 2 mins min reporting time than the 20 mins max time. If I change the max time to 1 hour, delete the device and re-add it, then it only reports every hour and the variance can be 2 degrees or so over an hour.

I have been using the DTH created by @mvevitsis (thank you!) and from reading through the thread, it sounds like I might be doing something stupid with publishing. Has anyone else experienced this and got any ideas how I can fix this please?