New SmartThings Schema Integration for Arlo

@Chares @Joe_Mcnelly - appreciate the feedback on the desire for audio doorbell. We will review with our product team and SmartThings and see if we can make this feasible.

2 Likes

If not alexa handles it just fine

I’m also waiting for the audio doorbell integration. There’s a thread on the Arlo Community with 5 pages of users asking for this integration for almost 2 years. Please make this happen!

Here are a couple use cases:

  • use motion sensor as trigger for automations
  • use doorbell button as trigger for automations
  • send audio messages to doorbell when someone stands by the door but didn’t push the button (they just knock)
  • enable/disable doorbell using presence or other automations (time of day, baby sleeping, etc)

Thanks!

2 Likes

@prjct92eh2 so in the ST app UX, the details page (page that appears after tapping on the device card from the home page) currently displays the video player and the on/off button for each device and below that there is history shown. At this moment , a doorbell button will not be shown there.

When the doorbell chime event is piped through, ST could will be aware of it and a user will need to setup an automation to trigger an action when the doorbell event occurs.

1 Like

Since you have already moved to the new schema integration and removed the older integration, there is no action needed to be taken on your end. In the linked services, there should just be one Arlo entry with the name “Arlo”.

Sorry, but I have not done anything yet as I’m waiting for the the…

I have too many current Automations, Scenes, and SmartApps that my Arlo devices are used in to do it the manual way since…

So, I’m just asking if I will receive any in app or other notification when SmartThings migrates me to this new Arlo Schema? BTW, is there a target date when all existing Arlo users will be automatically migrated to the new SmartThings Arlo Schema?

I uninstalled and reinstalled arlo linked service in my smartthings hub and now none of my cameras are recognized as motion sensors. I cannot set ST to armed as it says I do not have any devices. It suggests I add a device, and re-adding the alro cameras does nothing through this interface either. How are you getting the motion trigger to push from arlo to ST? I have both Arlo and Arlo Pro cameras.

1 Like

@arlo_eng, Well finally, Arlo has a new Video Doorbell with a built in battery coming soon. Will it be the same as the current Arlo Video Doorbell for compatibility with this new SmartThings Schema? But like the previous comments about the current Arlo Doorbell camera, hopefully Arlo/SmartThings will add the Motion sensor and Doorbell button to the integration.

1 Like

Hi @DaWeav - yes, we will provide out-of-the-box support for wire-free video doorbell. As soon as we enable support for doorbell button integration it will be for all supported doorbell types.

2 Likes

Hello Adam, I have the video doorbell connected to my SmartHub. Will the video doorbell also work in Smartthings if connected directly to my WiFi?

Hi @Mdterps, yes video doorbell integration is supported in either mode (SmartHub-connected, or direct to WiFi).

2 Likes

Thank you! This new integration has been great. For my video doorbell, I no longer have the on/off toggle within the iOS Arlo app (it is there on the android Arlo app). I was hoping to be able to use the on/off toggle in smartthings automations. Is it possible to have this added to the integration for the video doorbell?

@SmartThings @shravan @arlo_eng
Any update when existing Arlo users (like me) will be migrated to this new SmartThings Arlo Schema?

1 Like

We are planning a safe migration specially as the holiday timeframe is around. We are currently in beta testing mode internally and we are tentatively commencing on the migration early december. Exact date is not derived yet as the testing is occurring and issues that may arise will cause change in dates that we are targeting for internally.
I will talk to our support team to identify the notification path for users to be let known of before the migration occurs. We are targeting for a seamless migration - a way that the user will not be affected at all. But we also understand that there can be edge cases for certain users (customized setup) that may affect the seam less experience we want to provide with this migration.

3 Likes

I recently started controlling my Arlo Pro 3 with ST. I’m noticing an issue that I’m not sure how to address. I hope someone here can offer suggestions or tell me what I’m doing wrong.

I use ST to turn cameras on/off through certain scenes. The integration is working and turning them on/off as intended, but, after being turned off and back on (through ST) the cameras act as if they aren’t armed and don’t pick up motion about 50% of the time . Again, they show to be on in ST and in the Arlo app they show to be on and armed. My only solution to this issue is to disarm and arm them again in the Arlo app and they start motion notification again…?

1 Like

Hi @Mdterps, glad you are enjoying the new integration. I may be wrong but I don’t believe we ever had the on/off toggle for doorbell (we only have silent mode toggle), since the intention is to always have this device online.

I noticed today that my ST app was behaving a bit different. I was using both the classic and new app up until last night. I deleted the classic app because ST was not recognizing when I left the house. I figured the new classic app might be sending conflicting information to the hub. After I deleted it, the presence sensor (my phone) seemed to begin working correctly. Then I noticed that even thought the automations were triggering, the status of the Arlo was not changing. I had read previously here that the smartthings mode would no longer work with the update. What mode should the Arlo cameras be set in to work with ST’s presence sensor? I should also mention that the ST app shows the cameras are “armed” but the Arlo app shows they are “currently disabled and will not respond to mode changes”.

@jmorris718 can you please confirm if you have installed the new integration after deleting the classic app? or using the old integration (i.e you have not onboarded Arlo integration from scratch recently)

The SmartThings mode should continue to work for the cameras even with the new and old integration.
when armed, the motion events will be received proactively. the on/off will then turn on/off the privacy mode for the specific cameras where it’s supported.

if you are interested in using the new integration , please follow the below steps. Also note that the older Arlo integration in the “linked services” section of the ST app would need to be deleted which will also delete the devices associated with the older integration. once you onboard the new integration, the automations and scenes will have to be reset

Thanks for letting us know of this case. we shall try to reproduce this issue with our devices and get back with an update soon.
Are you seeing this issue only occur for the Arlo pro 3 cameras?

ok so i deleted the smartthings mode. I deleted the Arlo link from ST. Then I deleted both apps. Re-installed both apps… followed the migration instructions… re-linked Arlo. But now I cant add any cameras to the STHM. When I click add sensors it goes to the location screen as if I am adding the cameras all over again. Also no smartthings mode in Arlo.