New SmartThings App now completely broken (Outage 14 Jan 2021)

So I just tried to open my SmartThings app. It opens and hangs permanently on the splash screen. The menu is there, but nothing works. Tried killing the app and restarting it. Did not work. Restarted my iPhone complete. Same result. So glad you forced the crappy new version of the App on us riddled with bugs. Now I cannot control any of the 30+ devices in my home. The old app worked perfectly. I have had nothing but trouble with the new app and now it is completely broken. This is one of the worst business decisions I have seen from any company. What a piece of shit app. Any suggestions for a better hub and app to migrate to would be appreciated. After months of pain, I am tired of this BS.


There’s a post on the status page right now that there are problems, so it’s not just you:

As for alternatives, every platform has pluses and minuses and different ones will work for different people. See the following section of the forum:

The New app has been so-so since its launch. As you open the app, mine takes several seconds to identify the status of devices.

And this outage is a big deal- when you have automations of a fireplace running, or exterior/interior lighting set up (near sunset right now) and nothing working.

True, every app has its pro/cons, but times like this makes users want to gravitate to other platforms. I’m so heavily invested in ST that it makes it hard to leave.

1 Like

This is crazy. Again messing it all up? Lost control of everything without warning. Any way I can avoid these updates in the future?

Totally with you here. To me it feels like every time they make “upgrades” they mess up more than what they improve.

Yeah, I thought that too back when smartthings failed three different ways and left me stuck outside my house in the rain with no way to get in (I’m quadriparetic and use a wheelchair).

That’s when I came to the conclusion that I needed a more reliable system even if it meant giving up support of some complexity and some devices.

1 Like

Looks like it’s coming back up. My background color on the app has changed, and I have one motion detector that’s stuck “in motion” which can cause all sorts of trigger issues.

Now, hopefully I will be able to reset it via the IDE.

1 Like

Unfortunately, no. The design of the smartthings architecture does not allow individual customers to either delay or defer updates. :disappointed_relieved:

There are other competing platforms that do run most things locally and do let you defer updates, including Hubitat, HomeKit, and Abode, so it’s technically possible, but it’s just not the way that smartthings has chosen to go.


Thanks. I am glad all my bulbs are Lifx and my shades have manual override but this is not the first time these changes have messed things up for me in the last 4 months. It’s more frustrating every time instead of the other way around.

I would consider migrating to something like Homekit. My issue is I have lots of z-wave devices, which homekit does not support natively, so I would have to have another bridging technology to get them into the Homekit environment.

1 Like

That’s part of my issue. I have many zigbee and zwave devices with the purpose of using with Smartthings. The automation capabilities have been the reason for this but if it keeps having these issues it just makes me think about changing again.

SmartThings Cloud outages are why my own important automations on the platform are done in Smart Lighting, which runs locally on the hub is unaffected. I’d never use Automations or their new Rules API because the foundation of their system (the SmartThings cloud) just isn’t reliable. Of course, I’m migrating everything over to Hubitat, which also runs locally.

If you go for any home automation platform to replace SmartThings, make sure it all runs locally for handling local devices.


I agree generally, but you can actually put together a pretty decent simple home automation system based on Alexa routines. Even though it’s mostly cloud-based, my experience over the last three years has been that it’s much more reliable than you might expect. It has easily met my minimum six months MFOP (maintenance free operating period) requirement.

And If you get one of the echo models that has a zigbee hub inside you can even get some limited local operation, including voice control. As I’ve mentioned before, I use that as my “Plan B“ to give me some voice control of the pathway of lights from my room to the front door even if the Internet is out.

I do generally choose devices which work with both HomeKit (which is local, except for voice control) and echo (because I prefer its voice recognition), but speaking just for myself, I prefer to state my requirements in terms of quality of service, such as MFOP, rather than a technical description like “local.“ There are unstable local systems and there are surprisingly stable cloud-based systems. I’m more concerned about how reliable it’s going to be every day. :sunglasses:

1 Like

App control is still completely messed up for me (1/15/2021 8:30 AM EST). The app landing/home page reset to a random assortment of items, none of which I intentionally have visible normally. And every time I re-launch the app, the list is different and sorted differently.

The STHM tile is missing entirely on the landing page, so I’ve had no visibility into my security and leak sensors for almost 15 hours. The devices and sensors STHM is supposed to be using are only occasionally showing up in Devices view (which also keeps resetting sort order, and truncating the list by like 80% most times I load it).

Really, really, really fed up with ST right now. :face_with_symbols_over_mouth:


define re-launch… is that sign out/sign in r force quitting the app. if it is sign out/sign in, then your dashboard will be rearranged each time from any changes you had made.

click edit under the 3 dots in the upper left of the screen to see if STHM appears there.

1 Like

Only several seconds? Count yourself lucky! Mines takes anywhere from 30 seconds to a minute. :man_facepalming:t5:

I automated mines as well and have all kinds of fail safes but still reliant upon the “cloud”. Still have manual overrides though.


First time in a long time my home went haywire. :face_with_symbols_over_mouth: I almost unplugged the Hub but saw on the status page that ST was having issues. Didn’t last that long and all is well now. Actually, things seem more snappier. :face_with_monocle:

App is still slow as hell. :man_facepalming:t5:

I really miss Classic. I have a blend of Hubitat and ST and Hubitat has its share of issues as well.


still appear to be issues… 90 percent of my devices/rooms disappeared again

update… 2 minutes later they reappeared

1 Like

In addition my App keeps resetting the arrangement and filtering of the sensors on the home page. I had to fix it yesterday and I see they messed up again this morning.

1 Like

I have no flipp’n idea what they’ve done. I thought things were correct last night, but, AGAIN- today I have multiple door sensors showing ‘open’, and space heaters 'running, yet say they’re ‘OFF’ in the app.

This is the most frustrated I’ve been with ST- and most seems to have happened since the roll-out to the new app.

Completely unacceptable given that, if I were not home, I’d have all sorts of lights triggered on with doors showing ‘open’ and God knows what my indoor temps and energy usage would be with space heaters, thermostats, and fireplace running!!