New Smart things app rapidly going offline then online repeatedly

Why is this happening. I just migrated from the old app to this new one and set it up on my phone. It worked fine while I was setting it up and now that’s all it does. I’ve added people in my family that had the old smartthings installed and it’s doing the same thing on their end. I can’t seem to find anything in the community on this so I thought I’d ask.

-5 people in my family (me and 4 others are experiencing this)
-I’ve power cycled the smartthings hub
-I have Smartthings V2 hub
-router is Google WiFi, latest router, latest firmware
-All phones in the house are Pixels with the exception of 1 iphone 8 plus and they all do the same thing.
-I’ve tried it on an Android and iOS tablet and it did the same thing

Please help

Try disconnecting from the WiFi and use a cellular network. If that still doesn’t solve the problem when it’s an issue with the SmartThings mobile server most likely and you should report this to

Other people have also reported it, but I don’t know if there’s a fix:

Devices going off and on after "upgrade" from Classic