(New Release) Edge Driver Z-Wave Sensor and Child Thermostat Mc [BETA]

You can also try with the rear action button by holding down for 3 sec activates the wake up with an interval of 10 minutes

Action Button: Press and hold for 3 seconds
Enable/disable wake up for 10 minutes.
(When it is enabled, the orange Led will fast blink)

New version of Z-Wave Sensor and Child Thermostat Mc

────────────────────────────────────────────────────
 Name         Z-Wave Sensor and Child Thermostat Mc
 Version      2023-01-07T20:17:16.372296714
────────────────────────────────────────────────────

Improvements:

  • Added option for single or multiple mosaic of virtual child thermostat. It allows the new version 1.7.93.26 of the Android App to not fail and close with multiple mosaics, selecting by default single tile

By default, when the new version is installed, a simple mosaic is assigned with which the app will work without having to delete the virtual thermostat

1 Like

Thanks! This immediately fixed the Smartthings Android app crashing that I’ve experienced over the last few days.

1 Like

New version 6 of the Z-Wave Sensor and Child Thermostat Mc driver.

Improvements:

  • To adapt the driver to the HUB firmware libraries, the LAN type Child devices are replaced by the EDGE_CHILD type.
  • Everything will work the same way as old version.
  • This improve the operation performance and facilitates future updates since it uses the resources of the default libraries of the Hub.
  • This update will be done manually so that each user can do it when they see fit, since the LAN-type child devices will have to be deleted and recreated as CHIL_EDGE type. There is no rush, do it when you can, everything will continue to work
  • HUB smart Wifi users, who have libraries lower than 45.x should not change to this new driver since their HUB firmware libraries do not support CHILD_EDGE devices. They must wait for their hub to be updated.

IMPORTANT: HOW TO UPDATE DRIVER AND NOT LOSE THE ROUTINES OF THE CHILD DEVICES:

  • Wait for your current installed version to be Z-Wave Sensor and Child Thermostat Mc-(OLD)
  • Install the new version of the driver Z-Wave Sensor and Child Thermostat Mc
  • The routines of the real devices are not lost nor do they have to be modified.
  • Procedure to facilitate the modification of child device routines:
    • Without deleting the child Devices, change the driver from the Z-Wave Sensor and Child Thermostat Mc-(OLD) to the new VERSION Z-Wave Sensor and Child Thermostat Mc.
    • The child devices created will stop working and will keep all the routines. You can rename them to easily identify them.
    • With the new driver: Create the new Child devices you need.
    • Enter to the old Child devices menu Routines: Edit every routine and add the new child device and delete the old one.
    • Save the edited routine, which will go to the list of the new child device.
    • Once all the routines have been modified, delete the old child devices.
  • The version of the old driver will be renamed Z-Wave Sensor and Child Thermostat Mc-(OLD) and the new one Z-Wave Sensor and Child Thermostat Mc
────────────────────────────────────────────────────
 Driver Id    351974e8-d7de-46cb-a34f-92cc1371f80e  
 Name         Z-Wave Sensor and Child Thermostat Mc 
 Package Key  zwave-sensor-child-v6
 Version      2023-01-10T12:19:00.291710532
────────────────────────────────────────────────────
1 Like

@Mariano_Colmenarejo, following the steps of your excellent documentation, I’ve successfully completed the update procedure on my two thermostats and uninstalled the old driver from my hub.

N.B. I use SharpTools rules instead of SmartThings routines. Adding the new child device to an existing rule’s trigger worked just fine.

I have SharpTools rules that turn off the thermostat after a time of motion inactivity. Adding the new child device to an existing rule’s action of β€œsetThermostatMode with argument(s): [β€œoff”]” wouldn’t give me a thermostat mode pull-down list. I had to (easily) create a new action within the rule, then delete the old action.

2 Likes

Hi Mariano,
thanks a lot for your edge drivers! I’ve got four Eurotronic Spirit Z-Wave Plus thermostats, that I haven’t been able to get recognized with your z-wave Thermostat driver. Could you please try to incorporated them? As far as I know they use the Standard z-wave protocol (i attached screenshots from the Manual regarding commands, sorry about the Order, the third ist the First page). I would appreciate this a lot. Would you need additional data about the device?
Cheers and a good sunday
Robert



Hi @Robrit

Are you try with this driver

I had infact not, sorry for my inability to properly use the search function and thanks for the quick, friendly reply! All 4 of the thermostats now work with Edge drivers, thanks! :+1:

1 Like

Hi @Mariano_Colmenarejo,
First of all, thanks for your great work. I’ve been using your drivers and virtual thermostats for a few months. I’d like to ask a question if you don’t mind.
What is the effect of the Β« Select radiant floor and type Β» on the behavior of the thermostat?
I’ve read the information you gave for v2 of the Zibgee driver but it seems to have no effect when I try to use it. My radiant floor has a huge inertia so I’d like to configure the thermostat to start heating as soon as the temperature dips below the set point and stop heating as soon as the temperature starts to rise again but I don’t really understand how to configure both the radiant floor and the differential temperature settings to avoid a large difference between the lowest temperature and highest temperature.
Kind regards.

Hi @Joffrey_Heyraud

When you do not have underfloor heating selected then driver use this formula:
If you have a device.preferences.diffStartStop of 0.6ΒΊC and the heating setpoint = 20ΒΊC

Stop temperature (pending Heat status): > 19.7ΒΊc

  • device(β€œheating_Setpoint”) - (device.preferences.diffStartStop / 2)

Starting temperature (Heating state):<= 19.4ΒΊc

  • device(β€œheating_Setpoint”) - device.preferences.diffStartStop

When you have underfloor heating selected, then driver Use this formula:
If you have a device.preferences.diffStartStop of 0.6ΒΊC and the heating setpoint = 20ΒΊC

Stop temperature (pending Heat status): > 19.7ΒΊc

  • device(β€œheating_Setpoint”) - (device.preferences.diffStartStop / 2)

Starting temperature (Heating state): <= 19.55ΒΊc

  • (device(β€œheating_Setpoint”) - (device.preferences.diffStartStop / 2))- 0.15ΒΊc

If your system has a lot of thermal inertia, but it does not exceed the set point excessively, I would try lowering the differential to 0.2ΒΊc:

  • Stop temperature (pending Heat state) would be: > 19.9ΒΊc
  • Starting temperature (Heating state) would be: <= 19.75ΒΊc

You can check these values in the capability info panel.

If it still does not adjust to what you need because it exceeds the set point a lot when it stops, tell me and I will try to change something

Hi Mariano,

Thanks very much for the detailed reply. In the meantime, I have understood why I thought the radiant floor setting had no effect. It seems the Info Panel does not always refresh immediately. Sometimes I need to exit the tile and open it again to get the Info Panel information updated.
I will try new settings as per your suggestion and will get back to you.

Kind regards.

1 Like

The last versiΓ³n refresh infoPanel when any preference change value

Ok noted, thank you.

Hi @Mariano_Colmenarejo

Is there any chance for you to add temp/humidity offset settings? I would like to be able to calibrate these.

Thanks for the great work.

1 Like

The virtual thermostat has independent temperature compensation adjustment in its profile.

The real device depends on the model.
The zwave usually have the adjustment with some configuration parameter, so the stock profiles do not usually have compensation adjustment.

The zigbee all have compensation in the profile

I think that nothing would happen if the temperature and humidity compensation is added to the profile, since the compensation is not done by the driver, it is done on the platform together with the change of units from Β°C to Β°F

If you tell me which device it is, I’ll add it as soon as I can.

It is a Monoprice 4-1 Zwave Plus

Mfg Code	0109-2021-2101
Model	2021-2101
ocf Type	x.com.st.d.sensor.motion
Category	MotionSensor
Presentation ID	6cc97fe3-144f-33af-8552-fb30fab382d3
Type	ZWAVE
1 Like

Hi @mrfitz98
Added in this driver version the temperature and humidity compensation in your profile preferences

────────────────────────────────────────────────────
 Name         Z-Wave Sensor and Child Thermostat Mc 
 Version      2023-01-26T15:19:06.181740445
────────────────────────────────────────────────────

Works great, thank you!

1 Like

Hi @Mariano_Colmenarejo,

So as you kindly suggested I tried to set the differential temperature to 0.2 degrees with my radiant floor. It behaves better than 0.5, thank you. It overshoots the set point by around 0.6 degrees but I think it is ok. FYI, heating control in my house is tricky fir 2 reasons:

  1. the water-based radiant floor has a lot of inertia
  2. the house is extremely well insulated
    As a consequence, the inertia is not really bad with regards to the Β« heating start Β» level because the temperature dips very slowly. So even if the heating system is slow to produce heat, it’s not a big deal as the temperature will not decrease much in the meantime. On the contrary, it is a bigger problem for the Β« heating stop Β» level. Once the floor gets warm, the temperature will keep rising for a long time even in case heating is switched off soon after the temperature starts rising.

By the way I noticed a behavior that is a bit annoying. I use the Β« Lock Β» function when I want to force a specific mode (e.g. Eco or Away) that will not be changed by my cyclic time-based routines. However, I noticed that sometimes the thermostats get Β« magically Β» unlocked without any human or routine action. Do you have an idea about how it could happen? Could it be linked to driver updates?

Kind regards.

Hi @Joffrey_Heyraud

Thanks for reporting this issue.

I found and fixed the bug, which was in the automation to lock the thermostat when Away or Manual mode is selected.

I have corrected and published it on the zwave thermostat, then I will correct it on the zigbee

It Will be updated automatically