(New Release) Edge Driver Z-Wave Sensor and Child Thermostat Mc [BETA]

Yes, I do realize that. I was hoping you could change the default to save me some time every time I have to recreate the device. :slight_smile:

I think that anybody using this driver with voice control of the thermostat device would prefer the name to be more natural (at least in English), with β€œthermostat” at the end.

@Mariano_Colmenarejo, I have two problems with the sensor device that I haven’t yet mentioned because I first wanted to get the thermostat functioning correctly.

  1. The motion timeout is 60 minutes, not matter what I set the Delay Time to be in Settings. I’ve tried changing to the Aeotec Multisensor 6 driver and to your Z-Wave Config driver to change the setting and then changing back to this driver, but I can never make the setting stick.

  2. The Power Source pane is always blank. It should say USB.

This part of the code is exactly the same as the stock driver.
If the stock doesn’t work, this one won’t work either.
I see capability powerSource is not declared in driver template.
I can put some debug log and see some log that you send by removing and turning on the power to see what the device is sending.

I assume you mean 60 seconds instead of 60 minutes.

This part is also identical to the stock driver and will not work on the stock driver either.

  • I have seen that the initial configuration that it sends to the device is 20 sec, which is the default value in preferences.
  • I have also seen that the code has an error, both the stock and mine, which is a copy. Incorrectly sends values of the initial configuration.
  • The changes in preferences send them well, but the device may be asleep and you have to wake up device when you send the preference change.

I have made a version correcting the error in sending the configuration and I am going to force it to be configured when installing the new version, which by default only does it when the device driver is paired

Please, Install this driver version ans attempt to capture the logs.
I will see tomorrow, i am going to sleep :zzz:

────────────────────────────────────────────────────
 Driver Id    b88307ad-ed36-42fb-81b0-c9875e1bd25f  
 Name         Z-Wave Sensor and Child Thermostat Mc 
 Version      2022-11-22T22:34:07.813809801
────────────────────────────────────────────────────

Thank you Mariano. I’ll report it as not working. I tried the stock beta and it’s doing the same thing. It just won’t close.
By the way, I’m using a couple of your other drivers and they are awesome. I really appreciate your work.

1 Like

Thanks, I will report that this isn’t working in the stock driver to SmartThings Support.

I do mean 60 minutes (3600 seconds).

OK, I will see what happens with the updated driver and let you know. Update: That seems to have fixed the motion problem. I set it to a 30 sec delay and it’s resetting in about 45 seconds to a minute – a bit sluggish.

It is also sluggish to register detected motion in the app. I haven’t monitored the CLI log to see if the event shows up immediately, but I will.

Curious, I installed the beta stock driver, switched the device to it, switched back to your driver, and now the Power Source displays correctly.

Yes, I found the driver bug when I was seeing a problem with fibaro open close and corrected it, I forgot to say

this is the problem in case @nayelyz wants to report it.
The can_handle of the aeotec-multisensor subdriver compares with manufacturer, productType and productId and there are only fingerprints for manufacturer and productId

local AEOTEC_MULTISENSOR_FINGERPRINTS = {
  { manufacturerId = 0x0086, productId = 0x0064 }, -- MultiSensor 6
  { manufacturerId = 0x0371, productId = 0x0018 }, -- MultiSensor 7
}

local function can_handle_aeotec_multisensor(opts, self, device, ...)
  for _, fingerprint in ipairs(AEOTEC_MULTISENSOR_FINGERPRINTS) do
    --if device:id_match(fingerprint.manufacturerId, fingerprint.productType, fingerprint.productId) then
if device:id_match(fingerprint.manufacturerId, fingerprint.productId) then
      return true
    end
  end
  return false
end
1 Like

Thank you for sharing this, @Mariano_Colmenarejo.
I just reported the error to the engineering team.

2 Likes

@Mariano_Colmenarejo, I have seen behaviour where the thermostat Info Panel and State continues without change even though I’ve changed the Heating Temperature.

An example is below, where I decreased the Heating Temperature to 22.5 from 23.5 but the Info Panel and State of β€œHeating” remained unchanged even as you see that the reported Temperature exceeded the Heating Temperature.