(New Release) Edge Driver Z-Wave Sensor and Child Thermostat Mc [BETA]

This answers my question. Thank you.

Thank you also for the routines examples and screenshots.

These are SmartThings routines that I have found to work:

  • Turn on the heater when the thermostat state is heating
  • Turn off the heater when the thermostat state is β€œpending heat”
  • Turn off the heater when the thermostat state is β€œidle”

I use SharpTools rules which can combine the second and third into one rule.

2 Likes

You don’t need to use Sharp tools to do this.
With a simple routine you can do:

@Mariano_Colmenarejo, I don’t see where your routine turns off the heater when the thermostat state is idle.

@Mariano_Colmenarejo, I have a different problem which has been happening since the beginning. Humidity is not being displayed from my multisensor. Should it be?

@Mariano_Colmenarejo, I have another request.

I own 2 Oomi Multisensors from fantem.com, which are basically Aeotec Multisensor 6’s. When I try to delete one and readd it to SmartThings – so that it picks up the Aeotec edge driver – it gets readded with the DTH. I suppose that’s because it’s reporting with a different mfgr code.

Here’s its string:

zw:L type:2101 mfr:016A prod:0102 model:0064 ver:1.06 zwv:4.05 lib:03 cc:5E,86,72,59,85,73,71,84,80,30,31,70,7A,5A`

Here’s a real Aeotec’s string:

zw:L type:2101 mfr:0086 prod:0102 model:0064 ver:1.10 zwv:4.54 lib:03 cc:5E,86,72,59,85,73,71,84,80,30,31,70,7A,5A

I’d like to use your driver for this device. Is this something that you can add to your driver so that it’ll be discovered?

@BartschLabs

The humidity is not shown, it is an error of the first version. If you clear the app cache it should go away.

In the future, if everything works well, I may implement the profile with humidity for the devices that support it.

Added as Aeotec multisensor 6 in this driver version. Try it

──────────────────────────────────────────────────── 
 Name         Z-Wave Sensor and Child Thermostat Mc 
 Version      2022-11-14T09:29:29.053444128
────────────────────────────────────────────────────
  - id: "016A/0102/0064"
    deviceLabel: Oomi Multipurpose Sensor
    manufacturerId: 0x016A
    productType: 0x0102
    productId: 0x0064
    deviceProfileName: aeotec-multisensor-6
1 Like

That caused it to be discovered.

If I’m having trouble with functionality of one or more of the sensor’s capabilities, would I ask on the z-wave sensor thread and get them to fix it there? For instance, motion detection is not working probably because one of the sensor’s many settings is not exposed for me to set in the device in the app.

Update: Never mind. I found another of your excellent edge drivers that allows me to set z-wave settings not exposed by the usual drivers.

It did not.

Hi @BartschLabs

Then I will modify the driver.
sorry, I forgot to add the fingerprints to send the initial configuration and the two preferences parameters of profile. :man_facepalming:
That may have caused it to not work well, although it should have kept the configuration it had with the DTH.

Update: Initial Configuration and preferences fixed in this version

────────────────────────────────────────────────────  
 Name         Z-Wave Sensor and Child Thermostat Mc 
 Version      2022-11-15T09:47:25.441726399
────────────────────────────────────────────────────
1 Like

I have a Nortek/GoControl contact sensor that seems to work with your Z-Wave Sensor MC, but when it changes to Open state, it never changes back to Closed. I can see in the app a momentary blip when it’s closed, but it remains open. Any thoughts?

zw:S type:2001 mfr:014F prod:2001 model:0102 ver:4.84 zwv:3.67 lib:06 cc:71,85,80,72,30,86,84

Hi @Expose

This device is in smartthings stock beta driver Z-Wave Sensor
My driver for this device is the same as stock driver.
Please try if works fine with Smartthing stock Beta driver Z-Wave Sensor
If not works fine then need to report to @nayelyz to fix prior of the final migration

  - id: 014F/2001/0102
    deviceLabel: Nortek Open/Closed Sensor
    manufacturerId: 0x014F
    productType: 0x2001
    productId: 0x0102
    deviceProfileName: contact-battery-tamperalert

@Mariano_Colmenarejo, I see that there are now 37 thermostat modes that I can choose from, instead of a handful of modes.

Recently, if I ask Alexa to set the thermostat to heat, Alexa asks, β€œWhat do you mean by heat?” I try different responses, and eventually Alexa asks, β€œCan you tell me the exact value?”

If I ask Alexa to set the thermostat to auto, cool, or off, the thermostat mode gets set correctly.

Do you think all the new thermostat modes has anything to do with this?

Hi @BartschLabs

Of all the modes available in the capability thermostatMode, the driver has these 9 supported modes configured.
This is what you have to see in view of details, automations conditions and actions.(in englihs)

The modes that smartthings exposes to alexa I don’t know.

In fact the modes you see on my.smartthings.com are only the modes of the stock presentation.

The good news is that I figured out the β€œAlexa, set ___ thermostat to heat” problem. β€œHeating” is now the word to use. Alexa still responds, β€œIt’s set to heat,” even though β€œheating” is the new verbal command.

The not so good news is that this is what I see in the thermostat child device for modes.

Hi @BartschLabs

────────────────────────────────────────────────────
 Name         Z-Wave Sensor and Child Thermostat Mc
 Version      2022-11-22T18:10:13.772097618
────────────────────────────────────────────────────

It seems that the supported modes have not been configured correctly, I have modified the version to force the configuration of modes in the initialization.

You should see this in the logs when the driver is installed.

2022-11-22T18:08:06.420411251+00:00 PRINT Zigbee Temp Sensor and Child Thermostat Mc  << thermostat_Modes_Supported >>
2022-11-22T18:08:06.427285251+00:00 INFO Zigbee Temp Sensor and Child Thermostat Mc  <Device: 032e488a-9694-435f-a9f8-e101d3e2b90c (Thermostat-Environment Sensor)> emitting event: {"attribute_id":"supportedThermostatModes","capability_id":"thermostatMode","component_id":"main","state":{"value":["off","auto","eco","asleep","heat","cool","rush hour","away","manual"]}}

Prior to forcing an update of the driver, I solved the problem by deleting and recreating the thermostat device.

I’m still on this version of the driver:

1 Like

@Mariano_Colmenarejo, what do you think about making the default thermostat name be β€œsensor name Thermostat” instead of β€œThermostat-sensor name”?

This is the initial label for device create.
You can change the name as you want in app edit device

In CLI logs the new name assigned to device will appears some time after