(New Release) Beta Edge Drivers Z-Wave with more FIBARO devices:

This version of the driver tested by @fido fix the error of the start programmed sequences.

┌─────────────┬──────────────────────────────────────┐
│ Name        │ Z-Wave Bulb Mc                       │
│ Version     │ 2022-05-29T16:13:30.229238146        │
└─────────────┴──────────────────────────────────────┘
2 Likes

Absolutely brilliant to have the programmed sequences back in action, Police forms part of my house front security, Storm and fireplace are used at Halloween, thank you Mariano :grin:

3 Likes

Hi @Mariano_Colmenarejo , I’m using this driver with an Aeotec Nano Switch, it doesn’t report power, is that to be expected? I’m pretty sure the device itself can report power.

I can confirm it works for me also. Thanks so much for your hard work on this!! Top job!

1 Like

I have not touched anything about Aeotec, it is what is in the smartthings stock driver and It is their responsibility.

The nano switch model is not in the fingerprints, the nano dimmer is there, so nano switch will be paired as a generic switch.

2 Likes

Hello @Mariano_Colmenarejo .
Just needed to calibrate One of the blinds and it did not worked! Using the 28-04-2022 version.
On One of the previous versions it worked.
Now, we go to the calibraton-29 parameter and we cannot even select the calibrate option.

When we select the calibrate option, it stays like this:

If we press Ok it shows this message:

Can you please fix this?

Thanks.

Best Regards

Hi @andre_petinga
You have to click on the circle, it must be something that has changed in the latest version of the app

Ok, 2 things:

  • Yes, if I press the circle it does work.
  • The difficulty is to press the circle!! It only works when I press a little below, on the left of the circle. This happens on both options. Don’t know why…

Other users have also had problems with this, it must be some change in the latest version of the app.
I can’t do anything about this.

I don’t know if @nayelyz can clarify anything.

UPDATE: checked un Android versión 1.7.84.21, you can click on complete row, text included, and works fine

Yes, I think the problem must be with the app, because something similar happened with Google Chrome ,a few months ago…
My app version is higher : 1.7.86.21

@Mariano_Colmenarejo, please share with me the ID of that capability. In the meantime, I’ll ask if it is the expected behavior.

Hi @nayelyz,
It is not a capability, it is a preference with the enumeration type.
Before, in versions prior to 1.7.85.25 you could click anywhere on a line (row) and select that option.
Now you need to touch exactly on or near the point for that option to be selected

Ah, sorry. Got it, I already asked the team, I’ll keep you updated.

Update:

I made a test with an enumeration preference and I couldn’t replicate the issue:

@Mariano_Colmenarejo, can you share your definition of the preference, please?

1 Like

Hi @Mariano_Colmenarejo ,

How does the preference work?
I think once the user select “Start calibration” → “OK” then device start actual calibration.
Is the preference’s value changed to “Calibration not started” automatically after device’s calibration has done?

When you choose start calibration in preferences, the driver sends a parameter value to the device and saves the calibration status in memory with set_field.

The device starts the calibration and sends another parameter value indicating that it is started.

The driver reads that value and stores the current state of the calibration in memory.

When the device finishes the calibration it sends a parameter value indicating that it is done.

The driver stores that value in memory with set_field to remember it, since driver can’t dynamically change the value of the preference.
Then in preferences you will see the value you chose when starting.

If you want to start it again you have to choose, save the other value and choose start calibration again.

Some devices have only 2 values and others have 3 parameter values.

1 Like

@Mariano_Colmenarejo, can you share the definition of that device preference, please? Have you been able to replicate the issue mentioned by @andre_petinga?
I made a test with an enumeration preference and I can click on any part of the text to select it, or is this referring to the issue of selecting the option of “start calibration” again when it was previously selected?

Hi @nayelyz
I don’t have that device to test it, but I have tried in other enumeration preferences and it also works fine for me, as it does for you.
I hope @andre_petinga answers to clarify his problem.

Hi @Mariano_Colmenarejo and @nayelyz .
Just entered the app to try in other enumeration and works fine. Then, just went to the Calibration option and it works fine too!! I don’t understand what happened. The app version is still the same and I havent’ done anything to the phone… Like I mentioned, I have had this problem before, on Google Chrome, and it was a bug on a specific Google Chrome version.
In this case I don’t have any explanation :frowning:

Sorry…

1 Like