(New Release) Beta Edge Drivers Z-Wave with more FIBARO devices:

I tried again and this is what Hub found it

It has been paired with nothing in particular

This usually happens to me when the device is very far from the hub

Now it works perfectly again. I uninstalled edge drivers and unpaired and repaired device. Device paired as “Switch” with hubs internal driver or something. Edge drivers are not in use. But how long? Let see what happends in next few months, when edge drivers are forced to use.


image
image

Keyword for find purpose:
Aeon Labs Smart Energy Switch (for DSB06xxx-ZWUS/DSC24-ZWAU/DSC24-ZWEU)
Aeon Labs DSC06106

But did you try to do the same with the driver version that I modified?
That version sends the same configuration as the DTH.
You have to exclude the device, install only the modified driver and include the device again.

In the photo you send, is it without charge?, since it is on and does not measure power

Yes I tested the modified driver, but wattage/powervalues still not refreshing continously. SmartThings Driver (Beta) driver refreshed every time when pushed physical Switch button. I checked that new version was in use.

Whats interesting I uninstalled those two drivers below. After that also Z-wave Thing Mc and SmartThings Driver (Beta) disappeared. I dont know what happends there.
image

I can test modified driver one more time later this evening. Maybe there is some ghost data in Samsung Cloud.

Hi @lewisburgess,

I’m trying to replicate your settings but with a few minor HW differences.
I have some spare dimmer 2 units, so had hoped to re-purpose one as a smart button to trigger various events without a connected load.
I have a “centre off” retractive switch (MK K4900) with S1 connected to L1 and S2 connected to L2, Pushing in the top or bottom gives a momentary switch to either S1 or S2.
I have live & neutral at my FGD-212 so these are both connected directly, then the Sx, S1 & S2 are connected to Common, L1 and L2 of the switch.
I have tried to create a routing based on button 1 pushed (or button 2 pushed) but these do not seem to work.
There is no load connected to the Fibaro unit so not sure if this makes a difference?

I’m using the latest version of @Mariano_Colmenarejo drivers: 2022-09-23 with Z-Wave Switch Mc.

Thanks,
Declan.