(New Release) Beta Edge Drivers Z-Wave with more FIBARO devices:

Good evening.
You could add these two Fibaro devices:

  • Smart Module (FGS-214)
  • Double Smart Module
    (FGS-224)

Thank you

If you send me the fingerprints and if you know the different productId I can look at it and if it is not too complicated I will do it.
The hardest part will be the scenes.
I think that Fibaro on its website only advertises the single, double switch, plugs and dimmer 2 of the devices that are in the stock Beta driver Z-Wave switch as working with smartthings
I don’t think he intends to do anything

  • Smart Module (FGS-214) :
    zw:Ls2a type:1001 mfr:010F prod:0404 model:1000 ver:5.00 zwv:6.08 lib:03 cc:5E,55,98,9F,56,6C,22
    sec:25,85,8E,59,86,72,5A,73,5B,70,75,71,7A

@Mariano_Colmenarejo
Just incase these are ever useful here is the raw description of my Fibaro RGBW hardware driver (441)

Raw Description zw:L type:1101 mfr:010F prod:0900 model:1000 ver:25.25 zwv:3.52 lib:03 cc:27,72,86,26,60,70,32,31,85,33 epc:5 ep:[β€˜1101 26’]

Added Smart Module (FGS-214), mfr:010F prod:0404 model:1000 ver:5.00

  • Added the following settings parameters in preferences:
  FIBARO_SMART_MODULE_SINGLE = {
    MATCHING_MATRIX = {
      mfrs = 0x010F,
      product_types = 0x0404,
      product_ids = 0x1000
    },
    PARAMETERS = {
      restoreState = {parameter_number = 1, size = 1},
      switchType = {parameter_number = 20, size = 1},
      s1ScenesSent = {parameter_number = 40, size = 1},
      s2ScenesSent = {parameter_number = 41, size = 1},
      ch1OperatingMode = {parameter_number = 150, size = 1},
      ch1ReactionToSwitch = {parameter_number = 152, size = 1},
      ch1TimeParameter = {parameter_number = 154, size = 2},
      outputTypeQ1 = {parameter_number = 162, size = 1},
    }
  },

Try it and tell me if it works well or if something important is missing

driver version

β”Œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”¬β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”
β”‚ Name        β”‚ Z-Wave Switch Mc                     β”‚
β”‚ Version     β”‚ 2022-02-21T16:13:21.725323           β”‚
β””β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”΄β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”˜

Added old FIBARO WALL PLUG, FGWPx-102-EN-A-v1.00 (mfrs=0x010F, product_types = 0x0600, product_ids = 0x1000)

  • Added the following settings parameters in preferences
  FIBARO_WALL_PLUG_OLD_EU = {
    MATCHING_MATRIX = {
      mfrs = 0x010F,
      product_types = 0x0600,
      product_ids = 0x1000
    },
    PARAMETERS = {
      alwaysActive = {parameter_number = 1, size = 1},
      restoreState = {parameter_number = 16, size = 1},
      overloadSafety = {parameter_number = 70, size = 2},
      inmediatePowerReport = {parameter_number = 40, size = 1},
      standardPowerReports = {parameter_number = 42, size = 1},
      powerReportFrequency = {parameter_number = 43, size = 1},
      energyReportingThreshold = {parameter_number = 45, size = 1},
      periodicReports = {parameter_number = 47, size = 2},
      ringColorOn = {parameter_number = 61, size = 1},
      ringColorOff = {parameter_number = 62, size = 1}
    }
  },

driver version

β”Œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”¬β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”
β”‚ Name        β”‚ Z-Wave Switch Mc                     β”‚
β”‚ Version     β”‚ 2022-02-21T16:13:21.725323           β”‚
β””β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”΄β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”˜

Good evening.
It works well and there are all the parameters you need. Thank you

Now I just have to find where I put the Double Smart Module
(FGS-224) after removing it a few months ago

1 Like

I just tested the FGR-223 for the first time and it works pretty good. Thank you!
The calibration is working perfectly, and the only issue I’ve encountered is that I couldn’t find how to set the preset. it seems to default to 50%, but how do I change it?

1 Like

Hi @jahrin
I don’t know how the presets work, I don’t have a device to test it.
How did you use them with the DTH?

Hi @Mariano_Colmenarejo, this is actually my first time using the roller shutter so I wouldn’t know.
However, I went through all of the options and couldn’t find anything.

I’ll ask someone who uses DTH and let you know.

1 Like

Preset is a SmartThings mobile app concept and is set in the device settings in the mobile app usually.

1 Like

Thanks @Automated_House

I already saw it in the defaults
It is set by default to 50%
A preference can be added to customize the value device.preferences.presetPosition

@jahrin I’ll add it tomorrow and try it. Now it’s too late here

local PRESET_LEVEL = 50

local capability_handlers = {}

--- Issue a window shade preset position command to the specified device.
---
--- @param driver st.zwave.Driver
--- @param device st.zwave.Device
--- @param command table ST level capability command
function capability_handlers.preset_position(driver, device, command)
  local set
  local get
  local preset_level = device.preferences.presetPosition or PRESET_LEVEL
  if device:is_cc_supported(cc.SWITCH_MULTILEVEL) then
    set = SwitchMultilevel:Set({
      value = preset_level,
      duration = constants.DEFAULT_DIMMING_DURATION
    })
    get = SwitchMultilevel:Get({})
  else
    set = Basic:Set({
      value = preset_level
    })
    get = Basic:Get({})
  end
  device:send_to_component(set, command.component)
  local query_device = function()
    device:send_to_component(get, command.component)
  end
  device.thread:call_with_delay(constants.MIN_DIMMING_GET_STATUS_DELAY, query_device)
end
2 Likes

I have added in settings the preference device.preferences.presetPosition for the FGR-222 and FGR-223

  - name: "presetPosition"
    title: "window shade Preset Position"
    description: "This setting select window shade preset position command (0-100%)."
    required: true
    preferenceType: integer
    definition:
      minimum: 0
      maximum: 100
      default: 50

Added in this version

β”Œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”¬β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”
β”‚ Name        β”‚ Z-Wave Window Treatment Mc           β”‚
β”‚ Version     β”‚ 2022-02-22T10:15:13.887058           β”‚
β””β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”΄β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”˜
4 Likes

Thank you! it works perfectly!

2 Likes

Added to the stock Beta Z-Wave bulb driver all the settings parameters for the Fibaro RGBW Controller FGRGBWM-441-EN-A-v1.1 (mfr:010F, prod:0900, model:1000, ver:25.25 )

Driver Z-Wave Bulb Mc Version:

β”Œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”¬β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”
β”‚ Name        β”‚ Z-Wave Bulb Mc                       β”‚
β”‚ Version     β”‚ 2022-02-23T16:01:08.988561           β”‚
β””β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”΄β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”˜
  - id: Fibaro_RGBW_Controller/EU
    deviceLabel: Fibaro Light
    manufacturerId: 0x010F
    productType: 0x0900
    productId: 0x1000
    deviceProfileName: fibaro-rgbw-controller

The Stock beta driver does not have a Switch capability on the main component and to turn it on and off you have to open device details view and turn the White and RGB switches on or off.

At the request of another user, I have added a General switch to be able to turn everything on and off from the device tile or with voice assistant.

You tell me how it works

1 Like

Thank you Mariano, i will try this as soon as i can, my 441 was installed long before Samsung decided to drop groovy which means i have to remove an exterior access panel outside to reset the device, i tried power on off 3 times but it failed to exclude so a hardware reset is required before re inclusion

#update (The good)
Hardware exclusion by pushing b button on the 441 and re inclusion and subsequent connection to Marianos driver worked well

Due to the way Smartthings presents options Mariano is limited on how he codes the device which in turn limits the way the Fibaro RGBW drive works

All basic colours are presented as a RGB switch and white is presented as another switch

To control both white and RGB Mariano has a button that switches both on and off at the same time

(The bad)
If you buy a 441 or 442 chances are you buy them for there special firmware colour options, Marianos driver does not expose these special options
Fire place
Storm
Deep fade
Light fade
Police
Are not available which is a real pity, instant colour picking can be achieved by using a virtual device to switch on or off a chosen colour but that can be achieved by any RGB controler

Conclusion
All in all Marianos driver works for basic control, if Fibaro never make a proper driver the device will continue to function if and when groovy is killed, however the special colour options which these devices are used for will not be available

Hello @Mariano_Colmenarejo.
Thank you for this Z-Wave drivers!!!

I have 6 Fibaro Roller Shutter 2 (FGR-222)

Can you confirm that you have the following fingerprint in this drivers?

zw:L type:1106 mfr:010F prod:0302 model:1000 ver:25.25 zwv:3.52 lib:03 cc:8E,72,86,70,85,73,32,26,31,25,91,75 ccOut:32,31,91,2B,26,25

And another thing.
What do I have to do to change from DTH to Driver? Just delete the device in the app, remove DTH and Search for device again? Or do I need to access the Fibaro models and press any button there???

Thanks in advance!

Yes, that is the model that is included

  - id: FibaroRollerShutter2
    deviceLabel: Fibaro Window Treatment
    manufacturerId: 0x010F
    productType: 0x0302
    productId: 0x1000
    deviceProfileName: fibaro-roller-shutter-2

To install it:

  • Install the driver in the Hub
  • If you have a custom DTH you will have to edit the DYH in the IDE and disable the Fingerprint of the device by typing // in front of the fingerprint.
  • Exclude the device from the app, you will have to press 3 times quickly the button connected to S1
  • Install device by adding new device and search nearby.
  • put the device in inclusion mode, pressing 3 times quickly the button connected to S1.
  • I would not exclude all the devices at the same time, I would do it by excluding and installing one by one
1 Like

Ohhh. I think o have to find another way to exclude and include… My buttons are toggle, not momentary. So when I press up the button stays. And only if I press Stop, then the button returns to initial position.

Exclude STILL works with toggle switches, and include.

another way to do it

You would have to press 3 times quickly the B button of the device

this is the link to the manual