(New Release) Beta Edge Drivers Z-Wave with more FIBARO devices:

Quick Question about the Fibaro-FGS223 integration that got includes in the official channel
I used it to add a double switch to the network but in the app all i can see is only 1 device for the main switch.
Is that how it is suppose to work ?
I want to be able to control both lights separately.
It seems that the driver itself allows for as i see main and switch 1 and can open them separately.
Is there any way to create a device from the second channel as the official DHT does it?

Just create a virtual switch for Switch 1

1 Like

I added 4 Zooz Zen 72 Dimmers and 1 Zen 71 Switch this week, I already have 3 Zen 72’s installed using @krlaframboise Zooz ZEN72 700 Dimmer VER. 1.0.1 DTH.

I was surprised after I was finished and went to edit the names that they had all installed using @Mariano_Colmenarejo Z-Wave Switch Mc

I do not have // in front of the of the fingerprint line as described below.

“If you’re currently using my Groovy DTH for the device then you’ll need to either uninstall the DTH or put // in front of the fingerprint line near the top of the code because the ST onboarding process only looks at the installed Drivers if it’s unable to find a matching fingerprint in a custom Groovy DTH.”

Has the Edge driver priority changed?

Just curious/pointing out my observations.

I don’t know if anything has changed or not.

The Mc driver just like the stock beta driver has two generic fingerprints for switch and dimmer, that may be the reason why it is paired to the driver instead of the DTH

How do I do it with EDGE drivers?
it would make no sense to use the API to do it if the plan is to disable the API at the end of the day.
Can anyone share a guide ?

Here are links to two virtual device drivers, I use the one by @TAustin , so I cannot comment on the second one.

This Works great
Thank you very Much.
I would still prefer if this child will be created when the Driver finds the new device but this is a nice workaround.
Thank you @NickA for your help

If it is for a dual FGS223 switch, I would use the stock driver from the smartthings beta channel.
I would only use the Z-Wave switch Mc driver if you also have devices that are not included in the stock driver.

The stock driver Z-Wave switch will be updated automatically until the beta phase ends and the definitive version comes out.

  • Just install the stock driver on your hub.
  • Enter the device details view
  • Go to menu 3 points, top right and select driver
  • Select to use another driver. It will propose the compatible ones, the stock Z-Wave switch
  • Click on use this driver and wait 1 minute for it to install

You only have to change the settings that you have modified in preferences.

I’d like to sincerely thank you for your work, and for work I didn’t think would, or could ever be done. I know manufacturers would prefer users to upgrade and spend even more money on new devices, instead of this, you have breathed new life into once obsolete devices, it’s nothing short of remarkable. In two years you’ve done demonstrably and quantifiably more to help users than anyone else on the forum since it started. Even more so is the selfless way and lack of renumeration and praise needed, that make your efforts so sublime. It’s hard to quantify just how much money you’ve saved me personally, and as a community, both in devices and in batteries (with your ground breaking power reporting tweaks of local devices). There are too many impactful ways you’ve helped to mention, also without the physical device itself to work on or enjoy yourself, like the Fibaro RGBW Controller with it’s inbuilt animations like “Fireplace” and “Storm” that are finally able to run locally for the first time ever!

7 Likes

Thank you for your words!!

I am glad to know that this is useful for other users of the community :+1:

2 Likes

Good Evening.
Have you tried to implement the fibaro motion sensor driver?

Fibaro Motion Sensor ZW5 :

zw: Ss type: 0701 mfr: 010F prod: 0801 model: 1001 ver: 3.02 zwv: 4.05 lib: 03 cc: 5E, 86,72,59,80,73,56,22,31,98,7A sec: 20 , 5A, 85,84,71,8E, 70,30,9C

Hi @GiacomoF,
This one is among the half-done in the stock beta Z-Wave Sensor.

They’ll post it soon I think!

1 Like

The Fibaro Single Dimmer seems to be working much better now. S2 is working perfectly and being able to distinguish between on/off with pressed/held for a physical toggle switch means I can very easily set up a local automation to control other non-load devices from this toggle switch. This is really, really good.

I have noticed for S1 that there is no setting to synchronise with the physical switch. The Fibaro’s have parameter 22 to control this. This would mean, for a single physical switch installation that down is always on and up is always off, instead of acting like a 2-way switch with the Fibaro being the ‘hidden’ 2nd one. (Of course, this means if the physical switch is down and the lights are off, then toggling it up would mean they’d stay off and then would only come on if toggled down).

Would it be possible for you to expose this in your driver, rather than having to use a Z-Wave tweaker?

Otherwise, I don’t know what’s changed since the last time I tried this a few weeks ago with the same dimmer, but it’s so much better now. Reliable, working correctly from what I can tell and the S2 is great!

Oh, and whether this is a driver thing or a ST thing, it seems this works properly when both buttons are toggled together or very similar times. This didn’t work very well with the DTH + scene control + WebCore (it was quite unreliable anyway, but especially if both buttons were pushed together).

Thanks.

Yes, I added 2 buttons to be able to execute with automations and scenes the actions sent by S1 (Button1) and S2 (Button2) when activating parameter 28, sending scenes, according to the table in the manual.

the only thing that didn’t work well is that S2, by default also controls the load connected to S1 and it shouldn’t. I already reported it to @nayelyz

I have added parameter 22 for the option to synchronize the device state with the mechanical switch.

The changes are in this version

┌─────────────┬──────────────────────────────────────┐
│ Name        │ Z-Wave Switch Mc                     │
│ Version     │ 2022-03-06T10:45:23.484229           │
└─────────────┴──────────────────────────────────────┘

Hmm, I’m no longer seeing the issue of S2 controlling the attached load.

Mine is working correctly with:

Switch type: Toggle
Double click: activated
Function of 3-way: disabled for S2
Scene Activation: Activated
On-Off mode disabled

I’ve just updated the driver to the 2022-03-06 version and set parameter 22 to sync. This works.

The only thing I’ve noticed is occasionally the device in app shows the dimmer as 1% when off but rises to 100% when on. This is on-screen only, not what is physically observed. It’s not consistent.

Otherwise, this driver is now working very well for my Fibaro Dimmer 2 (‎FGD-212) with a double physical toggle switch, S1 controlling the local load (only) and S2 controlling the scene activation via ST (only).

Excellent!

1 Like

@lewisburgess,
Fibaro dimmer2, Fixed a bug in buttons actions assignments for scenes S1 and S2 being swapped.

  • button1 for scene values (S1) 10 and 11
  • button 2 for scene values (S2) 20 and 21

values 10 and 20 (OFF to ON), correct action now: Pressed
values 11 and 21 (ON to OFF), correct action now: Held (Relesed)

┌─────────────┬──────────────────────────────────────┐
│ Name        │ Z-Wave Switch Mc                     │
│ Version     │ 2022-03-08T16:21:50.425239           │
└─────────────┴──────────────────────────────────────┘
1 Like

Thanks, I hadn’t noticed this but I will check my rules.

I have been asked privately by another person about my settings for my Fibaro devices. I’ve copied the reply here in case it helps others and it is relevant to this thread.

I am seeing different behaviour between the Fibaro Dimmer and the Fibaro Single Switch. This is the same with both the stock Edge Z-Wave Switch (2022-02-23) and @Mariano_Colmenarejo’s version (2022-03-06T18:26:15). I generally use Mariano’s drivers because they are more complete and better.

The Dimmer is ‎FGD-212. The Single Switch is ‎FGS-213.

The IDE does not show the details of software versions for these as I’m using Edge drivers. It just shows a placeholder. I do have the Smartthings CLI but I can’t see a way of grabbing the device model/software version info in this way. It’s not exposed in the live logs either.

The dimmer is on a standard double toggle switch. My whole house was re-wired 3 years ago and I have 3-wire with the live presented at the wall switch. This means the modules are all behind the switches, not in the ceiling (there’s no permanent live in the ceiling, only switched).

I connected the toggle switch COM to Sx on the module. I’ve bridged COM between switch 1 and 2 on the rear of the physical switch. From the left switch, L1 goes to S1, and on the right switch, L1 goes to S2.

With the Dimmer, S1 controls the local load. S2 does not control the local load at all. There is scene activation set. However, with @Mariano_Colmenarejo’s driver, it shows as a button state. This means I can use a routine to control other devices (Ikea Zigbee bulbs in my case (using Edge drivers FWIW)) via the hub. Pushed = off, Held = on.

With the Single switch (non dimming), it’s pretty much the same, but I have noticed that while S1 and S2 controlled physically, operate as expected. S1 controls the local load and S2 controls the scene. However, in both the stock and @Mariano_Colmenarejo’s drivers I have noticed a ‘bug’ (not reported) which shows the device in the app itself is switched on/off when S2 is toggled, although the actual local load is not turned on/off. So it’s a visual bug. For me, it’s not a big problem as my specific usage for this switch is quite basic and this doesn’t cause me an issue - but the bug will annoy me if it’s not fixed. I think this is a ST thing, not Mariano.

Finally, I also have a Fibaro Double Switch. This is more of a problem because ST have decided that child switches are not presented as separate devices in the app. There’s separate comments about this, here: [ST Edge] Issues with multi-component devices and third-party integrations - #9 by lewisburgess

Some screenshots from both the Fibaro Dimmer:






Screenshots from the Fibaro Single switch:






2 Likes

I’ve updated to this version in the CLI and checked my routines on my Fibaro Dimmer (see my previous post above) and I haven’t noticed any difference in behaviour.

Down = on = Held
Up = off = Pressed

I didn’t have to change anything for some reason.

The driver version with changes is this.

In the screenshots the version is 2022-03-06

You can see what the dimmer sends by viewing the button in the app and pressing s2

May also have to see parameter 22 value.
The dimmer is supposed, send the value 20 when it goes from Off to On and 21 when S2 goes from On to Off.

Now for the value 20 it sends Pressed and for 21 it sends Held

In the fibaro single and double switches I do not modify any. The code Is same of stock driver

The screenshots were taken before the update and testing.

I’ll test some more, but it seems to be ok.

1 Like