(NEW RELEASE) Beta Edge Driver Zigbee Light Multifunction Mc

Added to this driver version

┌─────────────┬──────────────────────────────────────┐
│ Name        │ Zigbee Light Multifunction Mc        │
│ Version     │ 2022-06-17T18:59:44.964821147         │
└─────────────┴──────────────────────────────────────┘
  - id: "ZB-CL01/eWeLight"
    deviceLabel: eWeLight RGBW
    manufacturer: eWeLight
    model: ZB-CL01
    deviceProfileName: rgbw-level-colortemp-2700-6500
1 Like

Thanks Mariano!

1 Like

Hello,

Driver Zigbee Light Multifunction Mc Updated the presentations of the Custom Capabilities with the alternative values for the state button and I have changed the displayType:ToggleSwitch for displayType:switch, which seems more appropriate, leaving the power button only for on and off.

The driver version is the same and the presentations will be updated when clearing the cache in android and when reopening the app and each device once or twice and it will show the new switch buttons.

If there is any problem please tell me

1 Like

Can you ad

Ledavance gu10 rgbw 2000-6500

  • application: 01
  • endpointId: 01
  • firmwareFullVersion: 00103101
  • firmwareImageType: 48
  • firmwareManufacturerCode: 4489
  • manufacturer: LEDVANCE
  • model: PAR16 RGBW Z3
  • zigbeeNodeType: ROUTER
    Raw Description 01 0104 010D 01 0A 0000 0003 0004 0005 0006 0008 0300 0B05 1000 FC0F 01 0019

Added to this driver version

┌─────────────┬──────────────────────────────────────┐
│ Name        │ Zigbee Light Multifunction Mc        │
│ Version     │ 2022-06-26T20:24:06.570181871        │
└─────────────┴──────────────────────────────────────┘
  - id: "LEDVANCE/PAR16 RGBW Z3"
    deviceLabel: LEDVANCE PAR16 RGBW Z3
    manufacturer: LEDVANCE
    model: PAR16 RGBW Z3
    deviceProfileName: rgbw-level-colortemp-2000-6500
1 Like

Vi

Have this problem with the new driver version

Its a Lidl rgbw bulb

There is a problem with timer in sec and change mode.

It was not an issue with the older version

I have 2 Lidl RGBW bulbs and they work fine.
It may be the problem with the refresh of the app.
Try to clear the cache of the app or if it does not solve it, have a reboot of the Hub from IDE

Hi. I tried as mentioned. Both my Lidl e14 rgbw and the ledavance gu10 rgbw has the same issue.

There is no problem with my Lidl cct bulbs.

If i return to version 5, the problem is gone.

Those capabilities are changed to have more color changing modes.
It should be solved with a clear cache or a reboot of the hub

@Kristian_Horup
It may be the problem of the app, if the capablitity is not initialized with a value.
Try setting a value to those capabilities with an automation and it will resolve.

For example

When I have access to the cli I will modify the driver to set a value when the driver is changed

I can not change the settings… there is only af cloud with a mark.

I tried both reboot from hub and deleting cashe…

It worked momentaraly… if I try to reset til connection in the bulb it loads

But shortly hereafter this occurs

Those broken clouds are the app refresh problem.
You exit the device and enter again and it comes out fine.


performs the automation to set a value in those 2 functions and the problem is solved.
Now I can’t modify anything, I don’t have access to the cli

@Kristian_Horup,

This date version of driver fix the problem with new app version and capabilities without value assigned.

┌─────────────┬──────────────────────────────────────┐
│ Name        │ Zigbee Light Multifunction Mc        │
│ Version     │ 2022-06-27T11:06:51.719654002        │
└─────────────┴──────────────────────────────────────┘
1 Like

Ikea bulbs work with this too.

@Mariano_Colmenarejo

Hi, hope you are doing well?

I have an issue with a zigbee led strip controller device you added into an edge driver for me a while back. Sorry if this has already been addressed.

  1. GLEDOPTO ZigBee LED Strip Controller RGBww/cw
  2. I have 3 of these with the same issue.
  3. Driver: Zigbee Light Multifunction Mc Ver-2022-06-27
  4. Issue: If dimming action is made from an automation in either WW/CW, the dimming action is hit or miss. Example: If lights are at 20% brightness, and an automation calls for 100%, the lights may or may not set to 100%. What usually happens is they will flash to 100% then return to 20%.
  5. Strange thing is tho, if I make dimming changes from the ST app, or Alexa, the lights respond perfectly.
  6. I have double checked my automations to make sure there’s no duplicate commands.

Thank you for your help.

Hello, @MICHAEL_DUNCAN

I have not been able to reproduce the problem.
I’ve tried various automations with two different devices, setting a new level with different previous levels, and turning the device from on and off.

How exactly is your routine?

Is the device On or Off before automation set?

Do you have progressive On or Off activated?

Do you have set transition times > 0 for level or On-Off in preferences?

In the routine, does only the level change or also the Activated command?

If you send only the level, the driver will take care of turning on the bulb if it is off.