(NEW RELEASE) Beta Edge Driver Zigbee Light Multifunction Mc

Thanks. Bulbs working perfectly :slight_smile:

Coming from webcore, I now have to redo all my automations using edge.
All my smart bulbs (mostly Globe brand) are non-zigbee, only Wifi.
Is there an equivalent of this driver for WiFi-only devices?
I can’t seem to find a way to do simple things such as changing a bulb to a random color using edge :frowning:

There are no Edge Drivers for the Tuya/Smart Life family of devices which includes Globe Electric and dozens of other companies. The ones that work with ST all use official cloud to cloud (c2c) integrations. These are part of the new architecture and should continue to work. The problem is as you noted the features available in ST are limited. The integration is owned by Globe so ask them about improvements.

I have a weird issue with the GLEDOPTO, model GL-C-008 (I have 2 of them, they both show the same behavior). Everything works except turning it on with the power button. It’ll turn on if I change the dim level, color temp or pick a color, but not with the ON command. Off works. Thoughts?

Hi @neod192

I write it down and until Friday I will not be able to modify it

1 Like

Could you please add this?

  • application: 46
  • endpointId: 01
  • manufacturer: _TZ3000_obacbukl
  • model: TS0503A
  • zigbeeNodeType: ROUTER

Thanks

for some reason i am getting an error when i try to join use the invite. i have joined others. not sure why this isn’t working

SmartThings. Add a little smartness to your things.

Hi @fredd0

I have read something in other threads about problems to join several channels

1 Like

Nothing to do with this particular edge driver, it’s a platform problem affecting many channels. :disappointed_relieved: See the current active discussion thread:

Unable to join channels (25 Jan 2023)

2 Likes

Thanks for the info - it’s also working now

1 Like

Hi Mariano,

I have similar problems with the GL-C-008. ON/Off is generating problems. Setting the dim level works fine. Would be very nice if you can find a solution.

Thanks!

@WolframF @neod192

Fixed in this driver version

───────────────────────────────────────────────────
 Name         Zigbee Light Multifunction Mc         
 Version      2023-01-26T13:08:40.255016754        
───────────────────────────────────────────────────
2 Likes

Thanks! Looks like it worked :slight_smile: You’re our hero!

Hi Mariano,

Could you please add Woox RGB Zigbee Bulb (R9077)?

Details:
Data * application: 50

  • endpointId: 01
  • manufacturer: _TZ3000_keabpigv
  • model: TS0505A
  • zigbeeNodeType: ROUTER
    Raw Description 01 0104 010D 01 08 0000 0003 0004 0005 0006 0008 0300 1000 02 0019 000A

Thank you.

Hi @dusarik000 @pustelnik

Added to this driver version

───────────────────────────────────────────────────
 Name         Zigbee Light Multifunction Mc           
 Version      2023-01-26T23:30:55.998773104        
───────────────────────────────────────────────────
- id: "_TZ3000_keabpigv/Woox"
    deviceLabel: Woox TS0505A
    manufacturer: _TZ3000_keabpigv
    model: TS0505A
    deviceProfileName: rgbw-level-colortemp-2700-6500
  - id: "_TZ3000_obacbukl/TS0503A"
    deviceLabel: Woox TS0503A
    manufacturer: _TZ3000_obacbukl
    model: TS0503A
    deviceProfileName: level-rgb
1 Like

THANK YOU SO MUCH!!! Your driver works great set to 2 seconds to fade between brightness levels and on/off for my Sengled Zigbee 100W A19 Smart Bulb 2700K bulbs ! This is the sort of functionality I was missing with our smart bulbs!

2 Likes

Thank you very much :smile:
Your driver handles Woox bulb very well.

1 Like

I have a device that keeps using a default driver that is not EDGE. Maybe you can add this to your driver?

Description: Giderwel RGB+Cold White+Warm White full Color LED Flexible lightstrip Tunable Cold White to Warm White(2700K-6000K)

  • endpointId: 01
  • manufacturer: _TZ3210_eejm8dcr
  • model: TS0505B
  • zigbeeNodeType: ROUTER
    Raw Description 01 0104 010D 01 09 0003 0004 0005 0006 1000 0008 0300 EF00 0000 02 0019 000A

Also, I have one GLEDOPTO device that whenever I go to check it it says 'This device hasn’t updated all of its status information yet." Has been saying this for a week now. It seems to be working properly but seems like something is wrong. Any suggestions?

name: rgbw-level-colortemp-2700-6500
deviceManufacturerCode: GLEDOPTO
manufacturerName: SmartThingsCommunity
deviceModel: GL-C-008

Thanks!

@Mariano_Colmenarejo

Excellent work! I do notice the drivers are quite sluggish though, particularly when turning the active colour changing to β€˜inactive’ and when dimming. Turning lights off/on in comparison is pretty fast. I use my phone/aeotec wallmotes to switch scenes and to dim by level, compared the the new default edge driver and my prior smartapps, there are certainly a few seconds when dimming all lights and minutes when turning off the colour changing. Do you have any recs. to speed scene/dimming changes?

Hi @ASP

Delays when using scenes or routines with multiple devices at the same time is not a driver problem, any driver will do the same, they all work the same.

It is a problem with the execution of these scenes or routines on the new platform, I don’t know how they are going to solve it, if there is a solution.

There is a thread on this topic, I can’t find it now